User Manual

Network Management System
Industrial HiVision 7.0
The naming of copyrighted trademarks in this manual, even when not specially indicated, should not be taken to mean that these names may be considered as free in the sense of the trademark and tradename protection law and hence that they may be freely used by anyone.

© 2016 Hirschmann Automation and Control GmbH

Manuals and software are protected by copyright. All rights reserved. The copying, reproduction, translation, conversion into any electronic medium or machine scannable form is not permitted, either in whole or in part. An exception is the preparation of a backup copy of the software for your own use.

The performance features described here are binding only if they have been expressly agreed when the contract was made. This document was produced by Hirschmann Automation and Control GmbH according to the best of the company's knowledge. Hirschmann reserves the right to change the contents of this document without prior notice. Hirschmann can give no guarantee in respect of the correctness or accuracy of the information in this document.

Hirschmann can accept no responsibility for damages, resulting from the use of the network components or the associated operating software. In addition, we refer to the conditions of use specified in the license contract.

You can get the latest version of this manual on the Internet at the Hirschmann product site (www.hirschmann.com).

Hirschmann Automation and Control GmbH
Stuttgarter Str. 45-51
72654 Neckartenzlingen
Germany
Contents

1 The Management Tool 11
1.1 Integration of third-party devices 12
1.2 Enhanced auto-topology discovery 13
1.3 MultiConfig™ for network installation 14
1.4 MultiConfig™ for live operation 15
1.5 Engineered through experience 16
1.6 30 days free trial 17

2 Installation 19
2.1 System Requirements 20
2.2 Installation 22
2.2.1 Downloading the Industrial HiVision software 24
2.2.2 Installation under Windows 25
2.2.3 Installation under Linux 27
2.3 Update 30
2.3.1 Updating under Windows 30
2.3.2 Updating under Linux 31
2.4 Maintenance 32
2.5 Starting 33
2.5.1 Starting under Windows 33
2.5.2 Starting under Linux 35
2.6 Deinstallation 36
2.6.1 Deinstallation under Windows 36
2.6.2 Deinstallation under Linux 36

3 Preparation 39
3.1 Improving the security of Industrial HiVision 40
3.1.1 Physical protection 40
3.1.2 Measures before and during the installation of Industrial HiVision 41
3.1.3 Industrial HiVision configuration actions 43
3.1.4 Restrict File Access 48
3.2 Outside the program 50
3.3 Network structure 51
### Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.3.1 Advantages of the hierarchical network structure</td>
<td>51</td>
</tr>
<tr>
<td>3.3.2 Application Example</td>
<td>52</td>
</tr>
<tr>
<td>3.3.3 Configuration of the application example</td>
<td>54</td>
</tr>
<tr>
<td>3.3.4 Status display of the subdomains</td>
<td>57</td>
</tr>
<tr>
<td>3.4 Program default settings</td>
<td>58</td>
</tr>
<tr>
<td>3.5 Using Industrial HiVision with Firewalls</td>
<td>61</td>
</tr>
<tr>
<td><strong>4 Interface of the program</strong></td>
<td><strong>65</strong></td>
</tr>
<tr>
<td>4.1 Main window of Industrial HiVision</td>
<td>66</td>
</tr>
<tr>
<td>4.2 Menu bar</td>
<td>68</td>
</tr>
<tr>
<td>4.2.1 File</td>
<td>69</td>
</tr>
<tr>
<td>4.2.2 Edit</td>
<td>70</td>
</tr>
<tr>
<td>4.2.3 View</td>
<td>70</td>
</tr>
<tr>
<td>4.2.4 Configuration</td>
<td>72</td>
</tr>
<tr>
<td>4.2.5 Tools</td>
<td>74</td>
</tr>
<tr>
<td>4.2.6 Help</td>
<td>75</td>
</tr>
<tr>
<td>4.3 Tool bar</td>
<td>76</td>
</tr>
<tr>
<td>4.3.1 Edit mode</td>
<td>77</td>
</tr>
<tr>
<td>4.3.2 Preferences</td>
<td>78</td>
</tr>
<tr>
<td>4.4 Event line</td>
<td>79</td>
</tr>
<tr>
<td>4.4.1 Number of events</td>
<td>80</td>
</tr>
<tr>
<td>4.4.2 Types of events</td>
<td>81</td>
</tr>
<tr>
<td>4.4.3 Acknowledge events</td>
<td>82</td>
</tr>
<tr>
<td>4.4.4 Properties of an event</td>
<td>83</td>
</tr>
<tr>
<td>4.5 Folder frame</td>
<td>84</td>
</tr>
<tr>
<td>4.6 Navigation field</td>
<td>86</td>
</tr>
<tr>
<td>4.7 Detail display</td>
<td>87</td>
</tr>
<tr>
<td>4.7.1 Detail display – Topology</td>
<td>87</td>
</tr>
<tr>
<td>4.7.2 Detail display – List</td>
<td>88</td>
</tr>
<tr>
<td>4.7.3 Detail display - Devices</td>
<td>90</td>
</tr>
<tr>
<td>4.7.4 Detail display - Ports</td>
<td>92</td>
</tr>
<tr>
<td>4.7.5 Detail Display – Links</td>
<td>94</td>
</tr>
<tr>
<td>4.7.6 Detail display - Properties</td>
<td>95</td>
</tr>
<tr>
<td>4.7.7 Detailed display - Security Status</td>
<td>97</td>
</tr>
<tr>
<td>4.8 Event list</td>
<td>98</td>
</tr>
<tr>
<td>4.9 To navigate with the Keyboard</td>
<td>101</td>
</tr>
<tr>
<td>4.9.1 Navigating in a table</td>
<td>101</td>
</tr>
<tr>
<td>4.9.2 Changing the frame</td>
<td>101</td>
</tr>
<tr>
<td><strong>5 Creating a network plan</strong></td>
<td><strong>103</strong></td>
</tr>
</tbody>
</table>

User Manual  Industrial HiVision
Release 7.0  09/2016
Contents

5.1 Device detection 104
  5.1.1 Device Icons 106
5.2 Assigning device icons 107
5.3 Device arrangement 109
  5.3.1 Creating a network plan 109
  5.3.2 Moving devices into the network plan 110
  5.3.3 Creating new devices 111
  5.3.4 Arrange devices in the detail display 113
  5.3.5 Naming devices and ports 114
  5.3.6 Copying devices 114
  5.3.7 Devices with multiple IP addresses 115
  5.3.8 Creating a link 115
5.4 Device connection 117
  5.4.1 Automatically displaying the topology 117
  5.4.2 Connecting devices manually 118
  5.4.3 Reshaping a connection line 118
  5.4.4 Specifying the line thickness 119
  5.4.5 Other connections 120
  5.4.6 Detecting a link to another folder 120
  5.4.7 Specifying connection properties 121
  5.4.8 Link types 122
  5.4.9 Representation of the connection medium 123
5.5 The Network changing over time 124
  5.5.1 Adding devices with HiDiscovery 124
  5.5.2 Adding devices with network scan 125
  5.5.3 Adding devices manually 125
  5.5.4 Startup procedure for Hirschmann devices 126
  5.5.5 Interrupting device monitoring 126
  5.5.6 Removing devices 127
  5.5.7 Exchanging devices 127
5.6 Network Documentation 129
  5.6.1 Saving Industrial HiVision projects 129
  5.6.2 Saving reporting data 129
  5.6.3 Exporting the content of the detail display 130
  5.6.4 Printing the content of the detail display 130
  5.6.5 Exporting the event list 130
  5.6.6 Printing the event list 131
  5.6.7 Creating device documentation 131
  5.6.8 Printing or exporting the MAC/IP address assignment 132
  5.6.9 Printing or exporting the status configuration 132

6 Configuring the network 135
6.1 Using the dialog box 136
6.1.1 Description of the menu tree 137
6.1.2 Description of the object frame 137
6.1.3 Description of the function frame 138
6.1.4 Description of the control elements 140

6.2 Examples for using the multi-configuration 141
6.2.1 Same contact person on multiple devices 141
6.2.2 Software update on similar devices 143
6.2.3 Restarting multiple devices 144
6.2.4 Loading/saving the configuration for multiple devices 145
6.2.5 Configuring a trap destination on multiple devices 147
6.2.6 Saving support info for multiple devices 148
6.2.7 Configuring firewall rules on multiple devices 149
6.2.8 Configuring the Industrial HiVision property 152
6.2.9 Saving reference values for each device 152

7 Monitoring the network 153
7.1 Improving security on the network 154
7.1.1 Password-protecting devices on your network 154
7.1.2 Security status view and configuration 155
7.1.3 Security-related settings of devices on the network 156
7.1.4 Configuring security-relevant settings on the network 158

7.2 Status configuration 162
7.3 Status determination 163
7.3.1 Trap destination address 164
7.3.2 Updating device status 164

7.4 Status propagation 165
7.5 Management actions 167
7.5.1 Event actions 167
7.5.2 Time-linked actions 168
7.5.3 Industrial HiVision “I'm alive” event 168

7.6 Time-related recordings 169
7.6.1 History 169
7.6.2 Reports 170

7.7 User-defined properties 173
7.7.1 Description of user-defined properties 173
7.7.2 Application example for user-defined properties 173

7.8 Effect on system resources 176
7.8.1 Detecting utilization of system resources 177
7.8.2 Influencing utilization of system resources 178
7.8.3 Minimizing polling 179
7.8.4 Minimizing network load 180

7.9 Process visualization systems 181
Contents

7.9.1 Link to process visualization system 181
7.9.2 Structure of the transfer data for OPC 183
7.9.3 Connection as ActiveX control element 186
7.9.4 Supported applications for ActiveX 187
7.9.5 Supported applications OPC DA 187
7.9.6 Supported applications OPC UA 187

7.10 Remote access to Industrial HiVision 189
7.10.1 Web access to Industrial HiVision 189
7.10.2 App access to Industrial HiVision 192
7.10.3 Certificate for the https connection 196

8 References 199

8.1 File 200
8.1.1 New project 201
8.1.2 New 201
8.1.3 Connect... 203
8.1.4 Open 203
8.1.5 Save 203
8.1.6 Save as... 204
8.1.7 Save Backup 204
8.1.8 Load Backup 205
8.1.9 Export... 206
8.1.10 Export Events... 206
8.1.11 Print 207
8.1.12 Printing the event list 207
8.1.13 Exit and Stop Service 207
8.1.14 Exit 208

8.2 Edit 209
8.2.1 Undo 209
8.2.2 Redo 209
8.2.3 Edit mode 209
8.2.4 Switch to the free version 210
8.2.5 Cut 210
8.2.6 Copy 211
8.2.7 Paste 211
8.2.8 Paste as link 211
8.2.9 Delete 212
8.2.10 Rename 212
8.2.11 Select all 212
8.2.12 Acknowledge Status Change 212
8.2.13 Manage 213
8.2.14 Unmanage 213
8.2.15 Set devices and port names 213
8.2.16 Set default device Icon 214
8.2.17 Device Documentation 214
8.2.18 Drawing Size 214
## Contents

8.2.19 Background image 215  
8.2.20 Search 216  
8.2.21 Auto Topology 217  
8.2.22 Auto Layout 220  
8.2.23 Properties of a folder/device 221  
8.2.24 Properties of a component detail 227  
8.2.25 Properties of a connection 233  
8.2.26 Adding a component detail to a port 235  
8.2.27 Add to reporting 236  
8.2.28 Device and Port Signaling 238  

8.3 View 240  
8.3.1 Select VLAN 240  
8.3.2 Refresh VLANs 240  
8.3.3 Protocol Statistics 241  
8.3.4 Filter Events for Object 242  
8.3.5 Back 242  
8.3.6 Forward 243  
8.3.7 Up 243  
8.3.8 Home View 243  
8.3.9 Set Home View Settings 243  
8.3.10 Geographical Location View 244  
8.3.11 Zoom 244  

8.4 Configuration 245  
8.4.1 Monitor 245  
8.4.2 PSM Manager 247  
8.4.3 Reporting 248  
8.4.4 Scheduler 252  
8.4.5 Preferences 258  
8.4.6 Status configuration 313  
8.4.7 Scan Ranges 315  
8.4.8 User defined properties 317  
8.4.9 Multi-configuration 318  
8.4.10 MAC/IP List 319  
8.4.11 Refresh 320  
8.4.12 IP Configuration 321  
8.4.13 Trap destination 323  

8.5 Tools 325  
8.5.1 Dashboard 325  
8.5.2 Web interface 342  
8.5.3 Device configuration 343  
8.5.4 CLI 344  
8.5.5 SNMP browser 345  
8.5.6 Ping 345  
8.5.7 HiDiscovery Scan 345  
8.5.8 Scan Network 346  
8.5.9 Demo network 347
1 The Management Tool

Wherever individual network components are to be combined to create an overall system, Industrial HiVision 7.0 is the ideal solution for configuring and monitoring the administrable Hirschmann devices, including switches, routers, EAGLE20 firewalls, wireless BAT units and products from various manufacturers.

Designed for effective industrial supervision, Industrial HiVision can be easily integrated into SCADA applications. It offers a built-in SNMP to OPC server. The graphical user interface is available as an ActiveX control.

**Note:** Regarding security
An attacker can spoof SCADA systems which can lead to unauthorized access to ActiveX Native. Hirschmann OPC technology uses Distributed COM (DCOM) from Microsoft, to communicate between hardware and software. To help protect access to ActiveX Native and the OPC server, configure access rights with a DCOM configuration tool.

Hirschmann recommends that you do not use ActiveX Native.
1.1 Integration of third-party devices

Of course, network management software from a specific manufacturer of network components is optimized for operating these components. In comparison, a generic, manufacturer-independent network monitoring system will only provide superficial product integration. However, in the real world, networks are usually a heterogeneous environment with devices from multiple manufacturers.

Industrial HiVision makes it easier for the network administrator to also integrate non-Hirschmann products, as long as they are administrable. This applies to components of the network infrastructure as well as field devices. Managed products have a range of standard characteristics that can be monitored, such as the device status. In addition, the direct standard interface can be used to enter further device-specific information, such as the long-term history and status messages. You decide for yourself how detailed the monitoring of your application is to be.

Advantages:
- Monitoring and trend mapping for administrable devices from any manufacturer
- Status display for your entire system
- Comprehensive network monitoring using a single network management system.
1.2 Enhanced auto-topology discovery

To monitor an industrial network reliably, precise knowledge of the network topology is essential. The network administrator should know how and where which devices are linked to each other in order to manage a complex network efficiently and perform any maintenance measures that are required.

Existing customers are already familiar with the intuitive Industrial HiVision user interface. This allows rapid visualization of the network topology. The standardized LLDP protocol is used to scan network infrastructure components and the received information allows Industrial HiVision to build a representation of the network connectivity. End devices such as PLCs, I/O, and HMIs are also detected and their location is accurately depicted on the graphical topology map.

Industrial HiVision software enables you to detect unmanaged switches and hubs and display their position within your network diagram. The software is also able to determine the network topology of devices which are located behind a router. This results in an increased level of topology detail.

Because industrial networks evolve over time, documentation can easily become out of date. The auto-topology discovery function assists you to know what is connected where in your network.

Key benefits:
- Network maps are created automatically, without manual intervention
- Topology maps are very accurate
- Network documentation is up to date
1.3 MultiConfig™ for network installation

Many network infrastructure devices require identical configuration parameters. But those parameters will differ from one network to the next. Which redundancy protocol is required? What is the temperature threshold of the devices? Where is the time server located? Should the web interface be disabled for live operation? To which management station should alarms be sent? Should unused ports be disabled? The list goes on and on.

Configuring devices individually is a tedious task. A misconfiguration on a single device can be very difficult to find. As a result, Site Acceptance Tests will be prolonged or the network may be inoperable. MultiConfig™ helps prevent these issues from happening.

The configuration tool allows you to configure the same parameters across multiple devices simultaneously and it also shows you where there is an inconsistency between parameter configurations. It works across different types of devices, where those devices have parameters in common. MultiConfig™ allows you to save multiple device configurations, both locally and to a server, without touching each device individually.

Key benefits:

- Reduced network installation time
- Network infrastructure configuration consistency
1.4 MultiConfig™ for live operation

Throughout a network’s lifetime operation, it is necessary to carry out repetitive but essential maintenance tasks. The threat of cyber attacks means that responsible network administrators will change device passwords regularly. Technology innovations can have great benefits for your network and your company, but to take advantage of them you will need to update your device firmware. And in the worst case scenario, if your network breaks down, your support organization will need immediate access to the current configuration files and event logs of your network devices.

Of course, for a small network, the above can be done by accessing each device individually. But for both small and large industrial networks, network security and availability are the ultimate goals. MultiConfig™ can fulfill the above requirements with a few clicks of a mouse. As a result, network administrators can meet their daily objectives with less effort and minimal disruption.

Key benefits:
- Highest network availability.
- Least effort required for network administration and maintenance.
- Minimized operational disruption.

Note: If you change user access parameters on a device that contains identical SNMP, WEB- and CLI access parameters, then the changes are applied simultaneously to the 3 access modes.
1.5 Engineered through experience

Industrial HiVision 7.0 is the fourth generation network management software from Hirschmann. We have built on our experience with previous releases to evolve a product which is unique in the industrial space. Industrial HiVision 7.0 encompasses the features and benefits of earlier versions. These include:

Key benefits:
- Client/Server architecture
- Web browser client
- Edit and Run modes
- Network hierarchy display
- Global and individual status display and propagation
- Flexible event handling
- Customizable data acquisition
- Long-term trending
- Comprehensive export functions
- Asset Management
1.6 30 days free trial

As a network administrator, you need cutting edge tools to help you meet your targets. Hirschmann is famous for innovation. We are committed to evolving Industrial HiVision to match our new hardware functionality, meet the requirements of our customers, and exceed the demands of the Industrial Ethernet marketplace. Everybody knows, seeing is believing. Words cannot do justice to network management software. Download Industrial HiVision, and test it free of charge for 30 days at your convenience. Of course, longer evaluation periods are available on request. The current version 7.0 of Industrial HiVision is available for download at www.beldensolutions.com.
2 Installation

This chapter describes

- The prerequisites for installing and operating the software
- Installing the software
- Updating the software
- Maintaining the software
- Starting the program
- Deinstalling the software

You will find requirements for operating the software in the appendix (see on page 20 “System Requirements”).

**Note:** Regarding security
Industrial HiVision helps to protect the edit mode of the user interface by requesting a password. When you login to your network management station as an administrator and start the user interface of Industrial HiVision, then Industrial HiVision allows you to switch directly to the edit mode. You can thus avoid having to enter a password.

**Note:** Regarding security
The Industrial HiVision database contains the information for your Industrial HiVision project. Hinder the access to this file by means of selected access rights for the directory `<installation directory>\database`. 
2.1 System Requirements

To install and operate Industrial HiVision you require:

■ Hardware
  ▶ Processor
    x86 compatible CPU, 1 GHz minimum
  ▶ RAM
    from 2 GB with 32-bit processors
    from 4 GB with 64-bit processors
    Industrial HiVision requires approx. 500 MB free memory. Another 500 kB RAM is required for each detected agent. The network management unit also requires RAM for the operating system and any additional applications.
  ▶ Disk space
    2 GB free.
  ▶ Monitor resolution
    at least 1024x768 pixels.

■ Operating system
  ▶ Windows 7 (64 Bit)
  ▶ Windows 8.1 (64 Bit)
  ▶ Windows 10 (64 Bit)
  ▶ Windows Server 2008 R2
    Do not use as a Windows server. Verify that the Share Point Services, Exchange Server and Active Directory are uninstalled
  ▶ Windows Server 2012 R2
    Do not use as a Windows server. Verify that the Share Point Services, Exchange Server and Active Directory are uninstalled
  ▶ PC Linux
    64 Bit: Kernel 3.10, libc 6 (released for Debian 8)
    64 Bit: Kernel 3.10, libc 6 (released for Red Hat 7.2)
License
License keys for Industrial HiVision depend on the number of devices you want to monitor. You can get license keys for 16, 32, 64, 128, 256, 512, 1024, 2048 and 4096 devices.
2.2 Installation

Industrial HiVision consists of a number of components. A background service performs in large parts the work.

This service has a close connection to a database containing the relevant data for the settings of Industrial HiVision and the devices to be monitored. When you reboot Industrial HiVision, Industrial HiVision gets the configuration data from the database which were current when you last quit the program.

**Figure 1:** Architecture

1 - SNMP Get/Set/Trap, HiDiscovery, Ethernet/IP, Modbus/TCP, Ping, http, https
2 - http, https
The program Industrial HiVision, which you call up directly on the screen, maintains a connection with the background service, from which it gets the required data.

You can install Industrial HiVision additionally to a former release of Industrial HiVision. If you start different releases simultaneously each release maintains a connection to its own background service.

Industrial HiVision enables you to install
– the user interface (Industrial HiVision Client) and
– the service with the database (Industrial HiVision Server)
on different computers.
You can thus access a central network management station from different locations with multiple user interfaces. The number of user interfaces that can access a central network management station depends on the capacity of the network management station. To avoid access conflicts, only one user interface can access a network management station in the edit mode (see on page 291 “Advanced:Program Access”)
However, you can access multiple decentral Industrial HiVision servers with one user interface.

**Note:** Installing an external firewall with NAT between the service and the user interface
In the external firewall you activate port forwarding for the connection port in the service direction for the following ports:
- 11166, Industrial HiVision proxy server for the communication between the service and the user interface.
- 11165, Industrial HiVision Web server to also open the user interface in the browser.
(see on page 292 “Advanced:Services Access”)

**Note:** Industrial HiVision writes events (see on page 98 “Event list”) with dates and times in the database. The time written refers to the time in the system on which the service is running. When you start the user interface on a computer in a different time zone, Industrial HiVision displays the event times in the time zone of the computer on which the service is running.
2.2 Installation

32- and 64-bit systems
Industrial HiVision is available to you as a 32-bit and 64-bit version. The installation wizard automatically installs the version that suits your operating system.

2.2.1 Downloading the Industrial HiVision software

To install Industrial HiVision on your computer requires you to first register your download. After you complete your registration you can download the application.

To register your Industrial HiVision application download with Hirschmann, proceed as follows:

☐ Open the HirschmannIndustrial HiVision website:
  http://www.hivision.de.
☐ Click the “Download” link.
☐ Click the “Industrial HiVision Software Download” link.
☐ Click the software link that best suits your requirements.
☐ Open the “Downloads” tab.
☐ Select the “Software” option from the list.
☐ Select the software option that best suits your requirements.
☐ Enter your email address in the “Login” dialog, then click the “Register” link at the bottom of the dialog.
☐ Enter the appropriate information in the “Registration” dialog, then click the “Register” link. Belden-service sends you an email containing a link to your account (belden-service@salient.de).
☐ To activate your account, click the link displayed in the email.
☐ Enter a new password in the “Preferred Partner Portal” dialog and click the “Submit” option.

To install Industrial HiVision on your computer, proceed as follows:

☐ If you have Industrial HiVision running on your computer, then stop the current kernel.
☐ Open the HirschmannIndustrial HiVision website:
  http://www.hivision.de.
☐ Click the “Download” link.
To download the Industrial HiVision application, click the “Industrial HiVision Software Download” link.

Click the software link that best suits your requirements.

Open the “Downloads” tab.

Select the “Software” option from the list.

Select the software option that best suits your requirements.

Click the “Download selected files” link.

Read the license agreement, then click the “Accept” button.

Continue with the file download.

After the browser completes the download, your file explorer displays the Industrial HiVision zip file.

Verify that you have administration rights.

For Windows computers, extract the files contained in the zip file to your local drive. Note the location displayed in the text field.

For Linux computers, unpack the ihivision7.0_linux.tar file using the following command:

```
tar -xf ihivision7.0.tar -C /path/to/directory
```

Navigate to the location of the extracted files.

For Windows computers, double click the ihivision7.0_windows.exe file.

In the “Open File - Security Warning” dialog, click the “Run” button.

For Linux computers, start the installation script using the following command:

```
sh ./install.sh
```

Answer the questions of the installation script and follow its instructions. If you do not answer a question of the installation script, then the installation script selects the default answer.

### 2.2.2 Installation under Windows

**Note:** If you get the message *Error during installation of ikernel.exe*, this means that the user does not have any administration rights.
Depending on your selection, the installation assistant installs
- the Hirschmann Industrial HiVision 7.0 Service with integrated database
  (= Industrial HiVision Server) and
- OPC services,
- the Industrial HiVision Client (= user interface) program and
- the ActiveX control.

If you want to connect to a SCADA system, you need the OPC services on the Industrial HiVision server and/or the ActiveX control on the SCADA system.
OPC services function as the data source for SCADA systems.
The ActiveX control visualizes the network in SCADA systems.

To perform a HiDiscovery scan, Industrial HiVision requires the WinPcap program.
During the installation of Industrial HiVision, Industrial HiVision checks whether a version of WinPcap installed on your PC fulfills the requirements of Industrial HiVision. If not, you agree to the installation of WinPcap via the installation wizard.

During the installation, you can select whether the Hirschmann Industrial HiVision 7.0 Service
- is started automatically when the program starts or
- is started automatically each time the computer is rebooted.

**Note:** You will find the status of the service in Windows 7, Windows 2003 und Windows 2008 under **Start:** Control Panel: Administration Tools: Computer Management: Services and Applications: Services.
Here you can also terminate the service and restart it.
If you are running other resource-intensive programs on the computer, then close the Industrial HiVision program and the “Hirschmann Industrial HiVision 7.0 Service”. This service requires considerable computer resources. When it starts, the Industrial HiVision program asks you whether you want to start the service, and when you are leaving the program, whether you want to close the service.
Note that when the service is switched off, there is no network monitoring, which means that no events are recorded.
Note: In the default setting of the service properties on the “Logon” tab, no data exchange between the service and the GUI is permitted for the local system account (Start:Control Panel:Administration Tools:Computer Management:Services and Applications:Services, right-click on the “Hirschmann Industrial HiVision 7.0 Service” and choose Properties). This means that you can start a program from Industrial HiVision (see on page 266 “Basics:Event Actions”) and that the process runs in the background, but that the program is not visible on the monitor. Permitting the data exchange between the service and the GUI is a security risk, because this program can then be started independently of the user who is logged on. So-called Trojan horse attacks use this security gap. To automatically send a Short Message Service (SMS) or an e-mail when an event occurs, you do not need a data exchange between the service and the GUI.

Special features on Windows Server 2003
When installing Windows Server 2003, deselect the following components:
- Share Point Services
- Exchange Server
- Active Directory

2.2.3 Installation under Linux
- Logon with the su command so that you have root access rights.
- Quit the current kernel.
- Start the installation script with the command
  ```sh
  sh /mnt/cdrom/Software/IndustrialHiVision/linux/install.sh
  ```
- Answer the questions of the installation script and follow its instructions. If you do not answer a question of the installation script, then the installation script selects the default answer.
Example of a run of the installation script:

Welcome to Industrial HiVision

This script will install Industrial HiVision on your system. You can abort the setup process anytime by pressing ctrl-c.

Do you wish to continue? [y]es, [n]o (default=no)
y

Please specify a destination directory for the installation (default=/opt/ihivision7.0)

The directory /opt/ihivision7.0 does not exist.
Do you wish to create it? [y]es, [n]o (default=no)
y

Unpacking Industrial HiVision...

Running setup script...
*** Checking database user ***
*** Initialising installation directory ***
*** Initialising log directory ***
*** Configuring Services ***
*** Configuring Executables ***
*** Preparing Init Script ***
*** Industrial HiVision successfully installed ***

Industrial HiVision is now installed and ready for use.

☐ Start the Industrial HiVision service with the command
   /etc/init.d/ihivision7.0 start
   Industrial HiVision requires that you have logged on with su.

☐ You can quit the service with the command
   /etc/init.d/ihivision7.0 stop

☐ You can restart the service with the command
   /etc/init.d/ihivision7.0 restart

☐ You can check whether the service is running with the command
   /etc/init.d/ihivision7.0 status
To start the service when starting the operating system, you include the service start in the init sequence of your system. The various Linux distributions provide you with a whole range of options for this. For some start sequences compatible with Sys V, the installation copies the start script `ihivision7.0` into the `init.d` directory of the system. Depending on your requirements, you can
– integrate this script into the various run levels or
– start it manually with the above command.
The Init script was developed and tested under Red Hat, Ubuntu/Kubuntu and Mandriva Linux. Other distributions (such as Gentoo) use a different script format and thus require different scripts.
2.3 Update

2.3.1 Updating under Windows

To update a version of Industrial HiVision already installed, you install the new version as described on “Installation under Windows” on page 25.

During the installation, you can choose whether the installation routine transfers the database contents from a previous installation into the new installation.

If you want to transfer the database contents from an earlier version, you only uninstall the earlier version after the update. Industrial HiVision permits the installation of different versions on a PC.

**Note:** In order to correctly transfer the data from the previous version, the installation routine terminates the previous version of the service, with your permission, if it is still active. Therefore, there is no network monitoring during the update procedure.

**Note:** The Industrial HiVision backup is version dependent. Make a backup file after every software update (see on page 204 “Save Backup”).
2.3.2 Updating under Linux

To update a version of Industrial HiVision already installed, you install the new version as described on “Installation under Linux” on page 27.

During the installation, you can choose whether the installation routine transfers the database contents from a previous installation into the new installation.

If you want to transfer the database contents from an earlier version, you only uninstall the earlier version after the update. Industrial HiVision permits the installation of different versions on a PC.

**Note:** In order to correctly transfer the data from the previous version, terminate the previous version before the installation, if it is still active. Therefore, there is no network monitoring during the update procedure. If multiple previous versions are installed, Industrial HiVision takes the data from the latest previous version.

**Note:** During an update, Industrial HiVision can transfer the data from the database of the previous version if the previous version is in the specified installation directory. Otherwise, you can use the interface functions “Save” on page 203 and “Open” on page 203 to transfer the data.

**Note:** The Industrial HiVision backup is version dependent. Make a backup file after every software update (see on page 204 “Save Backup”).
2.4 Maintenance

Hirschmann are continually working on improving and developing their software. You should regularly check whether there is a new version of the software that provides you with additional benefits. You will find information about updates and upgrades on the Internet pages of Hirschmann Automation and Control GmbH.

www.hivision.de
2.5 Starting

2.5.1 Starting under Windows

During the installation, the program installation routine installs a program symbol for the link to the program Industrial HiVision on the desktop and

- in Start:Programs:Hirschmann:Industrial HiVision7.0

Start Industrial HiVision with a double-click on the program symbol on your desktop, or by selecting the program symbol in your start directory.

When starting, Industrial HiVision looks for the server. If Industrial HiVision does not find the server, Industrial HiVision opens a dialog for entering the server IP address or the server name. If the server is located on your local computer, you enter the name localhost.

Note: To be able to connect to the Industrial HiVision server from another computer, you first permit remote access in the server settings (see on page 292 “Advanced:Services Access”).

Figure 2: “Enter server address” window
If Industrial HiVision finds the server to which Industrial HiVision was last connected, Industrial HiVision connects to it again. If you want to connect to a different server, you click on “Cancel” in the “Connecting to server...” window. With File:Connect you open the dialog for entering the server IP address.

![Connecting to server... window](image)

**Figure 3: “Connecting to server...” window**

- **Connecting to multiple servers**
  - To connect to multiple servers, you copy the program symbol and add it again as a connection.
  - Open the properties of the new program symbol by right-clicking on the symbol and choosing “Properties”.
  - In the “Destination” row, you enter a blank after “C:\Programs\Hirschmann\Industrial HiVision7.0\bin\HiVision.exe”, **then the command line parameter** `-kernelHost <server name>`. For `<server name>` you enter the IP address or the name of your server.
  - Repeat these steps for every server you want to make a connection to.
2.5.2 Starting under Linux

□ Start the service before you start the graphic interface (see on page 27 “Installation under Linux”).

To be able to start Industrial HiVision from the graphic interface, you put an icon on the desktop you are using (KDE, Gnome, etc.). You will find a suitable image (ihivision_op32x32.png) in /opt/ihivision7.0/lib.

By double-clicking on the icon, or with the command /opt/ihivision7.0/bin/HiVision, any user can start Industrial HiVision.
2.6  Deinstallation

2.6.1  Deinstallation under Windows

☐ Quit the program Industrial HiVision before you start the deinstallation.

☐ To deinstall Industrial HiVision, select Start:Control Panel:Software.

☐ Select the program Industrial HiVision.

☐ Click on Change/Remove and follow the instructions of the deinstallation routine.

2.6.2  Deinstallation under Linux

☐ Quit the Industrial HiVision program before you start the deinstallation.

☐ Logon with the su command so that you have root access rights.

☐ Quit the Industrial HiVision service with the command /etc/init.d/ihivision7.0 stop

☐ Delete the /opt/ihivision7.0 directory with the command rm -rf /opt/ihivision7.0

☐ Remove the ihivision start script from the run levels of your init sequence (see on page 27 “Installation under Linux”).
**Note:** The database content and the licenses are lost during the deinstallation.
3 Preparation

Before you start entering and monitoring your network, set up the necessary or useful conditions.

- One prerequisite to be emphasized here is protecting your network management station.
- The necessary conditions include the accessibility of the devices to be monitored and the related access authorization.
- The useful conditions are the settings related to the presentation, such as color and font size.

- Create a data backup plan. Regularly export the data of your project. You can thus recreate your project at any time, should adverse circumstances damage the data stock.

The “Demo Network” program supplied allows you to simulate a network on your computer in order to familiarize yourself with Industrial HiVision without being connected to a network.
3.1 Improving the security of Industrial HiVision

Increasingly frequent attacks on IT systems, sabotage and espionage require in-depth knowledge of the targets for attacks on the part of the operator. The following list provides a selection of potential attack targets in the environment managed by a network management system:

- physical access to the network management station
- physical access to the managed devices
- manipulated installation files
- Ethernet access to the network management station
- Ethernet access to the managed devices
- Access to configuration and log files

This chapter provides guidelines to help you make it more difficult for unauthorized persons to access Industrial HiVision and the managed devices.

The term 'Security' in this manual, means everything related to the security and protection of your data network infrastructure.

3.1.1 Physical protection

Even the best IT security system and matching software security strategies are useless if an attacker has physical access to a device that you need to protect. The attacker can, for example, disconnect the device from the power supply, unplug data lines, sniff data lines, or destroy the device mechanically.

- Install devices that need protection in a locked cabinet or room.
3.1.2 Measures before and during the installation of Industrial HiVision

Take the first steps to help improve the security of your network management system before and during installation.

- **Check the installation scope**
  The more programs there are installed on your system, the more potential attack vectors for your system the attackers will find. The Industrial HiVision installation routines offer you several installation program extensions:
  - OPC DA service
  - OPC UA service
  - ActiveX control
  - GUI installation

- Check which products and program extensions you need to meet your needs.
- Remove any programs from your system that do not play a direct role in meeting your requirements.
- Only install the programs and program extensions, which you need to meet your requirements.

**Note:** Even if you do not install the OPC UA service, the communication port is open. This is a security risk.

To eliminate the security risk of the open communication port use the following work steps:
- If you have the Industrial HiVision program open, then close the program and stop the processes, click File > Exit and Stop Service.
- Open the service.xml file in a text editor for example, Notepad ++. The service.xml file is in \Program Files\Hirschmann\Industrial HiVision7.0\config.
- Search for the OPC service line, `<Service Name="OpcUaServer" Enabled="yes" Path="..." Foreign="yes">`. This line is located near the bottom of the file.
- Change “yes” to “no” for the OPC UA server for example, `<Service Name="OpcUaServer" Enabled="no" Path="..." Foreign="yes">`.
- Save and close the service.xml file.
- Restart the Industrial HiVision program.
### 3.1 Improving the security of Industrial HiVision

#### Verify the signature of the installation files

One option for attacking IT systems is to contaminate the installation files with malware. Hirschmann signs the *.exe-, *.ocx-, *.dll- and *.jar files in Industrial HiVision. The signature allows you to check whether you have original installation files from Hirschmann. Check the signature of the *.exe-, *.ocx- and *.dll files in Windows:

- The files in the installation path contain a signature.
- In the file explorer, open the "Properties" dialog of the file you want to check.
- In the "Properties" dialog, switch to the "Digital Signatures" tab.
- Mark the row with the signature and click "Details".
- In the "Details" dialog, click "View Certificate".

The certificate should be issued for “Hirschmann Automation and Control GmbH.

The certificate should be issued by VeriSign Class 3 Code Signing 2010 CA.

Verify the signature of *.jar files in Windows and Linux:

The user interface is a Java application.

If you start the user interface in a web browser, the web browser organizes the display of the signature for the *.jar file. The web browser also gives you the option to trust the signature or prohibit the execution of the *.jar file.

See “Web access to Industrial HiVision” on page 189.

#### Restrict access authorizations to the installation files

Anyone who has write permissions for the installed files on a system can manipulate these files.

- Make it more difficult to access the Industrial HiVision installation directory by exclusively giving people you can trust access to the directory.

Note: Regarding security

Anyone who has write permissions to the registry on a system can manipulate the registry entries. Help protect the registry by assigning write permission only to people you trust.
### Installing a redundant network management system

For high-availability network management, the Industrial HiVision network management system gives you the option of installing the software in two different locations. The two installations both access a common database.

This gives you the following redundant design options:
- the network management station itself
- the connection between the two network management stations

The benefit of redundant availability is offset by additional attack vectors. These additional attack vectors are as follows:
- the redundant network management station itself
- the redundant connection between the two network management stations

☐ Take the same security provisions for the redundant components as for the main components.

The "Redundant Network Management System Industrial HiVision" user manual provides details on installing the redundant system.

The "Redundant Network Management System Industrial HiVision" user manual provides details on installing the redundant system.

### Web server certificate

Industrial HiVision lets you use a web browser to encrypt communications with the Industrial HiVision web server. For encrypted communication, select the HTTPS transmission protocol. Industrial HiVision uses a self-signed certificate for HTTPS. Trust this certificate only if you are sure that you addressed the real Industrial HiVision web server with your connection request.

### 3.1.3 Industrial HiVision configuration actions

After installing Industrial HiVision, anyone can launch the program without restriction. The security-specific configuration starts with restricting access authorizations.
Change login name and password for edit mode
You can access Industrial HiVision freely in the newly installed condition. Industrial HiVision gives you the option of requesting a login when starting the program interface initially.
After starting the program interface, Industrial HiVision has an edit mode and a run mode.
See “Edit mode” on page 77.
☐ Setup the login request.
☐ Set up a password for access to the edit mode.
See “Basic setting: User Management” on page 263.

Specifying user authorizations
Limiting access with user rights in connection with passwords is a crucial part of protecting IT systems.
You can define appropriate authorization roles and users with the matching authorization roles.
☐ In order to limit access to Industrial HiVision, set up a user under "Local Users" and/or activate an authorization "Policy".
See “Basic setting: User Management” on page 263.

Setting up an LDAP
The Lightweight Directory Access Protocol (LDAP) is an application, whose tasks include authentication (verifying passwords) and authorization (verifying rights) in a data network. For example, Microsoft uses LDAP to perform user management in an Active Directory service. A central server or several distributed servers manage functions including user names and user roles.
If LDAP is activated, Industrial HiVision sends an inquiry to the LDAP server, as soon as a user logs on.
Industrial HiVision adopts the user names and authorization roles from the LDAP server and enters these into the local user directory.
☐ Ask the administrator of your LDAP server, which configuration data you should enter into the Industrial HiVision LDAP dialog.
☐ Give your LDAP server administrator the following user data to enter into the LDAP server:
  – User Name
  – Password
  – Access Roles
3.1 Improving the security of Industrial HiVision

See “Basic setting: User Management” on page 263.

■ **Radius Authentication**

The Remote Authentication Dial-In User Service (RADIUS) is a service for authentication (verifying passwords) and authorization (verifying rights) in a data network.

RADIUS is based on a client/server protocol.

If RADIUS is activated, Industrial HiVision sends an inquiry to the RADIUS server, as soon as a user logs on.

Industrial HiVision adopts the user names and authorization roles from the RADIUS server and enters these into the local user directory.

☐ Ask the administrator of your RADIUS server, which configuration data you should enter into the Industrial HiVision RADIUS dialog.

☐ Give your RADIUS server administrator the following user data to enter into the RADIUS server:
  - User Name
  - Password
  - Access Roles

See “Basic setting: User Management” on page 263.

■ **Monitoring the device configuration settings**

The device configuration is an attack target. An attacker who gains access to the management system can manipulate the device configuration, e.g., by disabling a port.

Industrial HiVision gives you the ability to save the configuration of devices as a reference configuration, and to regularly compare this with the actual configuration of the device (see new chapter).

☐ Click on the "Properties" tab in the detail display.

☐ Select the "Configuration File" property below "Property:"

Industrial HiVision lists the devices on your network that have the property "Configuration File".

☐ Select the devices whose configuration you want to monitor.

☐ Right click a selected device and select "MultiConfig™".

Industrial HiVision opens the "MultiConfig™" dialog.

☐ In the "MultiConfig™" menu tree, click on the "Status Config" dialog.

☐ To download the reference configurations of the devices, select the function framework of the "Status Config" dialog "Set current to reference".
Select the status for "Value is Reference Value", e.g., "OK".
Select the status for "Other Value", e.g., "Warning".
Click "Write".
To configure polling and status forwarding, select "Property Properties" in the menu tree of the "MultiConfig™" dialog. Note the network load caused by this function when setting the polling interval. One option for being able to react to current events despite large polling intervals is to send traps using the devices in the network. Enter the network management station into the devices as a trap target.
If the configuration of the device to be monitored changes, Industrial HiVision gives you the ability to compare the configuration saved in Industrial HiVision with the current configuration on the device.
To access the "Configuration File" device property, double-click the detail display of the device in question in the list view.
To display the differences, right click the "Configuration File" device property and select "Display differences".
The highlighted sections in the comparison have the following meanings:
- Green text on light gray background: Change
- Red text on light gray background: Deleted
- Blue text on light gray background: Added

### Tracking changes to program settings and device configurations
"Audit Trail" or "Audit Log" is the name for a chronological record of changes to a system and its environment. These records give you the opportunity to verify, for example, who made a configuration change and when.
Audit Trail uses the Windows Event Viewer or Linux syslog function. Audit Trail runs automatically without any user intervention.
Industrial HiVision logs information for the following events:
- MultiConfig™
  - Write operations with MultiConfig™ that completed successfully or did not complete.
- Properties dialog
  - Write operations in the Properties dialog box of a property
- Domains
  - Issue licenses
  - Revoke issued licenses
  - Add subdomain
  - Remove subdomains
3.1 Improving the security of Industrial HiVision

- **Scheduled actions**
  - Execution of a task
  - Add tasks
- **Device management**
  - Set device to "Managed"
  - Set device to "Unmanaged"
  - Delete device
  - Set trap target address
- **Change IP configuration**
- **Perform actions that require "Edit Mode"**
  - "Audit Trail" records actions for which Industrial HiVision prompts the user to enter the "Edit Mode" password before completing the action.
- **External programs**
  - Open or close the web interface of managed devices
  - Open or close the device configuration of managed devices
  - Open or close the command line interface of managed devices
  - Open or close the SNMP browser for querying SNMP MIB variables of managed devices
  - Logging of actions carried out by external programs is the responsibility of those external programs. Industrial HiVision logs the launch and termination of these external programs.
- **User-defined actions**
  - Add user-defined action
  - Run user-defined action

### Restricting remote GUI access rights

Industrial HiVision gives you the ability to connect with the Industrial HiVision server remotely from another computer.

- Disable remote access if you want to prohibit remote access to the Industrial HiVision server.
  
  See “Advanced:Services Access” on page 292.
3.1 Improving the security of Industrial HiVision

Restricting web server access rights
Industrial HiVision gives you the ability to use a browser to access the Industrial HiVision web server via the HTTP or HTTPS protocol. You can thus monitor your network from anywhere in the world.

- To enhance the protection for web server access, assign user authorizations.
  See “Basic setting: User Management” on page 263.
- Disable the web server if you want to prohibit browser-based access to Industrial HiVision.
  See “Advanced: Services Access” on page 292.

Restricting OPC server usage
Industrial HiVision enables you to activate/deactivate the OPC server or to activate/deactivate the writing of object values in Industrial HiVision via an OPC write command. Both are deactivated on delivery.

- Only activate what you really need.
  See “Advanced: Services Access” on page 292.
- Disable the function in the service.xml.
  See “Advanced: Services Access” on page 292.

3.1.4 Restrict File Access
You can help protect your management system by limiting the number of Industrial HiVision users and by restricting user permissions. To further deny unauthorized user access, restrict access to the Industrial HiVision “config” folder. The Industrial HiVision “config” folder contains the security related files `usermanagement.xml` and `service.xml`. The default path to the folder is as follows: “C:\Program Files\Hirschmann\Industrial HiVision <version number>”
Note: The Industrial HiVision “config” folder contains the usermanagement.xml file only after you have added users to the Configuration > Preferences > User Management dialog.
3.2 Outside the program

Industrial HiVision requires access to the devices to be monitored. Therefore keep in mind:

- Your network management station has access rights to every device to be monitored. This is the case if the IP address of your network management station is entered as an IP address with access rights on the device to be monitored. Devices with any IP address have access to Hirschmann devices whose configuration is set to the factory default.

- Your network management station is physically connected to every device to be monitored, directly or indirectly via hubs and switches or routers.
3.3 Network structure

Large data networks have hierarchical network structures. Industrial HiVision is scalable and can be adapted to the hierarchical network structure. Adapting to the hierarchical network structure means that you can set up a network management station for each subdomain of your data network. (see figure 53 “Domains”)

3.3.1 Advantages of the hierarchical network structure

This hierarchical adaptation offers the following advantages to you:

► Load distribution
In very large data networks with extensive monitoring, you can easily reach the limits of your system resources (see on page 176 “Effect on system resources”). Through the use of multiple network management stations, you can restrict the utilization of the data network and the network management station to the domain limits. This significantly increases the performance.

► Smaller projects
Smaller projects make it easier to get an overview.

► Organizational structure
Adapting your network management projects to your organizational structure enables you to create and copy relevant projects individually.

► Central administration of Industrial HiVision licenses
► Concentrated display of the statuses of the subdomains
3.3.2 Application Example

The following figure shows an application example of a hierarchical network structure. The network consists of the IT domain, with lower-level domains A1, A11, and B1. The IT network management station is in the IT network. The A1 network management station is in production network 1. The A11 network management station is in production subnetwork 11. An A12 network management station could also be in production subnetwork 12. In this case, the A1 network management station is the superdomain of the A11 domain. The B1 network management station is in distribution network 1. The domains A1 and B1 are subdomains of the IT domain. Industrial HiVision allows a nesting depth of 4 layers and 5 subdomains per domain.
Figure 4: Domains
3.3.3 Configuration of the application example

The configuration of hierarchically arranged network management stations comprises the following steps:

- Release subdomains
- Connect subdomains to superdomains
- Assign licenses from top to bottom

**Release subdomains**

First you go into the hierarchical levels from bottom to top. In Industrial HiVision, go into the subdomain interface and release access for the superdomain on the next higher level.

The following instructions describe this process for the A11 subdomain.

- In the settings, choose Advanced > Services.
- Allow remote access with Industrial HiVision Proxy Server > Remote Access = true.
- You open the dialog box for editing by double-clicking on the line.
- Select the subdomain interface with Global Settings > Subdomain interface enabled = true.
- You open the dialog box for editing by double-clicking on the line.
- Under Global Settings > Password, enter a password with which the superdomain can access this subdomain.
- Requirement for the password: 8 to 16 characters.
- You open the dialog box for editing by double-clicking on the line.
- Repeat these steps for the subdomains A1 and B1.

**Connect subdomains to superdomains**

- To connect the A11 subdomain to the A1 superdomain, on the superdomain A1 open the "Add New Subdomain" dialog with File > New > Subdomain.
- Enter the IP address of the subdomain.
- Enter a name for the subdomain under which Industrial HiVision displays the subdomain in the folder frame.
Enter and repeat the subdomain password with which the superdomain can access the subdomain. Industrial HiVision shows the subdomain in the upper part of the folder frame.

Repeat these steps for the IT superdomain with the superdomains A1 and B1.

You can delete a subdomain from the folder frame by selecting the subdomain and pressing the “Del” button.

Assign licenses from top to bottom
Now you assign the Industrial HiVision licenses in the levels of the hierarchy from top to bottom.
A superdomain requires its own license.

In the IT superdomain, enter your license key (see on page 276 “Basics: License”).

To assign licenses to the subdomain A1, right-click the subdomain A1 in the folder frame of the IT superdomain.
In the "Lease license nodes" dialog, enter the number of licenses you are leasing to subdomain A1.
The number of licenses for the subdomain A1 includes the number of licenses that you further assign from superdomain A1 to subdomain A11 in the next step.

To assign licenses to the subdomain A11, right-click subdomain A11 in the folder frame of the A1 superdomain.
In the "Lease license nodes" dialog, enter the number of licenses you are leasing to subdomain A11.
Superdomain A1 requires a separate license so that it can issue licenses to subdomains.
As an alternative, Industrial HiVision offers you the option to enter a license key directly in the subdomain.
Now you assign the Industrial HiVision licenses in the levels of the hierarchy from top to bottom.
A superdomain requires its own license.

- In the IT superdomain, enter your license key (see on page 276 “Basics:License”).
- To assign licenses to the subdomain A1, right-click the subdomain A1 in the folder frame of the IT superdomain. In the "Lease license nodes" dialog, enter the number of licenses you are leasing to subdomain A1. The number of licenses for the subdomain A1 includes the number of licenses that you further assign from superdomain A1 to subdomain A11 in the next step.
- To assign licenses to the subdomain A11, right-click subdomain A11 in the folder frame of the A1 superdomain. In the "Lease license nodes" dialog, enter the number of licenses you are leasing to subdomain A11. Superdomain A1 requires a separate license so that it can issue licenses to subdomains.

As an alternative, Industrial HiVision offers you the option to enter a license key directly in the subdomain.

**Note:** A subdomain maintains the validity of its borrowed licenses via periodic communication with the superdomain. If this communication is interrupted for more than an hour, the validity of the subdomains' borrowed licenses lapses. The lapsed licenses are then available again in the superdomain.

You will find an overview of the licenses assigned to subdomains in the Basics > License dialog in the configuration settings (see on page 276 “Basics:License”).
3.3.4 Status display of the subdomains

The superdomain determines the status of its subdomains and indicates this status with color.

<table>
<thead>
<tr>
<th>Color</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dark gray</td>
<td>Subdomain cannot be reached</td>
</tr>
<tr>
<td>Gray</td>
<td>Status determination not available</td>
</tr>
<tr>
<td>Green can be configured in the initial settings</td>
<td>OK</td>
</tr>
<tr>
<td>Yellow can be configured in the initial settings</td>
<td>Warning</td>
</tr>
<tr>
<td>Red can be configured in the initial settings</td>
<td>Error</td>
</tr>
</tbody>
</table>

Table 1: Meaning of the status colors of the subdomains
3.4 Program default settings

To take into account the individuality of every user, Industrial HiVision gives you the option of entering settings relating to the presentation, the function and the device detection.

- **IP parameters**
  Enter the IP parameters of your network management station under Configuration > Preferences > Advanced > Management Station (see on page 298 “Advanced: Management Station”).

- **Device access**
  Industrial HiVision independently detects the delivery settings of Hirschmann devices for the SNMP access.
  If for security reasons you have already made changes to the SNMP settings for the devices to be monitored, then enter the user names and the passwords under Configuration > Preferences > Advanced > SNMP Configuration (see on page 294 “Advanced: Device Credentials”).
Discover Devices

Industrial HiVision gives you three options for detecting devices in the connected network:

▶ Traps: Detecting devices using the alarm messages (traps) sent by them. Keep in mind that your network management station is entered as the trap destination address in every device to be monitored (see on page 164 “Trap destination address”).

▶ HiDiscovery: Detecting devices by means of a query using the HiDiscovery protocol. Select the relevant network card of the network management station (see on page 298 “Advanced:Management Station”).

On delivery, the HiDiscovery protocol on a new Hirschmann device is active.

▶ Network scan: Discovering devices by means of an IP query for an entered IP address range (see on page 104 “Device detection”).

Select the required method for device detection under

Configuration > Preferences > Basics > Discover Devices (see on page 258 “Basics:discover devices”).

License

To be able to utilize the entire scope of the functions of Industrial HiVision, enter your license key under

Configuration > Preferences > Basics > License (see on page 276 “Basics:License”).

After a new installation or after an update, Industrial HiVision starts fully functional for the duration of the free 30-day trial period.

After the free 30-day trial period, Industrial HiVision runs as a free version (see on page 210 “Switch to the free version”).

After you enter a license key, Industrial HiVision runs as the licensed version.

Font size

Depending on the setting of your screen resolution, some of the text displayed is too small or incomplete. Adapt the font size under

Configuration > Preferences > Display > Device,
Configuration > Preferences > Display > Appearance (see “Display:Appearance” on page 286 and “Display:Device” on page 283).
### Colors
The optimal signal effect of the display depends on your color sensitivity. Select your color display under Configuration > Preferences > Display > Status Colors (see on page 287 “Display: Status Colors”).

### Devices and port names
Industrial HiVision enables you to choose the name of the device/port that appears in the interface. Select the name of the device/port under Configuration > Preferences > Advanced > Device/Port Names (see on page 307 “Advanced: Device/Port Names”).

### Default device icons
Industrial HiVision enables you to assign defined default icons to different device types. Select device icons under Configuration > Preferences > Display > Device Icon (see on page 288 “Display: Device Icon”).
3.5 Using Industrial HiVision with Firewalls

Industrial HiVision is a management system that allows you to connect multiple clients to the Industrial HiVision services. You can install the management station which provides the Industrial HiVision services in the same network as the clients or in a remote network. You can separate the networks with a firewall. When a firewall separates the Industrial HiVision services from the clients, add rules to the firewall to forward the required Industrial HiVision service data.

**Note:** We recommend that you limit access to the "Project Data Server" to local users only. To limit access to the "Project Data Server", deactivate the "Remote Access" function.

The following list contains the various types of clients:

- **Application GUI**
  The Application GUI client uses the Industrial HiVision executable file to connect to the Industrial HiVision services.

- **ActiveX GUI (Windows)**
  The ActiveX GUI client uses the Industrial HiVision ActiveX control (.ocx) file to connect to the Industrial HiVision services. An OCX file is an application that runs on Microsoft's Windows systems.

- **Industrial HiVision Super Domain Client**
  This client is the Industrial HiVision service where you add an Industrial HiVision Subdomain.
Note: Activate the "Subdomain interface" and set the password on the Industrial HiVision subdomain.

- **Web GUI**
  The Web GUI client is available using any web browser. To access the Industrial HiVision services using a web browser, enter the IP address of the management station and the "Port" number. For example:
  https://[IP address of the network management station]:11165

Note: Regarding security
An attacker can spoof the Industrial HiVision Web GUI client, also known as the browser client, which can lead to unauthorized access to the Industrial HiVision kernel/web server. To help protect your network against attack, verify that every user requiring access has proper credentials. Limit the number of administrators and users. (see on page 263 "Basic setting: User Management")

- **HTML GUI**
  The HTML GUI client is available using any web browser. To access the Industrial HiVision index using a web browser, enter the IP address of the management station, the "Port" number, and idx. For example:
  https://[IP address of the network management station]:11165/idx
  To access the Industrial HiVision events using a web browser, enter the IP address of the management station, the "Port" number, and events. For example:
  https://[IP address of the network management station]:11165/events

- **HiMobile GUI**
  The Industrial HiVision HiMobile GUI provides services for mobile devices.

- **OPC UA HTTP/HTTPS**
  You can configure any suitable OPC UA client to access the Industrial HiVision OPC UA server through the corresponding port.

For entries marked with an “X”, activate the service in Industrial HiVision and add a rule to the firewall to forward the port data. To activate a service, mark the checkbox for the required service in the Preferences > Advanced > Services Access dialog.
Note: For the "Project Data Server" entries, verify that the Industrial HiVision service is running and accessible (see on page 292 “Advanced: Services Access”).

<table>
<thead>
<tr>
<th>Type of Industrial HiVision Service /Client</th>
<th>Web Server</th>
<th>Project Data Server</th>
<th>OPC UA Server (HTTP)</th>
<th>OPC UA Server (HTTPS)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application GUI</td>
<td>–</td>
<td>X</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>ActiveX GUI (Windows)</td>
<td>–</td>
<td>X</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>Industrial HiVision Super Domain Client</td>
<td>–</td>
<td>X</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>Web GUI</td>
<td>X</td>
<td>X</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>HTML GUI</td>
<td>X</td>
<td>–</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>HiMobile GUI</td>
<td>X</td>
<td>–</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>OPC UA HTTP</td>
<td>–</td>
<td>–</td>
<td>X</td>
<td>–</td>
</tr>
<tr>
<td>OPC UA HTTPS</td>
<td>–</td>
<td>–</td>
<td>–</td>
<td>X</td>
</tr>
</tbody>
</table>

*Table 2: Service-Client settings*
4 Interface of the program

This chapter describes the structure of the program interface. It provides you with an overview to help you find your way in the graphic interface. You will find a detailed description in the chapter “References” on page 199.

Expert knowledge of networks is not required to use Industrial HiVision. The interface enables you to operate the program intuitively. It contains elements of standard user interfaces, so you will be able to get started after a brief familiarization phase.
4.1 Main window of Industrial HiVision

When you start Industrial HiVision, the main window appears on the screen. It consists of the following parts:

- Menu bar
- Tool bar
- Event line
- Folder frame
- Navigation field
- Detail display
- Event list

By positioning the mouse on a screen position in Industrial HiVision for a short time, you open an information window with a small help text.

In the event list area, Industrial HiVision shows the time that is synchronized with the system time of the computer. Industrial HiVision updates this time every second. If the time displayed matches the system time of the computer, you can assume that the displayed content of Industrial HiVision is up to date.
4.1 Main window of Industrial HiVision

Figure 5: Main window
1 - Menu bar
2 - Tool bar
3 - Event line
4 - Folder frame
5 - Navigation field
6 - Detail display
7 - Event list
4.2 Menu bar

The menu bar is right at the top of the main window of the program. It gives you support in importing, exporting, and creating new projects, in copying, adding, and deleting data, and in changing the view and configuration. A help menu is also provided. See “Main window of Industrial HiVision” on page 66.

The menu bar contains the following selection items:

- File
- Edit
- View
- Configuration
- Tools
- Help
4.2 Menu bar

4.2.1 File

The “File” menu item in the menu bar contains the following selection fields:

- New Project
- Run Setup Wizard
- New
- Login
- Open... (Ctrl+O)
- Save (Ctrl+S)
- Save as...
- Save Backup
- Load Backup
- Export...
- Export Events...
- Print (Ctrl+P)
- Print Events
- Exit and Stop Service
- Exit (Ctrl+Q)

The key combinations in brackets allow you to start the selection items without using the mouse.
4.2.2 Edit

The "Edit" menu item in the menu bar contains the following selection fields:

- Undo (Ctrl+Z)
- Redo (Ctrl+Y)
- Edit Mode
- Switch to the Free Version (available during the 30-day trial period)
- Cut (Ctrl+X)
- Copy (Ctrl+C)
- Paste (Ctrl+V)
- Paste As Link
- Delete (Del)
- Rename (F2)
- Select All (Ctrl+A)
- Acknowledge Status Change
- Manage
- Unmanage
- Set Device and Port Names
- Set Default Device Icon
- Device Documentation
- Drawing Size
- Background Image
- Find... (Ctrl+F)
- Auto Topology...
- Auto Layout
- Properties... (Alt+Enter)

The key combinations in brackets allow you to start the selection items without using the mouse.

4.2.3 View

The “View” menu item in the menu bar contains the following selection fields:

- Select VLAN
- Refresh VLANs
4.2 Menu bar

- Protocol Statistics
- Filter Events for Object
- Back
- Forward
- Up
- Home View
- Set Home View Settings
- Geographical Location View
- Zoom

Figure 6: menu - View
4.2.4 Configuration

The “Configuration” menu item in the menu bar contains the following selection fields:

- **Monitor**
  This dialog gives you an overview of the setting of the monitored components. *(see on page 245 “Monitor”).*

- **PSM Manager**
  Product-Specific Modules (PSMs) describe the properties of a device which Industrial HiVision can read for monitoring or write to for configuration. The PSM Manager gives you the opportunity to update PSMs or import additional PSMs beyond the ones included with delivery and remove them again. *(see “PSM Manager” on page 247).*

- **Reporting**
  The reporting function allows you to manage long-term statistics outside the database of the network management system program. *(see “Reports” on page 170).*

- **Scheduler**
  Scheduler offers the possibility of having repeating tasks of Industrial HiVision carried out automatically. *(see “Scheduling” on page 249).*

- **Preferences (Ctrl+E)**
  You use this selection field to enter settings for the configuration of Industrial HiVision *(see on page 258 “Preferences”).*

- **Change Password...**

- **Status Configuration**
  With this dialog you can perform the status configuration of component details for the devices in a device class, or for all devices.

- **Scan Ranges**
  With this dialog you can enter the scan ranges for the device discovery.

- **User defined Properties** *(see on page 173 “User-defined properties”)*
  With the "User defined Properties" function, Industrial HiVision allows you to include additional properties from the MIB of SNMP-capable devices in the management.
MultiConfig™
The multi-configuration function (MultiConfig™) allows you to perform configurations on the device and in Industrial HiVision for:
– one or more devices
– one or more device properties, also for all the devices
– one or more device details, also for all the devices

MAC/IP List
MAC/IP list of the discovered devices.

Refresh (F5) the properties or refresh device.

IP Configuration
This dialog enables you to configure the IP parameters of a device detected by HiDiscovery without an IP address, or to change IP parameters already configured.

Trap Destination
When the dialog is opened, Industrial HiVision queries the trap settings of the device and displays whether the device sends traps to the IP address displayed.

The key combinations in brackets allow you to start the selection items without using the mouse.
### 4.2.5 Tools

The “Tools” menu item in the menu bar contains the following selection fields:

- Dashboard
- Web Interface
- Device Configuration
- CLI
- Actions
- SNMP Browser
- Ping
- HiDiscovery Scan
- Scan Network
- Demo Network
- Calculate Availability

You can activate menu items displayed in gray by selecting a device or property that supports this function.
4.2.6 Help

The “Help” menu item in the menu bar contains the following selection fields:

- Online Help, (F1)
- Readme
- Release Notes
- Tutorial
- Online
- Kernel Info
- About

You can use the F1 key to start the online help without using the mouse.

- **Online help (F1)**
  You select this field to start the online help of the program.

- **About**
  You select this field to open a window with information on the program.
4.3 Tool bar

In the tool bar you can quickly access frequently used functions by clicking on the relevant button. See “Main window of Industrial HiVision” on page 66. The tool bar contains the following selection fields:

- Back
- Forward
- Up
- Home View
- Undo
- Find
- Edit Mode
- Properties
- WWW
- Scan Network
- HiDiscovery Scan
- Preferences

Grayed-out selection fields cannot be used at the present time. This is the case, for example, if you want to use “Up” to reach a higher level when you are already on the highest level.
4.3.1 Edit mode

Industrial HiVision provides two operating modes. You use the "Edit mode" button to switch between these two operating modes.

- **Edit mode**
  The edit mode allows you to edit settings in your network display and settings for the monitoring functions. You can restrict access to the edit mode with a password. You can define appropriate authorization roles and users with the matching authorization roles.
  
  See “Basic setting: User Management” on page 263.

- **Run mode**
  The run mode is used exclusively for monitoring the network. Everyone who has access to the network management station can monitor the network with the settings entered in the edit mode. When you specify an authorization role that only has "Login" authorization, then a user can operate Industrial HiVision with only this role and only in run mode.
  
  See “Basic setting: User Management” on page 263.
4.3.2 Preferences

By selecting the "Preferences" tool in the tool bar you open a window with the following selection items:

- Basics
  - You specify how "Basics" will detect devices
  - you specify how Industrial HiVision reacts to events,
  - you enter passwords for accessing devices,
  - you manage your Industrial HiVision licenses.

- Display
  The "Display" selection field enables you to specify the mode of presentation for events, devices or text.
4.4 Event line

The event line gives you information on events which are saved in the event log (see on page 98 “Event list”) and which have not been acknowledged yet. The number of events that have occurred is displayed in three fields, sorted by type. You also get more detailed information on the events, which service logged them, and when the events occurred. See “Main window of Industrial HiVision” on page 66.

In the case of an event of the error type, for example, the relevant fields in the event line are colored. In the detail display, the device affected flashes red, and in the event window the relevant event line is highlighted in red. The user can change the standard settings for the display with color and flashing by means of the "Preferences" menu item in the tool bar (see on page 76 “Tool bar”).

Note: Regarding security
An attacker can spoof the Industrial HiVision browser client which can lead to unauthorized access to the Industrial HiVision kernel/web server. If you suspect that an unauthorized person has tried to access Industrial HiVision, then examine the host computer event log entries.
4.4.1 Number of events

The event line contains the number of unacknowledged events in the 3 information fields after the item "Events". Industrial HiVision can assign one of the 3 evaluation types to an event:

- Error: (red symbol)
  Industrial HiVision evaluates the event that has occurred as a severe error.
- Warning: (yellow symbol)
  Industrial HiVision evaluates the event that has occurred as an error that can lead indirectly to a problem in your network.
- Info: (blue symbol)
  Industrial HiVision evaluates the event that has occurred as a normal operating condition.

![Event line – events](image)

For every new event that occurs, Industrial HiVision increases the relevant counter by 1. When an event is acknowledged by the user, Industrial HiVision reduces the relevant counter by 1.
4.4.2 Types of events

In the three information fields after the item "Most Severe Recently", the event line contains more detailed information on the respective event.

<table>
<thead>
<tr>
<th>Designation</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>Date and time of the event</td>
</tr>
<tr>
<td>Source</td>
<td>Service, e.g. Industrial HiVision service</td>
</tr>
<tr>
<td>Message</td>
<td>Type of event, e.g. &quot;New device detected by ping&quot;</td>
</tr>
</tbody>
</table>

Table 3: Information on the event line

The last, most significant event is always displayed. If there is only information, then the latest information for the relevant event is displayed. If there are warnings too, then the latest warning for the relevant event is displayed. If there are also errors, then the latest message for the relevant event is displayed.

For each new event occurring, the following is displayed:

- In the "Time" field, the related date and the time
- In the "Source" field, the name of the service which logged the event
- In the "Message" field, a detailed description of the event type

You get the full listing of all events in the “Event list” on page 98. You will find the data from the event line in the columns of the event frame.
4.4.3 Acknowledge events

Use the "Acknowledge" button in the event line to acknowledge the displayed event after you have noted it. The "Ack." field in the event list provides you with another option for acknowledging events.

![Event line – events – acknowledge](image)

Figure 9: Event line – events – acknowledge

After the acknowledgment, the event line (see on page 81 “Types of events”) displays the next event from the event log. You get the full listing of all events in the (see on page 81 “Types of events”). Here you can also acknowledge the relevant events in the "Ack." (acknowledge) column.

When an event is acknowledged by the user, the relevant counter is decreased by 1 (see on page 80 “Number of events”).

In the "Ack." (acknowledge) column in the “Event list” on page 98, a green checkmark is set or the event is hidden after you acknowledge it, depending on the event filter selected.
4.4.4 Properties of an event

By clicking with the right mouse button on the event line and selecting "Properties", you open an information window with a text on the event currently displayed.

Figure 10: Event line – Events – Properties
4.5 Folder frame

In the folder frame of the Industrial HiVision program interface, you can move around like in other standard user interfaces. See “Main window of Industrial HiVision” on page 66. You can create new folders and move up and down within the hierarchy using the "Back", "Forward" or "Up" buttons in the tool bar (see on page 76 “Tool bar”).

- Back: go back to the last position
- Forward: go forwards to the next position
- Up: go up one level

You can also access these functions under the "View" menu item in the menu bar (see on page 70 “View”).

If you have divided your network into subdomains and configured them in Industrial HiVision (see on page 51 “Network structure”), then Industrial HiVision represents the domain structure in the top section of the folder frame.

The folders and elements listed in the folder frame are indicated by a “+” sign if they contain further subordinate elements or folders. To display them, you click on this plus sign. The subordinate elements/folders are indicated by a minus sign “-”.

To hide subordinate elements/folders again, you click on this minus sign.
In its state on delivery, Industrial HiVision contains three folders:

- **New Devices**
  In this folder, Industrial HiVision displays the newly-detected devices. This is part of the software and therefore cannot be deleted. Industrial HiVision does allow you to rename the folder.

- **Unused Devices**
  Industrial HiVision does not monitor the devices in this folder. This folder is part of the software and therefore cannot be deleted. Industrial HiVision does allow you to rename the folder.
  In order to decrease your network load, you can move devices which you do not need to monitor into this folder. Industrial HiVision assigns the device status "Unmanage" to devices in the "Unused Devices" folder. To monitor a device again, move the device to the desired folder.

- **My Network**
  Industrial HiVision provides this folder for you to create your own network plan. You can rename or delete it and create new folders for your network plans.
4.6 Navigation field

You can use the navigation field to move around the topology display (see on page 87 “Detail display”).
Click the navigation rectangle and pull it to the position you want within the navigation field. Your position within the detail display changes accordingly. See “Main window of Industrial HiVision” on page 66.
You can use the View > Zoom menu item in the menu bar, or right-click in the navigation field, to set the enlargement of the display in the detail frame by increments of 10%.
4.7 Detail display

In the detail display area of the Industrial HiVision user interface, you get a detail display of your network structure as a topology diagram, or in the form of a list. See “Main window of Industrial HiVision” on page 66.

Industrial HiVision allows you to move devices located in the "Map", "List", and "Devices" tabs to other project folders using drag and drop. For example, after scanning your network, Industrial HiVision displays a device in the "New Devices" folder. Using drag and drop you can move the device from the "New Devices" folder to the "My Network" folder. The drag and drop function allows you to move a single device or multiple devices at the same time.

4.7.1 Detail display – Topology

To access the topology view of the detail display, click on the "Map" tab of the detail display.
The devices and connections in your network structure are displayed in the topology view in accordance with the presentation options you selected. By selecting and pulling while pressing the mouse button, you can move devices.
Double-click on a device/component to go down one level in the detail display (see figure 28). The lowest level is the Component-detail-level. You recognize it by the diagram symbol.

![Diagram symbol for a component detail]

**Figure 11: Detail display – Topology**

**Figure 12: Diagram symbol for a component detail**

### 4.7.2 Detail display – List

To access the list view of the detail display, click on the "List" tab of the detail display.
The devices and connections in your network structure on this layer are displayed in a list in accordance with the presentation options you selected.

You double-click a device/component, you go down one level in the display.

Figure 13: Detail display – list view
4.7.3  **Detail display - Devices**

To access the device view of the detailed display, click on the "Devices" tab of the detailed display.

Industrial HiVision displays in a list the devices of the folder selected in the folder frame, and its subfolders. This list displays for each device:

<table>
<thead>
<tr>
<th>Name</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Symbol for the device</td>
</tr>
<tr>
<td>Status</td>
<td>Symbol for the device status</td>
</tr>
<tr>
<td>Name</td>
<td>Name you gave to the device in Industrial HiVision, otherwise the IP address of the device</td>
</tr>
<tr>
<td>IP Address</td>
<td>Management IP address</td>
</tr>
<tr>
<td>MAC Address</td>
<td>Management MAC address</td>
</tr>
<tr>
<td>Product</td>
<td>Name of the product family</td>
</tr>
<tr>
<td>Chassis</td>
<td>Product description</td>
</tr>
<tr>
<td>Serial Nr.</td>
<td>Serial number of the device</td>
</tr>
<tr>
<td>System Name</td>
<td>System name from the device MIB</td>
</tr>
<tr>
<td>Location</td>
<td>Location name that you entered in the device</td>
</tr>
<tr>
<td>Contact</td>
<td>Name of the contact person that you entered in the device</td>
</tr>
<tr>
<td>Firmware Version</td>
<td>The version of the firmware on the device</td>
</tr>
<tr>
<td>Chassis Name</td>
<td>Chassis name of a device with multiple management agents</td>
</tr>
<tr>
<td>Configuration</td>
<td>Devices that support this function assign a signature to a stored configuration.</td>
</tr>
<tr>
<td>Signature</td>
<td></td>
</tr>
<tr>
<td>PSM up to date</td>
<td>This column indicates whether the data read from the device for the current PSM (Product-Specific Module) corresponds to the data in Industrial HiVision. If the data read from the device is from an earlier version of Industrial HiVision, then Industrial HiVision will re-read the data from the device in the next scan cycle.</td>
</tr>
</tbody>
</table>

*Table 4: Meaning of the columns in the detail display of the devices*

The selection of a class of devices offers the possibility of filtering devices of a class and tagging them at the same time. Using the multi-configuration function, you can configure the selected devices together.
Interface of the program

4.7 Detail display

Figure 14: Detail display – Device view
4.7.4 Detail display - Ports

In the port view of the detail display, you click on the “Ports” tab page to go to the detail display.

Industrial HiVision displays in a list the ports of the folder/device selected in the folder frame and the subfolders in accordance with the presentation options you selected.

<table>
<thead>
<tr>
<th>Name</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Symbol for the port socket</td>
</tr>
<tr>
<td>Status</td>
<td>Symbol for the port status</td>
</tr>
<tr>
<td>Device</td>
<td>IP address of the device to which the port belongs</td>
</tr>
<tr>
<td>Port</td>
<td>Port number</td>
</tr>
<tr>
<td>Port Name</td>
<td>Name of the port as it is stored in the device</td>
</tr>
<tr>
<td>Medium Type</td>
<td>Type of the connected transmission medium, e.g. copper</td>
</tr>
<tr>
<td>Autoneg</td>
<td>Status of the autonegotiation function. A grayed-out display signifies that there is no autonegotiation function on this port.</td>
</tr>
<tr>
<td>Link</td>
<td>Link state of the device connected on this port</td>
</tr>
<tr>
<td>Port Enabled</td>
<td>Port setting: switched on or off.</td>
</tr>
<tr>
<td>Speed/Duplex</td>
<td>Speed and duplex transmission of the link connected on the port</td>
</tr>
<tr>
<td>User</td>
<td>MAC address of the device connected to this port, or if multiple devices are connected, e.g. by means of a hub, the number of connected devices.</td>
</tr>
<tr>
<td>Load</td>
<td>Network load of the incoming data volume</td>
</tr>
<tr>
<td>PVID</td>
<td>Port VLAN ID of this port. A hyphen indicates that the device has no port VLAN function.</td>
</tr>
<tr>
<td>Ingress</td>
<td>Status of the ingress filter function. A grayed-out symbol indicates that the device has no ingress filter function.</td>
</tr>
<tr>
<td>VLANs</td>
<td>The port’s membership of VLANs. A number indicates the VLAN ID of the VLAN of which the port is a member. “U” stands for member of the VLAN; data packets without tag. “T” stands for member of the VLAN; data packets with tag.</td>
</tr>
<tr>
<td>VLAN Consistency Check</td>
<td>PVID contained in VLANs</td>
</tr>
</tbody>
</table>

Table 5: Meaning of the columns in the detail display of the ports
### 4.7 Detail display

#### Figure 15: Detail display - Port view

![Port View Table]

<table>
<thead>
<tr>
<th>Type</th>
<th>Status</th>
<th>Device</th>
<th>Port</th>
<th>Port Name</th>
<th>Media Type</th>
<th>Auto Neg</th>
<th>Link</th>
<th>For</th>
</tr>
</thead>
<tbody>
<tr>
<td>10.0.1.1</td>
<td>2</td>
<td>Copper</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.0.1.1</td>
<td>1.1</td>
<td>Copper</td>
<td>1.1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.0.1.2</td>
<td>3.4</td>
<td>Copper</td>
<td>3.4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.0.1.2</td>
<td>3.3</td>
<td>Copper</td>
<td>3.3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.0.1.2</td>
<td>3.2</td>
<td>Copper</td>
<td>3.2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.0.1.2</td>
<td>3.1</td>
<td>Copper</td>
<td>3.1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.0.1.2</td>
<td>2.1</td>
<td>Copper</td>
<td>2.1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.0.1.2</td>
<td>2.3</td>
<td>Copper</td>
<td>2.3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.0.1.2</td>
<td>2.2</td>
<td>Copper</td>
<td>2.2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.0.1.2</td>
<td>1.2</td>
<td>Copper</td>
<td>1.2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.0.1.5</td>
<td>7</td>
<td>Copper</td>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.0.1.5</td>
<td>6</td>
<td>Copper</td>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.0.1.5</td>
<td>5</td>
<td>Copper</td>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.0.1.5</td>
<td>4</td>
<td>Copper</td>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.0.1.5</td>
<td>3</td>
<td>Copper</td>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.0.1.5</td>
<td>2</td>
<td>Copper</td>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.0.1.5</td>
<td>1</td>
<td>Copper</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.0.1.6</td>
<td>4</td>
<td>Copper</td>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.0.1.6</td>
<td>14</td>
<td>Copper</td>
<td>14</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10.0.1.6</td>
<td>3</td>
<td>Copper</td>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
4.7.5 Detail Display – Links

To access the links view of the detailed display, click on the "Connections" tab of the detailed display. Industrial HiVision displays in a list the links of the folder selected in the folder frame and its subfolders. For each link, this list displays:

<table>
<thead>
<tr>
<th>Name</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Status</td>
<td>Symbol for the link status according to the settings in the monitoring</td>
</tr>
<tr>
<td>Name</td>
<td>Name of the link - a name you entered for the link, or the IP address/port number of the connected devices</td>
</tr>
<tr>
<td>Connection</td>
<td>Status of the link (active, inactive)</td>
</tr>
<tr>
<td>Device A</td>
<td>Name/IP address of device A, to which the link is connected</td>
</tr>
<tr>
<td>Port A</td>
<td>Port number of device A, to which the link is connected</td>
</tr>
<tr>
<td>Device B</td>
<td>Name/IP address of device B, to which the link is connected</td>
</tr>
<tr>
<td>Port B</td>
<td>Port number of device B, to which the link is connected</td>
</tr>
<tr>
<td>Load A-B</td>
<td>Network load of the data volume from device A to B</td>
</tr>
<tr>
<td>Load B-A</td>
<td>Network load of the data volume from device B to A</td>
</tr>
<tr>
<td>Speed/Duplex</td>
<td>Speed and duplex transmission of the link</td>
</tr>
<tr>
<td>Medium Type</td>
<td>Type of the transmission medium of the link, e.g. copper</td>
</tr>
<tr>
<td>Link Changed</td>
<td>Date of the last status change for the link</td>
</tr>
<tr>
<td>Config Check</td>
<td>Discrepancy in the settings of the ports to which the link is connected. Refer to table 7</td>
</tr>
<tr>
<td>PVID Port A</td>
<td>Port VLAN ID of port A. A hyphen indicates that device A has no port VLAN function.</td>
</tr>
<tr>
<td>PVID Port B</td>
<td>Port VLAN ID of port B. A hyphen indicates that device B has no port VLAN function.</td>
</tr>
<tr>
<td>VLANs</td>
<td>The link’s membership of VLANs. A number indicates the VLAN ID for the VLAN of which the link is a member. “U” stands for member of the VLAN; data packets without tag. A number alone stands for member of the VLAN; send data packets with tag.</td>
</tr>
<tr>
<td>VLAN Check</td>
<td>When Port A and Port B have the same VLAN list, the result of the check is &quot;Ok&quot;. A hyphen indicates that there is no VLAN list information at a port</td>
</tr>
<tr>
<td>MTBF</td>
<td>Mean Time Between Failure of the components participating in the link. (see on page 348 “Calculate Availability”).</td>
</tr>
<tr>
<td>MTTR</td>
<td>Mean Time to Repair of the components involved in the link. (see on page 348 “Calculate Availability”).</td>
</tr>
</tbody>
</table>

Table 6: Meaning of the columns in the detail display of the links
4.7.6 Detail display - Properties

To access the properties view of the detail display, click on the "Properties" tab of the detail display.

Industrial HiVision displays in a list a selected property of device classes for the folder/device selected in the folder frame, and its subfolders.

☐ Select a device class (e.g. Windows PC).
☐ Select a property which you want to see for the devices of the device class.

**Table 7: Config. check - meaning of the display**
This list displays for each device in the device class:

- Status derived from the value in the right column
- Name/IP address of the device
- Device class
- Name of the queried property
- Value of the property

The properties view provides you with a quick overview -- for example, if you want to see the following:

- The software version of the devices of a device class
- The location of the devices of a device class
- The relay states
- The port properties of the Windows PCs
- etc.

Figure 17: Detail display - Properties view
4.7.7 Detailed display - Security Status

In the detailed view "Security Status", Industrial HiVision gives you an overview of the security properties of the devices in the selected folders. See "Security Status" on page 155.
4.8 Event list

Industrial HiVision logs the events relating to the program itself and to the devices being monitored. (see on page 279 “Display:Event”).

Examples of events are:
Industrial HiVision started, status improvement/disimprovement, event acknowledged, trap received, settings modified, device added, and so on.

Industrial HiVision allows you to write the events to an event log file, as well as displaying the events in the program interface.

Depending on the selection in the drop-down menu, the following is displayed by Industrial HiVision:

- Unacknowledged warnings and errors
- Unacknowledged events
- Warnings and errors
- All events
- When you click on “Filter Events for Selected Object”, Industrial HiVision shows the events of the selected object in the event list.

User-defined events
For user-defined events, Industrial HiVision opens a window in which you can specify which events Industrial HiVision is to display in the list. For help with the input notation, hover the mouse pointer over an input field.
For every event, Industrial HiVision logs

- An identification number
- Whether the event was acknowledged by the user
- The event type (Info, Warning, Error)
- The event category
- The time the event occurred
- The user responsible for the entry, e.g. the user who acknowledged the event
- The source that caused this entry, e.g. the device that changed to a better status
- The component that caused this entry, e.g. the port for which the connection status changed back to “ok” again
- The message stating which event caused this entry

The event list enables you to acknowledge individual events, or all events at once. See figure 5 on page 67.
Right-click on a line in the event list and select
- “Acknowledge” to acknowledge this event, or
- “Acknowledge all” to acknowledge all the events on this tab page.
Double-click on a row in the event list to select the source of the event in the folder frame, if the event can be assigned to a device or a property.
4.9 To navigate with the Keyboard

4.9.1 Navigating in a table

You can use the arrow keys to move up, down, right and left between the table fields in a table.
You use the tab key to move to the next table field.
With “Ctrl+Tab” you move to the next field outside the table.

4.9.2 Changing the frame

With “Tab” you move to the next frame in the program interface.
5 Creating a network plan

The monitoring of a network starts with the display of the network on the network management interface. Industrial HiVision allows you to view your network in different display variations at the same time, based on different criteria. Thus, for example, you can set up a network plan which
– shows the actual physical environment
– shows the most important connection nodes
– is based on the topology of your network, and so on.
You can display a device in several network plans by means of copying or connections.

The network display is subdivided into:

► Device detection
► Device arrangement
► Device mapping
► Device connections

Networks are generally undergoing constant modification. This involves

► removing devices
► adding new devices, and thus
► rearranging connections.
5.1 Device detection

During the first step in setting up a network plan, Industrial HiVision supports you in discovering the following devices installed on the network (see on page 258 “Basics: discover devices”):

- Hirschmann BAT family
- Hirschmann OCTOPUS family
- Hirschmann GECKO family with Management
- Hirschmann Rail Switch with Management
- Hirschmann MICE family
- Hirschmann Power MICE family
- Hirschmann MACH family
- Hirschmann GREYHOUND family
- Hirschmann GES-24TP Plus
- Hirschmann EAGLE family
- Hirschmann Rail Router family
- Hirschmann Redundancy Switch family
- Hirschmann LioN-P family
- Hirschmann LioN-R family
- Hirschmann LION family
- Hirschmann Embedded Ethernet family
- Hirschmann OWL family
- Magnum 5RX
- Magnum 6K
- Magnum 10KT
- Magnum DX line
- Magnum 10ETS
- Magnum 10RX
- Magnum 12KX
- Schneider Electric TCSESM, TCSESM-E, TCSESB families
- Selectron Systems ESM family
- Selectron Systems ERT family
- ABB AFF, AFS and AFR families
- INSYS MoRoS Modem, ISDN, HSPA, UMTS, GPRS, LAN, MI
- Meinberg LANTIME GPS, M300, M600
- Advantech SNMP-1000
- EPSON FX-2190, ACULASER C100N printers
5.1 Device detection

- Devices with SNMP
- Windows PCs
- Devices with ICMP (Ping)

**Note:** Industrial HiVision detects SNMP based devices of a third party manufacturer based on the MIB II standard. As a result, Industrial HiVision represents existing interfaces of the `ifTable`, including VLAN or routing interfaces, as separate ports.

Under **Configuration > Preferences > Basics > Discover Devices**, you select your preferred device discovering method.

Industrial HiVision provides 4 methods for discovering devices:

- **Discovering devices using traps**
  After they are switched on, the devices send a switched-on message to the network management station entered in the device. Industrial HiVision evaluates this message and displays the devices in the default map entered (see on page 258 “Basics:discover devices”).
  This method is suitable for use during ongoing monitoring in networks where the bandwidth needs to be managed.

- **Discovering devices using the HiDiscovery protocol**
  The HiDiscovery protocol uses the MAC address to communicate with devices in the network on which the HiDiscovery protocol is active.
  This method enables you to detect devices in your network to which you have not yet assigned a valid IP address.
  Industrial HiVision displays the devices in the default map entered (see on page 258 “Basics:discover devices”).
  This method is suitable for when you start up a newly installed network and want to assign the IP address to the new devices.
Creating a network plan

5.1 Device detection

- Discovering devices via a defined IP address range
  Using Net Scan, Industrial HiVision periodically sends Ping and SNMP requests to the devices with an IP address in the defined IP address ranges. Industrial HiVision positions the devices thus detected in the default map for this IP address range. When defining the IP address range, you can assign a default map to each IP address range (see on page 258 “Basics: discover devices”). This method is suitable for monitoring a running network. Adapt the frequency of the requests to the bandwidth of your network.

- Discovering newly created devices
  Industrial HiVision allows you to create a device manually and to assign an IP address to the entry for this device. After the device is created, Industrial HiVision can send an enquiry to this IP address in order to detect it (see on page 111 “Creating new devices”).

5.1.1 Device Icons

After Industrial HiVision scans your network, the "Map" tab displays the results. The tab displays the various icons for the devices discovered during the network scan. If the devices have a PSM assigned, then the tab displays the PSM. Otherwise, Industrial HiVision displays an icon in accordance with the status of the device.

The following list contains a description of the Industrial HiVision icons:

- Yellow cube - The device only responds to ping requests.
- Blue cube - The device responds to HiDiscovery requests, but is not a Hirschmann device.
- Hirschmann icon - The device responds to HiDiscovery requests. Industrial HiVision has determined that the device is a Hirschmann device based on the MAC address, but the device does not have a PSM.
- Unknown node icon - A user entered the device manually into Industrial HiVision, but is unreachable.
5.2 Assigning device icons

To visualize the devices more clearly in the detail display, Industrial HiVision allows you to assign different icons as default icons to the device types.

In the state on delivery, Industrial HiVision detects a number of device types (e.g. Hirschmann devices) and assigns the corresponding device icons to these devices. You can assign icons to other device types in the “Preferences” dialog. To differentiate the device types, Industrial HiVision provides you with the following assignment characteristics in the device detection (see on page 288 “Display: Device Icon”):

- System Object Identifier (SysOID)
  The SysOID denotes an MIB variable. As the SysOID of a manufacturer MIB contains the manufacturer, you can use different icons here to differentiate the devices on the manufacturer level. In the state on delivery, Industrial HiVision contains the SysOIDs for Hirschmann, Schneider, Siemens, Rockwell and Cisco.

- EtherNet/IP
  Similarly to the System Object Identifier, EtherNet/IP devices contain information about the manufacturer and the product. Here you can get Industrial HiVision to assign the icons down to the device level.
- **Modbus/TCP**
  Similarly to the System Object Identifier, Modbus/TCP devices contain information about the manufacturer and the product. Here you can get Industrial HiVision to assign the icons down to the device level.

- **MAC Address**
  The MAC address also contains manufacturer information. Depending on the manufacturer’s coding depth, you can perform icon assignment from the manufacturer level down to the device type level.
5.3 Device arrangement

5.3.1 Creating a network plan

For a new network plan, you create a new folder in the folder frame.

☐ Click with the right mouse button on the globe symbol and select New > Folder in the drop-down menu.

☐ Click with the right mouse button on the new folder and select "Properties..." in the drop-down menu. Give the new folder the name that you want to use for this network plan. You can also change the name of a folder by selecting the folder twice or marking the folder and pressing the F2 key. Complete the entry for the name by pressing the Enter key.

☐ Right-click on the new folder and select "Scan Ranges". The "Scan Ranges" dialog allows you to define IP address ranges. In this folder, Industrial HiVision represents newly detected devices with IP addresses from this IP address range.
5.3 Device arrangement

5.3.2 Moving devices into the network plan

Move the newly detected devices into the network plan folder.

☐ Mark these devices.

☐ Click on a device you have marked and move it onto the network plan folder in the folder frame.
5.3.3 Creating new devices

If you want to enter the network plan before the devices are installed in the network, you position new devices in the detail display.

- Click with the right mouse button in the detail display frame and select New > Device in the drop-down menu. The Properties dialog opens.

- Enter the IP address of the new device in the "IP Address" tab page. If you have selected the "Scan device" field, when you close the dialog with "OK", Industrial HiVision automatically scans the network for the device. If you selected "Create device", Industrial HiVision adds the option to create modules and ports for the device to this dialog.

If the new device is disconnected from the network management station by a NAT router, for example, then Industrial HiVision can communicate with the new device via the port forwarding of the NAT router. You then enter the IP address of the NAT router and the SNMP port number of the port by means of which Industrial HiVision shall communicate with the new device in the "IP Address" tab page. Enter the combination of the port and the IP address of the new device in the NAT table of the NAT router.
Creating a network plan

5.3 Device arrangement

In the "Properties" tab page you enter
- the name you want to give the device and
- the status propagation/status determination, if required
On (see on page 221 “Properties of a folder/device”).

Select the device and press the F5 key on your keyboard, or right-click on the device, and select "Refresh" so that Industrial HiVision detects the device in the network and calls up its data.
5.3.4 Arrange devices in the detail display

Industrial HiVision supports you in arranging the devices inside the detail display.

☐ Right-click in the detail frame and select "Auto Layout", so that Industrial HiVision repositions the objects in the detailed display, taking your connections into account.

☐ Right-click on a device and select Drawing > To Front/To Back to move devices which are lying upon each other into a higher/lower drawing layer.

☐ Right-click in the detail display and select Drawing > Line Up all Objects to arrange the devices line-by-line.

☐ Select multiple objects in the detail frame, right-click on the detail frame, and select Drawing > Align Tops/Align Bottoms/Align Left/Align Right to line up the selected objects in rows/columns.
Here Industrial HiVision selects the outermost object as the position for the row/column.

☐ Select multiple objects in the detail frame, right-click on the detail frame, and select Drawing > Center Horizontally/Center Vertically to line up the selected objects in rows/columns.
Here Industrial HiVision selects the first object selected as the position for the row/column.

Note: If you have pushed individual objects out of the visible area by moving object groups, and if they are still contained in the folder frame, you can pull the objects back into the visible area by right-clicking in the detail window and selecting "Auto Layout" or Drawing > Line Up all Objects all objects.
5.3.5 Naming devices and ports

The device/port name that Industrial HiVision displays in the folder frame or the detail display is taken from the properties dialog of the device/port by Industrial HiVision. If no name is entered, Industrial HiVision displays the management IP address for a device and the module/port number for a port.

- To enter the name, right-click on a device/port and select "Properties".

The configuration settings (see on page 307 "Advanced:Device/Port Names") enable you to automatically transfer

- the device/port names from the device and
- in the case of the device name, also from the Domain Name Server (DNS) or from a private hosts file.

5.3.6 Copying devices

In order to represent different monitoring scenarios, for example, Industrial HiVision gives you the option of copying devices. For this purpose you can enter different status configurations for copied devices in the properties dialog. Industrial HiVision has one data record for each device. Every copy has its own data record. The content of the data record is taken from the original by the copy.

Example with two monitoring scenarios:
In one monitoring scenario, you want to display only events that you determine to be critical. A connection break on port 3 of device A would be critical.
In the other monitoring scenario, you want to display events relevant for maintenance. The loss of a redundant voltage supply on device A would be relevant for maintenance.
- To realize this, you create two new folders in the folder frame and give one folder the name “Critical” and the other “Maintenance”.
- Right-click on device A and select "Copy".
- Add a copy of device A to each of the “Maintenance” and “Critical” folders.
Double-click on the “Critical” folder to get to the component level. Double-click on port 3 to go to the detail level.

In the dialog (see on page 227 “Properties of a component detail”), enter the relevant settings for the “Link” detail.

Proceed in the same way in the “Maintenance” folder.

### 5.3.7 Devices with multiple IP addresses

Industrial HiVision represents devices with multiple IP addresses, such as a router, as one device. In the Properties dialog of the device, on the "MAC/IP Addresses" tab page, you can see which IP addresses are assigned to the device.

For unique assignment, Industrial HiVision identifies a device with exactly one IP address. If you want to identify a device with a different IP address, you delete the device in the interface and create it again with the desired IP address. After the device is updated, Industrial HiVision identifies the device with this IP address.

### 5.3.8 Creating a link

To display a device in a number of network plans, Industrial HiVision gives you the option of creating links from devices. Connections are particularly useful if you want to divide your network into several folders. You can then display in both network plans the device connecting the two network plans with one another. In contrast to making a copy, the link accesses the data record of the original. Every change to the original is reflected in the link.
As well as links for devices, you can also create links for components.

- Copy the object for which you want to create the link.
- Right-click on the position where you want to place the link and select "Paste As Link".
5.4 Device connection

5.4.1 Automatically displaying the topology

The easiest way of displaying links between devices is provided by the Auto Topology function of Industrial HiVision.

- Select Edit > Auto Topology....

- In the dialog for automatic topology discovery (see on page 217 “Auto Topology”) you select how you want Industrial HiVision to execute the Auto Topology function and click "OK".

Then Industrial HiVision queries the devices for their links. Industrial HiVision displays the detected links in the interface and starts monitoring the link state and load.

In the case of Wireless Local Area Networks (WLAN), Industrial HiVision displays wireless connections with dashed lines. Because access stations can be mobile, roaming from one access point to another is a completely normal process. Therefore, Industrial HiVision does not include the connection status in the status configuration of radio connections. Industrial HiVision detects a break in the connection to the access point after the polling time for determining the status of the access point has elapsed.
5.4.2 Connecting devices manually

After you have arranged the devices to meet your requirements, you add the connections between the devices.

- Click on the center of a device symbol. Click again and, holding down the mouse button, move the cursor onto the device symbol with which you want to connect the device.

5.4.3 Reshaping a connection line

Industrial HiVision allows you to reshape connection lines. Thus, for example, you can represent a HIPER-Ring just like a ring.

- Select the connection in order to bend the line or give it a curved shape. Depending on the shape of the connection and the selection, the following options are available to you (see bubble help):
  - Add an anchor point with one click on the handle.
  - Switch between “Add anchor point” and “Change shape of curve” by re-selecting the connection.
  - Delete the anchor point by double-clicking.
  - Change the shape of the curve using the handle.
  - Straighten the connection piece with one click on the handle.
5.4.4 Specifying the line thickness

Depending on the selected background image, the connection lines can blend into the background. Industrial HiVision gives you the option of changing the line thickness. This enables you to make the lines more distinct from the background.

You set the line thickness globally in the menu Preferences > Display > Device (see on page 286 “Display:Appearance”).
5.4.5 Other connections

In the same way as you can connect devices, Industrial HiVision also gives you the option of connecting folders and components other than symbols and text with one another. In the illustration below, (see figure 23) you will find an example of a connection with a folder.

![Connection with a folder](image)

*Figure 23: Connection with a folder*

5.4.6 Detecting a link to another folder

Industrial HiVision uses a flag to indicate links to a device or folder outside the current folder. Beside the flag you will find information about where the link leads to. If the link has multiple destinations, Industrial HiVision groups the destinations together and the bubble help shows you the destinations.
When you double-click on the flag,  
- you go directly to the port named in the destination if a single device is connected, or  
- you open a drop-down menu if the flag points to multiple destinations. The drop-down menu shows the destination of the link. Select the link whose ports you want to go to.

Figure 24: Flags as link indicators

5.4.7 Specifying connection properties

Specify the connection properties.

☐ Right-click on a connection line and select "Properties..." *(see on page 233 “Properties of a connection”).*

☐ On the "Connection" tab page you enter the ports to which the line is connected.  
   Click your way through the tree structure until you can select the port on the device to which you are connecting the line.

☐ Also on the "Connection" tab page, select the properties you want to monitor under "Monitor". In the default setting, Industrial HiVision automatically monitors the connection interruption, network load and port redundancy.
5.4.8 Link types

For clarification purposes, Industrial HiVision represents the links in different ways, according to their character.

<table>
<thead>
<tr>
<th>Representation</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Normal link</td>
</tr>
<tr>
<td></td>
<td>Stand-by link</td>
</tr>
<tr>
<td></td>
<td>Interrupted link</td>
</tr>
<tr>
<td></td>
<td>Radio link</td>
</tr>
<tr>
<td></td>
<td>Stand-by radio link</td>
</tr>
<tr>
<td></td>
<td>Interrupted radio link</td>
</tr>
</tbody>
</table>

*Table 8: Link types*
5.4.9 Representation of the connection medium

Industrial HiVision enables you to identify the medium of a connection based on the icon for the connection ends (see on page 234 “Connection”).

<table>
<thead>
<tr>
<th>Representation</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>■</td>
<td>Copper</td>
</tr>
<tr>
<td>●</td>
<td>Optical</td>
</tr>
<tr>
<td>◆</td>
<td>Wireless, sawtooth line</td>
</tr>
<tr>
<td>□</td>
<td>Unmanaged</td>
</tr>
<tr>
<td>←</td>
<td>Unknown</td>
</tr>
</tbody>
</table>

*Table 9: Representation of the connection medium*
5.5 The Network changing over time

Rarely does your network remain in a static condition. Generally, from time to time new devices are added and other devices removed and then reinserted in other positions.

5.5.1 Adding devices with HiDiscovery

A simple method of adding a new device is to use the HiDiscovery button in the tool bar.

- Click on the HiDiscovery button in the tool bar.
  Industrial HiVision starts a network request.
  Industrial HiVision displays newly detected Hirschmann devices that do not have an IP address yet in the “New Devices” folder.
  Industrial HiVision displays newly detected Hirschmann devices that already have an IP address in the default map for the address range (see on page 258 “Basics: discover devices”).

As described on the previous pages, you can move the new devices among your network folders and create links.
Assigning the IP address

After you have added a new device, e.g. with HiDiscovery, Industrial HiVision gives you an option of assigning an IP address to the device (see on page 321 “IP Configuration”).

- Right-click on the device and select "IP Configuration". With the IP configuration dialog you can enter
  - the device name
  - the IP address
  - the network mask
  - the gateway IP address

5.5.2 Adding devices with network scan

A method of adding a new device with a previously configured IP address is provided by the Scan Network button in the tool bar.

- Click on the Scan Network button in the tool bar.
  Industrial HiVision starts a network inquiry in accordance with the settings under “Basics: discover devices” on page 258. Industrial HiVision displays newly detected devices in the default map for the address range (see on page 258 “Basics: discover devices”).

As described on the previous pages, you can move the new devices among your network folders and create links.

5.5.3 Adding devices manually

Another option for adding a new device is to add the device manually (see on page 111 “Creating new devices”).
As described on the previous pages, you can move the new devices among your network folders and create links.

### 5.5.4 Startup procedure for Hirschmann devices

Industrial HiVision simplifies the startup procedure for Hirschmann devices. Apart from the installation, you can start up Hirschmann devices from your network management station:

- Detect Hirschmann devices using HiDiscovery (see on page 104 “Device detection”).
- Configure the IP parameters (see on page 321 “IP Configuration”).
- Enter the trap destination address (see on page 323 “Trap destination”).
- For a new device, you use the Web interface to change the SNMP password.
- Enter the new SNMP password in Industrial HiVision (see on page 294 “Advanced: Device Credentials”).

### 5.5.5 Interrupting device monitoring

To reduce the load on your network, Industrial HiVision provides you with two options for interrupting the monitoring for individual devices and folders:

- Move the device into the “Unused Devices” folder.
5.5.6 Removing devices

To remove a device

☐ Right-click on the device and select "Delete" in the drop-down menu (see on page 84 “Folder frame”). Industrial HiVision allows you to delete the device or move it into the “Unused Devices” folder.

5.5.7 Exchanging devices

In order to meet the time requirements, by degrees you will have to replace existing devices in your data network with newer devices that have new functions. Industrial HiVision provides a conversion tool for this scenario, with which you can save the configuration of a Classic device as an XML file in a file path. A list of the devices that support this feature can be found on the FAQ page of Hirschmann: https://hirschmann-support.belden.eu.com/link/portal/15045/15054/ArticleFolder/12/Industrial-HiVision

☐ Highlight the Classic device that you want to replace with a HiOS device.
☐ Select Configuration > MultiConfig™.
In the "MultiConfig™" dialog select:
- Device Settings > Advanced > Configuration Saver
- Check the file path, file name and click on "Write"
  Industrial HiVision saves the configuration in an XML-format file.

In the next step, migrate the saved Classic devices configuration to the HiOS device, which you previously installed and created in the network plan.

- Highlight the HiOS device, onto which you want to apply the configuration of the Classic device.
- Select Configuration > MultiConfig™.
- In the "MultiConfig™" dialog select:
  - Device Settings > Advanced > Configuration Migrator
- Select the previously saved XML file using the file selection dialog.
- Check the file path and file names for the log file, in which Industrial HiVision will log the result of the migration and then click "Write".
  Industrial HiVision transfers the migrated configuration from the Classic device onto the HiOS device.
  If the "Status" column in the dialog shows that the HiOS device has rejected the configuration data, you will find information on possible causes in the log file.
  You will find the path to the log file under Configuration > Preferences > Advanced > Load/Save > Configuration Saver.
5.6 Network Documentation

Industrial HiVision provides a number of functions to assist you in the documentation of your network.

5.6.1 Saving Industrial HiVision projects

Industrial HiVision allows you to save your current network data and the configuration of Industrial HiVision in a project file (see “Save” on page 203 and “Save as...” on page 204).

5.6.2 Saving reporting data

Industrial HiVision records the data of the reporting function (see on page 248 “Reporting”) in a separate database outside of the project. You will find this database in the installation directory in the subdirectory report_db. As this subdirectory may contain reporting databases from multiple projects, Industrial HiVision creates a subdirectory for each project therein: <INSTALL_DIR>/report_db/<UUID>/pm.h2.db

You will find the UUID in the help menu in the kernel info.
5.6.3 Exporting the content of the detail display

Industrial HiVision allows you to export the content of the detail display (see on page 206 “Export...”).

☐ Choose File > Export... and select the file type in the "Save" window.

5.6.4 Printing the content of the detail display

Industrial HiVision allows you to print the content of the detail display.

☐ Select File > Print.
   Industrial HiVision creates a temporary PDF file of the content of the detail display and opens this PDF file in the PDF display program, e.g. Acrobat Reader, that is installed on your management station.

5.6.5 Exporting the event list

Industrial HiVision allows you to export the complete event list (see on page 206 “Export Events...”).

☐ Choose File > Export Events... and select the file type in the "Save" window.
5.6.6 Printing the event list

Industrial HiVision allows you to print the complete event list.

☐ Select File > Print Events.
Industrial HiVision creates a temporary PDF file of the content of the detail display and opens this PDF file in the PDF display program, e.g. Acrobat Reader, that is installed on your management station.

5.6.7 Creating device documentation

Industrial HiVision allows you to create device documentation. In the device documentation, Industrial HiVision creates a PDF file for every device selected. The PDF file contains information about the device and its settings.

☐ In the detail window, mark the devices you want to document.

☐ In the menu bar, select Edit > Device Documentation > Document Selected Devices or right-click a selected device and choose "Document Selected Devices".

☐ In the "Choose a directory" window, enter the folder in which you want Industrial HiVision to write the PDF files and click on "Select".

For each device selected, Industrial HiVision writes a PDF file with the name: “inventory_<IP address>.pdf” in this folder.
5.6.8 Printing or exporting the MAC/IP address assignment

Industrial HiVision allows you to create a list of the IP addresses in the project and their related MAC addresses (see on page 226 “MAC/IP addresses of a device”).

- Select Configuration > MAC/IP List.
- Click "Print".
  Industrial HiVision creates a temporary PDF file of the content of the detail display and opens this PDF file in the PDF display program, e.g. Acrobat Reader, that is installed on your management station.
- Click on "Export".
  Industrial HiVision allows you to export the list as:
  - PDF file
  - HTML file
  - CSV file (see on page 366 “CSV export”)

5.6.9 Printing or exporting the status configuration

Industrial HiVision allows you to print or export the status configuration (see on page 313 “Status configuration”).

- Select Configuration > Status Configuration.
- Click on "Print".
  Industrial HiVision creates a temporary PDF file of the status configuration and opens this PDF file in the PDF display program, e.g. Acrobat Reader, that is installed on your management station.
- Click on "Export".
  Industrial HiVision allows you to export the list as:
  - PDF file
- HTML file
- CSV file (see on page 366 “CSV export”)
6 Configuring the network

When you have your network displayed in Industrial HiVision, with your devices and connections, you can configure the devices. The multi-configuration function (MultiConfig™) allows you to perform configurations on the device and in Industrial HiVision for:

- one or more devices
- one or more device properties, also device overlapping
- one or more device details, also device overlapping

You go to the multi-configuration dialog by selecting at least one device or property in the detail display and choosing Configuration > MultiConfig™ in the menu bar.

Note: Keep in mind how this affects your system resources (see on page 176 “Effect on system resources”).
6.1 Using the dialog box

The MultiConfig™ dialog contains 3 frames:
- Web-based, interface-type menu tree
- Object frame
- Function frame

Figure 26: MultiConfig™ dialog overview
1 - Menu tree
2 - Object frame
3 - Function frame
4 - Control elements
6.1.1 Description of the menu tree

In the Web-based, interface-type menu tree, you choose the function that you want to configure. Here you will find functions
- that you configure on the devices
- and properties that you configure for the monitoring in Industrial HiVision

6.1.2 Description of the object frame

The object frame contains a table of the objects that you selected for configuration in the detail display.
In the first row of the table you will find the summary of the statuses of the objects in the table.

The status symbols behind the objects have the following meanings:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>✔️</td>
<td>Industrial HiVision has read the values of the parameters and displays the matches in the function frame.</td>
</tr>
<tr>
<td>❓</td>
<td>Action initiated but not started yet.</td>
</tr>
<tr>
<td>🔄</td>
<td>Industrial HiVision is reading/transferring the values of the parameters.</td>
</tr>
<tr>
<td>🤔</td>
<td>Move the mouse pointer over the symbol to obtain information about any peculiarities. A peculiarity could be, for example, that a table contains hidden entries. These hidden table entries are lost when data is written.</td>
</tr>
<tr>
<td>⚠️</td>
<td>Industrial HiVision can reach the device. One or more values are missing from the transfer. Move the mouse pointer over the symbol to obtain information.</td>
</tr>
<tr>
<td>❌</td>
<td>The objects have not supplied any values. The connection to the device is interrupted. Move the mouse pointer over the symbol to find out the reason why you cannot read/write the values.</td>
</tr>
</tbody>
</table>

*Table 10: Meaning of the status symbols*
6.1.3 Description of the function frame

In the function frame, Industrial HiVision provides a selection of parameters and actions. Industrial HiVision chooses the configurable parameters and executable actions that represent an intersection of the selected objects and the selected function.

As the number of variations for representing the parameters is too large, you will find additional application examples later on (see on page 141 “Examples for using the multi-configuration”).

You use the selection field on the left side of the function frame to select the parameters you want to configure.

The symbols beside the selection fields, if there are any, have the following meanings (see table 11).

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>📄</td>
<td>The objects read have different values for this parameter.</td>
</tr>
<tr>
<td>🗞️</td>
<td>The object selected has no value for this parameter.</td>
</tr>
<tr>
<td>📚</td>
<td>Some objects have no values for this parameter.</td>
</tr>
</tbody>
</table>

Table 11: Meaning of the symbol beside the selection fields

To simplify entering settings that reoccur, Industrial HiVision allows you to create default settings (see on page 142 “Using contact person with default setting”).
Because the MultiConfig™ function provides a range of input options on different device types, Industrial HiVision allows any values to be entered in the input fields. If Industrial HiVision detects an inconsistency during entry, Industrial HiVision changes the font color to red.

To load or save files, enter a path in the respective dialogs describing the storage location of the file. Industrial HiVision can handle absolute and relative paths. A relative path begins with `<Install-Dir>/service`. 

Figure 27: Default setting for the multi-configuration function.
6.1.4 Description of the control elements

- **Write**
  With "Write" Industrial HiVision transfers the data for the parameters selected to
  - all the objects contained in the table of the Object frame.
  - the objects with an error status contained in the table of the Object frame.
  - all the objects without an error status contained in the table of the Object frame.
  You select the objects you want to write to in the Object frame under "Write Mode".
  When you write configuration parameters on devices in this way, these parameters are located in the temporary memory of the devices. To save the device configuration data, the last configuration step you perform is to save the new configuration on the devices.

- **Reload**
  With "Reload", Industrial HiVision transfers the data in the selected parameters from the objects contained in the table of the object frame.
  To display the values of the parameters for an object, click on the object in the object frame.

- **Cancel**
  With "Cancel" Industrial HiVision closes the dialog. Changes that you entered after the last write command are lost.
  Actions that have already started 🔄 are completed by Industrial HiVision.

- **Help**
  With "Help" Industrial HiVision opens the online help on the relevant page.
  If an example exists for the opened dialog (see on page 141 “Examples for using the multi-configuration”), then Industrial HiVision opens the online help on the page for the example.
6.2 Examples for using the multi-configuration

Depending on the menu item you select, you will find different representations in the function frame. The following examples show you the different representations.

6.2.1 Same contact person on multiple devices

You want to enter the same contact person, e.g. Michael, on multiple devices.

☐ In the detail display, choose the topology view or another view that displays devices.
☐ Select the devices on which you want to enter the same contact person.
☐ To open the MultiConfig™ dialog, right-click on a selected device and choose “MultiConfig™”.
☐ In the MultiConfig™ dialog, choose
Device Settings > Basic Settings > System
in the menu tree
You will then find the table with the related devices in the object frame, and the configurable parameters in the function frame.

Displaying current parameter values

☐ To display the values of the parameters for an device, click on a row of the table in the object frame.
☐ To display the values of the parameters that are the same on each device, click on the first row "All Objects" of the table in the object frame.
### Writing contact persons on devices
- Select the selection field in the "Contact" row.
- Enter the name of the contact person, e.g. Michael, in the "Contact" field.
- To transfer the change to the devices and temporarily save them there, click "Write".
- To save the change on the devices into the permanent memory, choose Device Settings > Basic Settings > Load/Save, in the menu tree, choose the action "Save to Device" and click "Write".

### Using contact person with default setting
Industrial HiVision allows you to create a name as the default setting so that you do not have to enter the name again when configuring additional devices later on.
- Select the selection field in the "Contact" row.
- Enter the name of the contact person, e.g. Michael, in the "Contact" field.
- Select the "Edit Presets" selection field. Industrial HiVision now opens the preset table.
- Click "New" beside the preset table to enter the selected parameters under the table as presets in the table.
- To give the new table entry a meaningful name, double-click the name cell for this entry and enter the name, e.g. “Contact person Michael”. Click on the enter button to take over the change.

From now on, you can select the “Contact person Michael” preset instead of having to select and enter the name.
- To change an existing table entry, select the desired row, change the parameters, and click "Set".
- To select an object in the Object frame, deselect "Edit Presets" in the Function frame.
6.2.2 Software update on similar devices

You want to perform a software update on a number of similar devices.

- In the detail display, select the device view.
- Select the Device Class.
- Select the devices on which you want to perform the software update.
- To open the MultiConfig™ dialog, right-click on a selected device and choose “MultiConfig™”.
- In the MultiConfig™ dialog, choose
  Device Settings > Basic Settings > Software in the menu tree.
  You will then find the table with the related devices in the object frame, and the settings for the update in the function frame.
- To open the file selection screen, click on “..” in the function frame. Select the software update file or use drag & drop to pull it into the row and click on “Open”.
- Select the selection fields in the "Update" and "File" rows.
- Click "Write" to transfer the update to the devices.
  In the object frame, the ✔️ symbol in the "Status" column informs you that the transfer was successful.
- To activate the new software on the devices, perform a cold start on the devices:
  (see on page 144 “Restarting multiple devices”)
6.2.3 Restarting multiple devices

With its MultiConfig™ function, Industrial HiVision offers the option of initiating a restart on multiple devices. Industrial HiVision distinguishes between a successive "Restart (consecutively)" and a concurrent "Restart (simultaneously)".

- **Restart (consecutively)**
  Industrial HiVision sends a restart command to a device and waits until the device has executed the restart. Then Industrial HiVision sends the restart command to the next device.
  You select this method if the devices you want to start are connected to the network management station in a line.

- **Restart (simultaneously)**
  Industrial HiVision sends the restart command to the devices to be started nearly simultaneously. You select this method if the network management station accesses the devices directly.
  Note: Restarting a device interrupts the transfer. This means that some devices may not receive the restart command.

- In the MultiConfig™ dialog, select
  Device Settings > Basic Settings > Restart (consecutively) or
  Device Settings > Basic Settings > Restart (simultaneously) in the menu tree.
  In the object frame, you will now find the restart options for the devices.
- Select the selection field, e.g. in the "Cold Start" row after a software update.
- Click "Write".
6.2.4 Loading/saving the configuration for multiple devices

Depending on the devices you have selected, Industrial HiVision gives you multiple options for transferring configurations:

<table>
<thead>
<tr>
<th>Action</th>
<th>Load/Save</th>
<th>Load/Save via PC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save on device</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Copy the current configuration from the non-volatile memory of the device to the permanent memory of the device.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save on tftp server (binary)</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Copy the current configuration in binary form from the non-volatile memory of the device to the specified URL.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save on tftp server (script)</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Copy the current configuration as an editable and readable script from the non-volatile memory of the device to the specified URL.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Load from device</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Copy the configuration from the permanent memory of the device to the non-volatile memory of the device.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Load from tftp server</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Read the configuration from the specified URL to the non-volatile memory of the device.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Load from tftp server and save on device</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Read the configuration from the specified URL to the non-volatile and permanent memories of the device.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Delete: current configuration</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Overwrite the configuration in the non-volatile memory of the device with the configuration in the permanent memory of the device.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Delete: current configuration and from device</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Delete the configuration in the non-volatile memory of the device and the configuration in the permanent memory of the device, and replace with the configuration from the state on delivery. After the next restart, the IP address is also in the state on delivery.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save on PC (script)</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Copy the configuration as an editable and readable script from the non-volatile memory of the device to a file on the PC.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save on PC (binary)</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Copy the configuration in binary form from the non-volatile memory of the device to a file on the PC.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Table 12: Transfer options for configurations*
In the detail display, choose the topology view or another view that displays devices.

Select the devices on which you want to save a configuration, or from which you want to load a configuration.

To open the MultiConfig™ dialog, right-click on a selected device and choose "MultiConfig™".

In the MultiConfig™ dialog, choose

- Device Settings > Basic Settings > Load/Save in the menu tree or
- Device Settings > Basic Settings > Load/Save via PC

You will then find the table with the related devices in the object frame, and the options for transferring the configuration in the function frame.

### Table 12: Transfer options for configurations

<table>
<thead>
<tr>
<th>Action</th>
<th>Load/Save</th>
<th>Load/Save via PC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Load from PC (script)</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Read the configuration from a file as an editable and readable script from the PC to the non-volatile memory of the device.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Load from PC (binary)</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Read the configuration from a file in binary form from the PC to the non-volatile memory of the device.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Load/Save
Select a selection field by clicking on the desired transfer type.
Load/Save via PC
Select the selection field in the “Action” row by choosing the desired transfer type.
Select the selection field "File" / "URL" and enter the file name with the complete path, e.g. "File"
D:\Data\Network Management\Configurations/$CURRENT-DATE/$IP_ADDRESS.$EXTENSION
or the "URL"
tftp://10.0.1.159/configs/2009_10_28/$IP_ADDRESS.cfg
Industrial HiVision allows you enter a file name and a URL in the settings (see on page 309 “Advanced:Load/Save”).
Industrial HiVision automatically takes over this file name(URL when it opens the MultiConfig™Support Info Speichern- dialog.
When writing the data, Industrial HiVision creates any subfolders that are missing.
To transfer the data, click "Write". In the object frame, the ✔️ symbol in the "Status" column informs you that the transfer was successful.

6.2.5 Configuring a trap destination on multiple devices
You want to configure the same trap destination on multiple devices.
In the detail display, choose the topology view or another view that displays devices.
Select the devices on which you want to configure the same trap destination.
To open the MultiConfig™ dialog, right-click on a selected device and choose “MultiConfig™”. 
6.2 Examples for using the multi-configuration

- In the MultiConfig™ dialog, choose Device Settings > Diagnostics > Status Config > Trap Destinations in the menu tree.
  You will then find the table with the related devices in the object frame, and the table for the trap destinations in the function frame.
- To create a new entry in the table, click "New".
- Enter the IP address of the trap destination, select the active status and click "OK".
  In the table you will find the rows with the new trap destination.
- To transfer the change to the devices and temporarily save them there, click "Write".
- To save the change on the devices into the permanent memory, choose Device Settings > Basic Settings > Load/Save, in the menu tree,
  choose the action "Save to Device" and click "Write".

6.2.6 Saving support info for multiple devices

You require help from the support team. To process your request, the support team requires as much information as possible about your network and the network components installed.
This dialog allows you to gather this information very effectively.
- In the detail display, choose the topology view or another view that displays devices.
- Select the devices for which you want to save the support information.
- To open the MultiConfig™ dialog, right-click on a selected device and choose "MultiConfig™".
- In the MultiConfig™ dialog, choose Device Settings > Diagnostics > Save Support Info in the menu tree.
  You will then find the table with the related devices in the object frame, and the options for transferring the configuration in the function frame.
- Select the selection field in the "Save Support Info" row by clicking on the field.
Select the selection field "File" and enter the file name with the complete path, e.g. "File"
D:\Daten\Netzmanagement\supportinfo/$CURRENT-DATE/$IP_ADDRESS.$EXTENSION
Industrial HiVision allows you enter a file name and a URL in the settings (see on page 309 “Advanced:Load/Save”).
Industrial HiVision automatically takes over this file name when it opens the MultiConfig™"Save Support Info" dialog.
When writing the data, Industrial HiVision creates any subfolders that are missing.

To transfer the data, click "Write".
In the object frame, the ✓ symbol in the "Status" column informs you that the transfer was successful.

Depending on the device type and the firmware version, Industrial HiVision writes a selection of the following files for every device selected:
- *audittrail.html
- *config.cli
- *config.xml
- *dump.hmd
- *eventlog.html
- *exception_log.html
- *runningConfig.txt
- *runningConfigAll.txt
- *switch.cfg
- *systeminfo.html
- *trapLog.txt

6.2.7 Configuring firewall rules on multiple devices

The server for the virus update files requires you to release another port in the firewalls of your company. For this, you want to add a new 1st rule for the relevant firewalls that releases this port.
Creating a new rule as an initial setting

- In the detail display, choose the topology view or another view that displays devices.
- Right-click on a firewall device to which you want to add this rule and select “MultiConfig™”.
- In the menu tree of the MultiConfig™ dialog, select the relevant packet filter.
- In the function frame of the MultiConfig™ dialog, select "Edit Presets".
- To save an initial setting for the existing rules, click "New" in "Edit Presets".
  - If you want to save the entire content of the table as a rule set, deselect the rules in the table.
  - If you want to save individual rules as a set, select these rules.
  - Give a meaningful name to the initial setting by double-clicking on the name. After you have entered the name, e.g. “Existing rule set”, click on the enter button.
- After you have just saved the existing rules as a rule set in an initial setting, delete the existing rules.
- To create the new rule for the port release, you define the new rule, or if required, multiple rules.
- To save the newly created rule - for multiple rules, the rule set - as an initial setting, click "New" in "Edit Presets".
  - Give a meaningful name to the initial setting by double-clicking on the name. After you have entered the name, e.g. “Virus update”, click on the enter button.
- To restore the original rules again, click on the initial setting “Existing rules”.
- To apply the data, click "Write".
  - In the object frame, the ✓ symbol in the "Status" column informs you that the transfer was successful.

After these actions, the firewall device is in its original state again, and the preset “Virus update” is saved in Industrial HiVision.

Close the MultiConfig™ dialog.

Adding a new rule to the relevant firewall devices

- In the detail display, choose the topology view or another view that displays devices.
- Select the firewall devices to which you want to add this rule.
Right-click on a selected firewall device and select “MultiConfig™”.

To add the new rule for the port release as the first rule, you select the first rule.

With "Edit Presets" deactivated, select the preset “Virus update” in the selection list.

Industrial HiVision inserts the rules with the preset “Virus update” before the selected rule.

**Note:** Industrial HiVision allows you to insert new rules before the last rule if the rules on the devices in this dialog are identical.

To apply the data, click "Write".

In the object frame, the ✓ symbol in the "Status" column informs you that the transfer was successful.

Close the MultiConfig™ dialog.

### General information on inserting rules

► **Edit Presets activated:**

Mode for displaying and editing rules

- To display a preset in the bottom frame, you click on the rule.
- To save the rules from the bottom frame as a preset setting, click "New".
- To change a preset, you click on the preset. Edit the rules in the bottom frame. Confirm the action with "Set".

► **Edit Presets deactivated:**

Mode for inserting and adding rules.

- To add rules from an initial setting to the rules in the bottom frame, select the row above which you want to insert the rules in the bottom frame, and select your desired initial setting.
- To add rules from an initial setting to the end of the rules in the bottom frame, deselect the rows in the bottom frame and select your desired initial setting.
6.2.8 Configuring the Industrial HiVision property

The availability of your transmission component has the highest priority. Therefore, you want Industrial HiVision to keep you informed if the redundancy of the supply voltage is missing. In the standard status configuration of the power unit status of Industrial HiVision

- Industrial HiVision assigns the status “OK” to the value “Not installed”.
- Industrial HiVision assigns the status “No status” to the value “Not available”.

However, in both cases you want to receive the status “Warning”.

☐ In the detail display, select the "Properties" view.
☐ Under "Property:", choose the property "Status" ("Power Supply").
☐ In the table you select the power units for which you want to change the configuration.
☐ To open the MultiConfig™ dialog, right-click on a selected row and choose "MultiConfig™".
☐ In the MultiConfig™ dialog, choose "Status Config" in the menu tree.

You will then find the table with the related devices in the object frame, and the options for setting the status configuration in the function frame.

☐ Select the selection fields in the "Value" = "Not Installed" and "Value" = "Unavailable" rows by clicking on the fields.
☐ In the selection fields for the two rows, choose the status "Warning".
☐ To save the change in Industrial HiVision, click "Write".

6.2.9 Saving reference values for each device

The multi-configuration function provides support when processing the same values on several devices, and also when processing individual values for several devices. An example can be found at “Configuration signature check” on page 157.
7 Monitoring the network

The basic settings of Industrial HiVision enable you to begin with the monitoring immediately after you set up the network plan. Important components for modifying the settings relating to the network monitoring are:

- Security-relevant settings
- Status configuration
- Status determination
- Trap target address
- Status forwarding
- Event actions
- History

You will find an overview of the monitored components under “Monitor” on page 245.

You will find settings for monitoring the properties of a folder/device, a component or a connection in the chapters

- “Properties of a folder/device” on page 221
- “Properties of a connection” on page 233
- “Properties of a component detail” on page 227
7.1 Improving security on the network

An IT network offers many attack targets for uninvited intruders. Awareness of potential security vulnerabilities and consistent closing of these security gaps enhance the security of your network. Industrial HiVision gives you a convenient approach to configuring security-relevant settings. The following sections show you step-by-step details how Industrial HiVision helps you to improve the security of your network.

7.1.1 Password-protecting devices on your network

Configurable network switching devices such as hubs, switches, routers, firewalls, and wireless access points are attack targets for potentially causing damage to your network.

- Make it more difficult to access network switching equipment management features, by assigning effective passwords to these devices.

Industrial HiVision gives you a multiple configuration feature that lets you assign the same password to multiple devices in a single step. But keep in mind that access protection improves with each individually assigned password.

- Assign new passwords to these devices periodically. Select effective passwords.
7.1.2 Security status view and configuration

Security Status
In the detail display "Security Status", Industrial HiVision provides an overview of the security properties of the devices in the selected folders. The "Status" column shows the critical condition of a property in this line. The symbols have the following meanings:

- this property was not queried
- the results of querying this property comply with the general security policies
- the results of querying this property infringe on general security policies. Please check the settings against your general security policies.
- "-" means, that the device does not possess this function.

To configure the properties that you want Industrial HiVision to monitor, make selections in the "Configure Monitoring" table. The selected properties are reflected as results in the Status column. The properties of the following columns can be found dependent on the device in the device sub-folder "Security" for the respective devices:

- Tftp
- Profinet IO
- IEC61850
- ANY Rule Status
- SNTP/NTP Status
- Telnet
- HiDiscovery
- Http
- 802.1X Port Access Control Enabled
- Restricted Management Access
- Ethernet/IP
- SNMP V1/V2
- Unused Active Ports
- Default Password

Industrial HiVision queries these properties cyclically (default setting: 24 hours). Clicking on "Refresh" instantly imports Industrial HiVision the values.
The "ANY Rule Status" property is available for firewall devices. The AND-conjunction fulfillment of the following settings in the firewall rules for incoming and outgoing traffic lead to the "Warning" status:

- Source IP (CIDR) = "any"
- Destination IP (CIDR) = "any"
- Source Port = "any"
- Destination Port = "any"
- Protocol = "any"
- Action = "Accept"

In order to increase the security of your network, the multi-configuration function gives you the option of changing several properties with the "warning" status with one operation.

- Highlight the device rows in the table, where you want to perform changes and right click "MultiConfig™".
  The "Security Lockdown" dialog under "Device Security" enables you to carry out several security settings at once.
- To check the affected settings in the "Security Status" dialog, refresh the display by clicking on "Refresh". The altered properties should now display the status 🌡.

### 7.1.3 Security-related settings of devices on the network

#### Disabling HiDiscovery

The HiDiscovery protocol gives you the ability to assign a device a device name and IP parameters via Ethernet.
To keep this assignment as easy as possible, HiDiscovery does without mechanism for restricting access to the devices.

To restrict unauthorized modifications to IP parameters and devices names of the devices on your network, disable HiDiscovery on these devices as soon as you finish configuring the devices. The multi-configuration function enables you to deactivate HiDiscovery on several devices in a single step. Highlight several devices and right click on MultiConfig™. Under Device Settings > Basic Settings > Network > Global you will find the "HiDiscovery Enable" button to disable HiDiscovery.

## Configuration signature check
Classic devices from Hirschmann supply device configurations with an individual configuration signature. HIOS devices from Hirschmann provide device configurations with an individual fingerprint.

The configuration signature changes every time you save a configuration on the device, even if the existing configuration remains the same. The fingerprint changes when you save a configuration on the device and the existing configuration is altered.

The device saves the randomly generated configuration signature / fingerprint together with the configuration. Industrial HiVision allows you to monitor the configuration signature / fingerprint. You are consequently in the picture if someone changes the configuration of a device.

To select the devices with a configuration signature / fingerprint, switch to the detail view in the "Properties" tab. Select the "Configuration Signature" Property:" via the table in the row

Highlight the devices in the table, where you want to monitor the configuration signature / fingerprint.

Right-click on the selection and select "MultiConfig™".

In the "MultiConfig™" menu tree, click on the "Status Config" dialog.

In the "MultiConfig™" function frame, click on the "Set current to reference" dialog.

In the "Reference Value" frame, select the status, which the property is supposed to adopt, if a current value is different from the reference value.

To adopt the current configuration signature / fingerprint as a reference in Industrial HiVision click "Write".


7.1 Improving security on the network

### Port Security
The port security feature allows you to specify, which device is permitted to send data to this port. Thus enabling you to block the receipt of data from other devices.
The "MultiConfig™" dialog from Industrial HiVision provides support while configuring the port security feature of Classic devices.

### Loading device certificates / keys
When you want to communicate with a device, in some circumstances you want to know whether you are really communicating with the genuine device. Certificates exist to verify the authenticity of devices. Certification Authorities (CA) provide such certificates, e.g. Verisign, Symantec. Some companies maintain their own institution with a separate server, which issues proprietary certificates.
Industrial HiVision allows you, using the "MultiConfig™" dialog, the opportunity to upload certificates to devices. Using a separate certificate for each device, provides you with greater security than if you were to use one certificate for several devices.

- Right-click in the topology view on the device, whose certificate you want to upload to the device and select "MultiConfig™".
- In the menu tree of the MultiConfig™ dialog, you will find the dialogs for uploading the certificates/keys under Device Settings > Device Security > Management Access > Server.

7.1.4 Configuring security-relevant settings on the network

### Security Lockdown
The "Security Lockdown" function (access restrictions) gives you the ability to apply security features that already exist on Hirschmann devices at the push of a button on the managed or selected devices.
The degree of restriction is oriented on the current conditions in the network. In other words, current network operations will be maintained, but additional access will be restricted.

The "Security Lockdown" function includes the following security functions, assuming they are supported by the devices:

- **Restricted management access**
  Industrial HiVision restricts management access to the devices at the network management station. In as-delivered condition, any IP address is open to access.

- **Port security**
  Industrial HiVision enables the port security feature on ports associated with a MAC address.
  If the MAC address is invalid for a connection, e.g., due to a timeout, the device performs a selectable and configurable action. Such an action could for example, send a trap to the network management station.
  This function is disabled in as-delivered condition.

- **Port security action**
  If the device detects an unauthorized access attempt, the device performs the action that you configured previously.
  The possible actions are:
  - Do nothing
  - Disable port
  - Send trap
  - Disable port and send trap

- **Disable unused ports**
  Industrial HiVision disables the unused ports on a device.

- **Disable unused slots**
  Industrial HiVision disables those slots of a modular device on which the device does not discover a module.

- **Disable unsecure protocols**
  Various protocols are used to access devices on the network for management. Industrial HiVision disables the protocols that are considered to be unsecure. Protocols considered to be unsecure include: HTTP, Telnet, SNMPv1, SNMPv2, HiDiscovery. The SNMPv3 function is maintained.

The "MultiConfig™" feature gives you the ability to configure the "Security Lockdown" function for several devices together in a single step.

- **To access the "Security Lockdown" dialog, select the device view in the detail view.**
- **Select the device class to configure.**
To open the "MultiConfig™" dialog, select the devices to be configured. Right click a selected device and select "MultiConfig™".


The "Security Lockdown" function has the following restrictions:
- The "Port Security" function is unavailable for the Eagle and BAT devices.
- The "Disable Unused Slots" function is only available for the modular P4 and P5 devices.
- The "Disable Unused Slots" function is the only available function for the GarrettCom RX10 devices.
- The “Restrict Management Access”, “Clock Synchronization”, and “HiDiscovery” functions are available for the following devices:
  - The “Classic” devices starting with Version 09.0.01
  - The “HiOS” devices starting with Version 06.0.00
  - The “HiSecOS” devices starting with Version 03.0.00

Comparing IP/MAC address pairs
Attackers often use their own devices to gain access to your data network. To do this, the attacker uses the IP address of an existing device that is currently switched off, or a free IP address on the subnet they want to intrude into.

However, the MAC address of the attacker's own device will differ from the MAC address on the device whose IP address the attacker is spoofing.
Industrial HiVision gives you the ability to track down this kind of attacker with the help of this feature.
To do this, Industrial HiVision collects the IP/MAC address pairs of the connected devices. Industrial HiVision lists the IP/MAC address pairs it collected in a table. You can manually extend this table with user-defined entries.
Industrial HiVision gives you the ability to automate the process of regularly checking the content of this table against the live IP/MAC address pairs on your network. If Industrial HiVision detects a difference, Industrial HiVision notifies you in line with the action you defined.

Make the relevant settings in order to monitor the IP/MAC address pairs.

See “MAC/IP Address Pair Security” on page 319.
Detecting rogue devices

A rogue device is a device accessing a part of the network where it does not belong.

Let's assume that you completed the configuration of your data network in Industrial HiVision, and Industrial HiVision has the valid topology for your devices and device connections. This is the right time to freeze this state in Industrial HiVision.

Industrial HiVision then gives you the ability to reference the frozen state and identify intruders on your data network.

When you activate this function, Industrial HiVision stores an image of the topology.

But how do you deal with new devices on your data network beyond the existing installation? These new devices could pose a potential risk to your data network. This is why the "Rogue Device Detection" function has a special procedure for these devices.

☐ After initially setting up Industrial HiVision, activate the "Rogue Device Detection" feature under Configuration > Preferences > Basics > Discover Devices > Discovery Mode.

  – Industrial HiVision lists any newly detected devices in the "Rogue Devices" folder. Since you consciously create manually entered devices in a certain folder, Industrial HiVision leaves manually entered devices in the relevant folder.
  – When Industrial HiVision lists a new device in the "Rogue Devices" folder, Industrial HiVision generates both a "New device detected" event and a "Rogue Device Detection" event.

☐ You can use a "Event Actions", or a "User defined Actions", to define how Industrial HiVision should react to a new device appearing in the "Rogue Devices" folder.
7.2 Status configuration

The status configuration specifies which status is assigned to the value of the component detail. Possible statuses are:

- OK,
- Warning,
- Error, and
- No Status.

Example:
You can assign the status "OK", "Warning" or the status "Error" to a connection break.
In the case of a terminal device that you regularly turn off, a connection break (device switched off) is not an error.
In the case of a server that should be available, a connection break is a serious error that should be monitored.

Industrial HiVision allows you to perform the status configuration of a component detail device overlapping for the devices in a device class (see on page 313 “Status configuration”).

If you want to change the status configuration of individual devices, you will find access to the status configuration in the Properties window of a component detail. The status configuration allows you to enter status configuration settings for each component detail (see on page 227 “Properties of a component detail”).

A pre-condition for determining a status is monitoring a component detail. When it monitors a component detail, Industrial HiVision queries the value periodically. Industrial HiVision assigns a status to this value as part of the determination.

In the state on delivery, the status configurations are set so that you can monitor your network properly right after the installation.
7.3 Status determination

To monitor your network, your network management station requires information from the components of the network. To acquire this information,

- the network management station can query the components periodically
- or
- the components send information (traps) on their own initiative to the network management station.

- Periodic querying (polling)
  Depending on the size of the network and the querying frequency, periodic querying can lead to significant loss of available bandwidth. In the case of, for example, short-term overloading of the network, an answer or a trap can get lost. An advantage of periodic querying is the high probability that the network management station will receive an answer when it makes the next query.

- Traps
  As soon as a device detects a status change, it sends an alarm message (trap) to the network management station. Since the device only sends a trap if there has been a status change, this method has little effect on the network load. However, if a packet gets lost, the network management station may not be informed of the status change.
7.3.1 Trap destination address

To send alarm messages, a device needs the IP address (= trap destination address) of the network management station, to which it sends any alarm messages that arise. You can enter the trap destination address directly on the device via, for example, the Web-based interface, or more straightforwardly using Industrial HiVision (see on page 323 “Trap destination”).

Right-click on the device and select "Trap Destination" in the drop-down menu. The trap configuration dialog opens up. Select "Send Traps" and click "Write".

7.3.2 Updating device status

Industrial HiVision displays the status that the device had at the time of the device detection, or the status from the received traps or status queries.

Refresh allows you to read in the properties again.
7.4 Status propagation

The status propagation specifies whether the status is propagated to the next highest level.

Figure 28: Status propagation to a higher level
0 - Lowest level = component detail
1 - 1. higher level
2 - 2. higher level
3 - 3. higher level
4 - 4. higher level
5 - 5. higher level
6 - 6. higher level
A folder takes the worst status that the content of a component is showing. The evaluation is based on the following sequence:

- Error (worst status)
- Warning
- OK
- Not Available
- No Status

You specify the meaning of the color assignment at Configuration > Preferences > Display > Status Colors.

In the properties window of the relevant component, you specify the determination of the status and the propagation. The component can also be a folder in the folder frame.
7.5 Management actions

In addition to passive observation of the network, network monitoring also consists of active intervention into network events. Active intervention manifests itself in the response to events in the network or administrative actions such as switching ports on and off according to a schedule.

7.5.1 Event actions

Industrial HiVision allows you to react automatically to events such as a status change.

- Select Configuration > Preferences > Basics > Event Actions
  or click "Preferences" in the tool bar and select Basics > Event Actions.

The automatic reaction options (see on page 266 “Basics: Event Actions”) provided by Industrial HiVision are:

- Popup Message Box
- Send SMS
- Send Email
- Run Executable
- Play Sound
- Push Notification

In the second frame of this dialog, Industrial HiVision enables you to assign a selected reaction to an event.
7.5.2 Time-linked actions

Industrial HiVision offers you the opportunity to set a time period during which Industrial HiVision responds to an event with an action.

- Select Configuration > Preferences > Basics > Event Actions or click "Preferences" in the tool bar and select Basics > Event Actions.

- Create a new entry in "Alarms". The "Time" frame in the "Alarms" dialog gives you the option of defining a fixed period with a fixed start and end point.

7.5.3 Industrial HiVision “I'm alive” event

Industrial HiVision enables you to receive an “I'm alive” event from Industrial HiVision when using remote monitoring.

- Select Configuration > Preferences > User defined Actions or click "Preferences" in the tool bar and select Basics > User defined Actions.

- Define an action that Industrial HiVision is to perform as an “I'm alive” event, e.g. send an SMS. (see on page 266 “Basics:Event Actions”)

- Define an alarm that triggers Industrial HiVision to perform the action. (see on page 266 “Basics:Event Actions”)

7.6 Time-related recordings

Industrial HiVision allows you to record time-related values from properties in various databases:
- in a project database (history)
- in a separate report database (report)

With the size of a database the access time for the database increases. For this reason, Industrial HiVision restricts the number of history entries that can be recorded to the project database.

7.6.1 History

To monitor your network over a user-specified period of time, Industrial HiVision allows you to log states with time information. You will find settings for logging and displaying the history in the properties dialogs
- "Properties of a connection" on page 233 and
- "Properties of a component detail" on page 227.

Configuring the protocoling

The Properties dialog of a component detail and the connection dialog of a connection enable you
- to switch on the protocoling of the history
- to enter the recording/querying interval
- to enter the maximum number of entries recorded. When the maximum number of entries is reached, Industrial HiVision throws out the oldest entry when a new one is recorded.

100 entries (= default setting) take up approx. 5 kByte of your hard disk capacity.
### Network load

Double-click on a link to open the history window. There you will find for each data direction a graphic representation of the network load.

*Figure 29: Network load*

If no ports are assigned to the link yet, you can double-click on the link to open the dialog for assigning the ports.

If you activated polling of the threshold values in the properties dialog of a link, then the graphical display shows the threshold lines.

### 7.6.2 Reports

The reporting function allows you to manage long-term statistics outside the database of the network management system program. Industrial HiVision stores values from properties with time information in a special report database.

To evaluate the recorded values, the reporting function allows you to output reports in the form of graphics and tables.
Note: Depending on your settings, Industrial HiVision can collect any amount of data and save it on your hard drive. Make sure that your hard drive has sufficient free memory space.

Application example for temperature monitoring

You want to monitor the temperature fluctuation within a switch over the course of a 5-day work week for a period of several weeks. Industrial HiVision should generate a report for each week. You would like to have the first report on Sunday, October 7, 2012 and further reports at weekly intervals.

Add the temperature property to reporting:
- To go to the properties level, double-click on the desired switch in the topology display.
- Right-click on the icon for the temperature property. Select "Add to Reporting...".
  Industrial HiVision opens a dialog for entering the reporting parameter.
- Enter October 1, 2012, 12:00 am as the recording start time.
  Press the Enter key to close the date dialog.
  Set the recording start time no later than the time at which the report requires the first entry.
  Retain "Indefinite" as the recording stop time.
  Choose a polling interval as large as possible, but short enough that Industrial HiVision is able to record the expected fluctuations.
  Enter 10 minutes as the "Polling Interval".
  Click "OK"

Create a template for the report:
A template defines the appearance of the report to be generated. In this example, you want the report to be a line graph in a PDF file.
- Select Configuration > Reporting in the menu bar.
- In the "Reporting" dialog, select the "Templates" tab.
- To create a new template for your report, click "New".
- Enter the parameters for the template (see table 13):
- Click "OK"

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Name</td>
<td>Temp. SW1</td>
</tr>
<tr>
<td>Report Header</td>
<td>Temperature fluctuation in switch 1</td>
</tr>
</tbody>
</table>

Table 13: Defining a new template
Create scheduling for the report:
With the scheduling function, you define the points in time at which you want Industrial HiVision to create reports as well as the time period the report should cover.

- In the menu bar select Configuration > Reporting.
- In the Reporting dialog, select the "Scheduling" tab.
- To create a new schedule for your report, click "New".
- Enter the parameters for the template (see table 14):
- Click "OK"

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Name</td>
<td>Temp. SW1</td>
</tr>
<tr>
<td>Recurring</td>
<td>This type of scheduling generates successive reports.</td>
</tr>
<tr>
<td>Duration</td>
<td>5 days</td>
</tr>
<tr>
<td>Offset to Execution</td>
<td>6 days, as you want the report to include data from Monday through Friday and the first generation of the report is to take place on Saturday.</td>
</tr>
<tr>
<td>First Execution</td>
<td>Sunday, 7 October 2012, 00:00:00 am CET</td>
</tr>
<tr>
<td>Repeat</td>
<td>1 week</td>
</tr>
</tbody>
</table>

*Table 14: Defining a new schedule*
7.7 User-defined properties

To use this function you require advanced knowledge of SNMP MIB and the device.

7.7.1 Description of user-defined properties

In the state on delivery, Industrial HiVision already recognizes a large number of devices and their properties. With the "User defined Properties" function, Industrial HiVision allows you to include additional properties from the MIB of SNMP-capable devices in the management. In this way you can add and monitor the properties of any SNMP-capable devices in Industrial HiVision. You can also add additional properties from MIB to devices already recognized by Industrial HiVision and monitor them.

7.7.2 Application example for user-defined properties

In a sensitive network, you want to use ICMP packets to monitor the load on the network components. If a device receives more than 10 ICMP requests within 5 minutes, you want Industrial HiVision to output a warning.

☐ To inform Industrial HiVision about this new property, you select the Configuration > User defined Properties dialog.

☐ In the "User defined Properties" dialog, click "New" to create a new entry with a new property.
In the "Name" field, give the new property a unique name, e.g. `UserDef_ICMP-Message`. Here Industrial HiVision expects a name that starts with "UserDef_".

In the "Label" field, enter an identifier for this property that Industrial HiVision will display in the user interface, e.g. `ICMP-Watch`.

Select "Parent Property", e.g. "Agent".

In the "MIB Variable/OID" field, enter the MIB variable of the new property. Alternatively, the MIB Manager allows you to search for the MIB variables in the MIB of the device:
- Click on the 3 dots to open the MIB Viewer.
- Click on "MIB Manager" to get an overview of the MIBs that the MIB Viewer has loaded.
- To load additional MIBs into the MIB Viewer, click "Load..." and select the desired MIB in your file system.
- Click "OK" to close the MIB Manager.
- In the MIB Viewer, you can now open the path `org:dod:internet:mgmt:mib-2:icmp` to select the MIB variable `icmpInMsgs`.

In the "Instance" field, enter the instance of the MIB variables, in this case 0.

Select the "Type" of the property, e.g. "Delta".
7.7 User-defined properties

To finish defining the property, click "OK". You can now see the new defined property in the "User defined Properties" window.

To close the "User defined Properties" window, click "OK".

Now go to the list view from the detail display.

In the list view, select the agent of the device that you want to monitor.

To open the "New Property" window, right-click on the list view and select New > Property.

To close the window again, select the newly-defined property “ICMP Watch” in the "New Property" window and click "OK".

You have now assigned the new property “ICMP Watch” to the agent. To monitor the new property of the agent, configure the status (see on page 162 “Status configuration”) and the status determination (see on page 163 “Periodic querying (polling)”).
7.8 Effect on system resources

Industrial HiVision provides you with a range of options for managing and monitoring your network. This range of options also makes it possible for you to exhaust your system resources and even to overload them.

In this chapter you will find information about how to
- detect
- influence and
- minimize the utilization of your system resources.
### 7.8.1 Detecting utilization of system resources

Polling operations and history records are the main activities that affect your system resources.
In extreme cases, when you change such settings you can see that your system has slowed down.
In other cases, you require objective indicators to back up your subjective perception. You will find these indicators in the help menu of the kernel info.

<table>
<thead>
<tr>
<th>Indicator</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of polled properties</td>
<td>Displays the number of properties for which polling is activated. This display takes into account the devices (see on page 213 “Manage”) monitored by Industrial HiVision and their properties.</td>
</tr>
<tr>
<td>Number of properties recording history</td>
<td>Displays the number of properties for which the history recording is activated. This display takes into account the devices (see on page 213 “Manage”) monitored by Industrial HiVision and their properties.</td>
</tr>
<tr>
<td>Polling operations per minute</td>
<td>Industrial HiVision sums up the properties for which polling is activated and relates the total to the polling interval. As some polling intervals are greater than 1 minute, the number of polling operations can exceed this calculated value within the last minute. This display takes into account the devices (see on page 213 “Manage”) monitored by Industrial HiVision and their properties.</td>
</tr>
<tr>
<td>Polling operations in the last minute</td>
<td>Displays the number of polling operations performed in the last minute. This display takes into account the devices (see on page 213 “Manage”) monitored by Industrial HiVision and their properties.</td>
</tr>
<tr>
<td>Total number of history entries set</td>
<td>Displays the number of entries saved by Industrial HiVision (see on page 169 “Configuring the protocoling”).</td>
</tr>
<tr>
<td>Total number of actual history entries</td>
<td>Displays the number of entries actually saved by Industrial HiVision.</td>
</tr>
</tbody>
</table>

*Table 15: Indicators for system resource utilization in the kernel info*
7.8.2 Influencing utilization of system resources

You will have the most influence on the utilization of your system resources by using the settings for polling operations and history recording. You can see for which properties you have currently activated the polling or the history recording in the "Monitor" dialog (see on page 245 “Monitor”).

To keep the utilization of your system resources as low as possible, please note the following points:

- Every property that you have activated in Industrial HiVision for periodic querying creates a load on your network management station and increases the network traffic.
  - Check which properties you really want to monitor.
  - Check which query frequency you require for this monitoring.
- Every history entry creates a load on your network management station and uses up the free memory space on your network management station.
  - Check which properties you really want to record.
  - Check which buffer size you require.
- The multi-configuration function allows you to set up statistic counters on multiple devices at the same time. By setting up statistic counters, you activate the polling and recording operations.
  - Before you use the multi-configuration function, check what effect the settings have on your system resources.
- Many events increase the memory requirement, the program start time and the start time of the event filter dialog.

For a sufficient performance of your network management station, consider the following additional factors:

- Network range
- Number of nodes
- Complexity of the node management
- Network load
- Computer resources of your network management station
- Memory size (RAM and hard drive) of your network management station
7.8.3 Minimizing polling

Industrial HiVision gives you the option of adjusting polling gradually to your requirements. You can change the polling interval and also determine which properties are to be queried by Industrial HiVision.

- Changing the polling interval for the properties of several devices
  The table (see on page 364 “Monitored properties in the basic setting”) shows you which properties Industrial HiVision monitors with the basic polling setting. To reduce the polling volume from temperature monitoring for the devices in the detail display, proceed as follows:
  - Select the "Properties" file card in the detail display.
  - For "Device Class:" select "All"
  - "Property:" = "Temperature" ("Device")
  - Select all devices with "Ctrl"+"a".
  - Right-click on a device and select MultiConfig™.
  - In the function frame of the MultiConfig™ dialog, select "Property Properties".
  - Enter 15 minutes for the polling interval, for example in the function frame of the MultiConfig™ dialog.
  - To save the change in Industrial HiVision, click "Write".

You can also turn off polling completely in the same way.

- Turning off polling for connection properties
  With the default value, Industrial HiVision polls the network load every 30 seconds.
  To turn off network load polling, proceed as follows:
  - Select the "Connections" file card in the detail display.
  - Select all connections with "Ctrl"+"a".
  - Click on a connection with the right mouse button and select MultiConfig™.
  - In the function frame of the MultiConfig™ dialog, select "Connection Properties".
7.8 Effect on system resources

7.8.4 Minimizing network load

Industrial HiVision gives you the option of reducing the network load caused by the device detection.

- Select Configuration > Preferences > Advanced > Services.
- Under "Industrial HiVision Ping Service", reduce the "Scan Rate [devices/min]".
- Under "Global Settings", reduce the value for "Simultaneously Discovered Devices".
7.9 Process visualization systems

7.9.1 Link to process visualization system

As an interface to process visualization systems (SCADA, Supervisory Control and Data Acquisition) Industrial HiVision contains OPC services and an ActiveX control element on Windows operating systems.

A process visualization system can use the ActiveX control element to graphically represent data from Industrial HiVision.

If the Hirschmann Industrial HiVision 7.0 Service is active, then the OPC services can read data from Industrial HiVision and make it available to the process visualization systems. The OPC services can also write data in Industrial HiVision. The OPC services support Data Access V1 to V3 and OPC Unified Architecture for communication purposes.

OPC DA is based on the Distributed Component Object Model (DCOM) protocol from Microsoft. DCOM is designed as a transport protocol on multiple layers, e.g. on the http Internet protocol. Thus DCOM supports direct communication between software components via the LAN. Windows 7, Windows 2003 und Windows 2008 support DCOM. For further information on DCOM, visit the Microsoft website. Activate the DCOM protocol and the remote access to the network management station, in order that an OPC client has remote access to the OPC server.

OPC UA is an XML-based, operating-system-independent protocol.

Initial setting for the Industrial HiVision OPC server service: Deactivated (see on page 292 “Advanced:Services Access”).
**Note:** If you activate the Industrial HiVision OPC server service, an OPC client use the OPC service and Industrial HiVision to access Industrial HiVision managed devices with write authorizations. In the Configuration > Preferences > Advanced > Mobile Devices dialog, under "OPC Server" you can use "Global Write" to deactivate the write permission.

*Figure 31: Link to process visualization system*
7.9.2 Structure of the transfer data for OPC

The Industrial HiVision OPC server maps the data to be transferred in the same tree structure in which Industrial HiVision represents it in the folder frame. The individual elements and their values are known as tags. To indicate the hierarchy, Industrial HiVision uses prefixes which Industrial HiVision puts before the tag name. The tag names correspond to the names of Industrial HiVision in the English language version. Changing the names in Industrial HiVision has the effect that OPC clients cannot access the tags any more. The same applies to moving components into other folders.

Note: If you intend to move components regularly, you can put a link to the components in your own folder (e.g. Folder/OPC) and access the link using OPC. This method can be useful if your process visualization system has a length restriction for the tag name.

<table>
<thead>
<tr>
<th>Prefix</th>
<th>Type of component</th>
</tr>
</thead>
<tbody>
<tr>
<td>C_</td>
<td>Link</td>
</tr>
<tr>
<td>D_</td>
<td>Device</td>
</tr>
<tr>
<td>F_</td>
<td>Folder</td>
</tr>
<tr>
<td>L_</td>
<td>Link</td>
</tr>
<tr>
<td>P_</td>
<td>Port</td>
</tr>
<tr>
<td>V_</td>
<td>Device detail</td>
</tr>
</tbody>
</table>

*Table 16: Tag name for OPC*
For device names, Industrial HiVision represents the IP addresses with dots instead of underscores. The Industrial HiVision OPC server replaces dots and spaces with underscores.

Every node/folder in the structure consists of 5 tags, with the exception of devices, device details and links.

A device also has the “Managed” tag.

A device detail also has the “Value” tag.

A link also has the “ConnectionState”, “Utilization_AB” and “Utilization_BA” tags.

<table>
<thead>
<tr>
<th>Tag name</th>
<th>Meaning</th>
<th>Component</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>Name of the component, as displayed by the program interface.</td>
<td>all</td>
</tr>
<tr>
<td>Security status</td>
<td>Current status as numerical value.</td>
<td>all</td>
</tr>
<tr>
<td></td>
<td>0=No Status, 1=Unavailable, 2=Ok, 3=Warning, 4=Error</td>
<td></td>
</tr>
<tr>
<td>Status</td>
<td>Current status as numerical value.</td>
<td>all</td>
</tr>
<tr>
<td></td>
<td>0=No Status, 1=Unavailable, 2=Ok, 3=Warning, 4=Error</td>
<td></td>
</tr>
<tr>
<td>StatusString</td>
<td>Current status as readable (English) text, e.g. &quot;OK&quot;, &quot;Error&quot;</td>
<td>all</td>
</tr>
<tr>
<td>StatusReason</td>
<td>List of all the reasons that contribute to the status of the component, in readable (English) text form.</td>
<td>all</td>
</tr>
<tr>
<td>StatusChanged</td>
<td>Shows whether the status of the object is unconfirmed.</td>
<td>all</td>
</tr>
<tr>
<td></td>
<td>0=Confirmed 1=Unconfirmed</td>
<td></td>
</tr>
<tr>
<td></td>
<td>You can use OPC to set the value to &quot;0&quot;.</td>
<td></td>
</tr>
<tr>
<td>Managed</td>
<td>Shows whether Industrial HiVision is monitoring the device.</td>
<td>Device detail</td>
</tr>
<tr>
<td>Value</td>
<td>Current value of the component detail.</td>
<td>Device detail</td>
</tr>
<tr>
<td>ConnectionState</td>
<td>Link status, as displayed by the program interface through line representation:</td>
<td>Link</td>
</tr>
<tr>
<td></td>
<td>1=Unavailable 2=Active (unbroken line) 3=Standby (dotted line) 4=Inactive (chain line)</td>
<td></td>
</tr>
<tr>
<td>Utilization_AB</td>
<td>Load on the line from the first terminal point to the second terminal point (sequence as represented in the OPC tree).</td>
<td>Link</td>
</tr>
<tr>
<td>Utilization_BA</td>
<td>Load on the line from the second terminal point to the first terminal point (sequence as represented in the OPC tree).</td>
<td>Link</td>
</tr>
</tbody>
</table>

*Table 17: Available tags*
Note: The OPC server from Industrial HiVision supports the querying of up to 3000 OPC tags.

Figure 32: Example of the representation as an OPC tree structure
7.9.3 Connection as ActiveX control element

To connect Industrial HiVision to a process visualization system, you require the ActiveX control element, which you can optionally install with Industrial HiVision.

During the installation of Industrial HiVision with the ActiveX control element, the installation program registers the ActiveX control element in the Windows operating system.

☐ Incorporate the ActiveX control element “HiVisionAxControl Control” into your process visualization system.

The ActiveX control element requires a link to the Industrial HiVision service.

☐ By transferring the parameters to your process visualization system, you create the link to the Industrial HiVision service. Under Object:Properties, you enter the name or the IP address of the computer on which the Industrial HiVision service is running. If the Industrial HiVision service is running on the local computer, you enter localhost.

You can now operate Industrial HiVision in “running mode” on the interface of your process visualization system (see on page 77 “Edit mode”).
7.9.4  **Supported applications for ActiveX**

Hirschmann has tested Industrial HiVision with the following applications:

<table>
<thead>
<tr>
<th>Software</th>
<th>Version</th>
<th>Manufacturer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft ActiveX Container</td>
<td>-</td>
<td>Microsoft Corporation</td>
</tr>
<tr>
<td>Internet Explorer</td>
<td>6.0</td>
<td>Microsoft Corporation</td>
</tr>
</tbody>
</table>

7.9.5  **Supported applications OPC DA**

Hirschmann has tested Industrial HiVision with the following applications:

<table>
<thead>
<tr>
<th>Software</th>
<th>Version</th>
<th>Manufacturer</th>
</tr>
</thead>
<tbody>
<tr>
<td>RS View 32</td>
<td>7.20.00</td>
<td>Rockwell Automation</td>
</tr>
<tr>
<td>Genesis 32</td>
<td>8.00.138.00</td>
<td>Iconics, Inc</td>
</tr>
<tr>
<td>Simatic WinCC</td>
<td>6.0</td>
<td>Siemens AG</td>
</tr>
<tr>
<td>Citect SCADA</td>
<td>6.0</td>
<td>Citect Corporation</td>
</tr>
<tr>
<td>Softing OPC Demo Client</td>
<td>4.10 Built 512</td>
<td>Softing AG</td>
</tr>
</tbody>
</table>

7.9.6  **Supported applications OPC UA**

You can find out which applications Hirschmann has tested Industrial HiVision in connection with OPC UA in the readme file.

To connect a Scada-Client with an Industrial HiVision OPC UA-Server, the Scada-Client requires the following URL:
opc.tcp://<IP-ADDRESS>:11167/OPCUA/HiVisionUaServer
7.10 Remote access to Industrial HiVision

7.10.1 Web access to Industrial HiVision

Industrial HiVision allows you to access the Web server of Industrial HiVision with a browser via the http or https protocol. We recommend that you use the secure https protocol and certificate (see on page 196 “Certificate for the https connection”). You can thus monitor your network from anywhere in the world.

Example of an Internet address entry:
https://[IP address of your network management station]:11165

You can restrict the access with a password. To have information on accessing, Industrial HiVision can create an event for every successful access (see on page 291 “Advanced:Program Access”).

Note: The applet communicates with the service through the "Port"11165 and the "Port"11166. The "Port" is configurable beginning with Industrial HiVision version 7.0. (see on page 292 “Advanced:Services Access”) Verify that this communication is possible. This is particularly important if the connection is made using firewalls / port forwarding.

Take note of this information when using a firewall (see on page 22 “Installation”).

The Industrial HiVision Web server provides the following pages:
- Selection of the different websites
- Graphic user interface
- Event view
Note: If you wish to test Industrial HiVision before connecting the application to an actual network, then use the demo network provided by Industrial HiVision (see on page 347 “Demo network”).

- **Selection of the different websites**
  On this page, the Industrial HiVision Web server presents for selection the websites provided by Industrial HiVision.

  URL for this website:
  https://[IP address of your network management station]:11165/idx

- **Graphical user interface**
  The Industrial HiVision Web server provides the same graphic interface as the one used in your network management station. This enables you to monitor and configure your network remotely in the same way as you are accustomed to doing on-site.

  URL for this website:
  https://[IP address of your network management station]:11165

- **Events on the website**
  PDAs, smartphones and other portable devices are increasingly important tools for IT administrators. For administrators, the event list is an important part of Industrial HiVision. The event list contains a concentrated overview of the state of the monitored network (see on page 98 “Event list”).
  The Industrial HiVision Web server provides the event list in HTML format, optimized for display on portable devices such as the iPhone, BlackBerry devices, etc.

  The following is an example of the URL for the Industrial HiVision Web server:
  https://[IP address of your network management station]:11165/events

  The event website allows you to confirm events. Industrial HiVision synchronizes the confirmations with the graphic user interface and vice versa.
For the sake of clarity, Industrial HiVision restricts the display to the following events:

- Unconfirmed events
- Confirmed events of the types "Warning" and "Error".

When you confirm a standard event in the list, Industrial HiVision removes the confirmed standard event from the list.

Industrial HiVision refreshes this page every 5 minutes.

You can select different refresh cycles in the Display > Event dialog in Configuration > Preferences.
(see on page 279 “Display:Event”)

In addition to the predefined filters by "Category", Industrial HiVision offers user-defined filters according to the "Source" and the "Component" that caused an event.

- Copy a string from the "Source" or "Component" table column to the corresponding filter field. You can make the string more general by using the wildcard "*".

**Note:** When accessing the event list via http(s), Industrial HiVision saves the filter settings in a Web session on the Web server of Industrial HiVision.

Industrial HiVision gives you the option to change the lifetime of this Web session in the Configuration > Preferences > Advanced > Services dialog.

Use the setting Industrial HiVision Web Server > Web Server Session Timeout [min].

If a password is configured for the Web access, this password remains valid after the Web session is finished.
7.10.2 App access to Industrial HiVision

HiMobile is a mobile application (app) for mobile devices such as smartphones and tablet PCs. Anywhere in the world that you have an Internet connection and a link, e.g. via VPN, to the network of Industrial HiVision, HiMobile allows you to receive information about the status of your network. To do this, HiMobile connects to the service of Industrial HiVision as a client in order to exchange information.

Functions of HiMobile:

- Display of the Industrial HiVision folder frame with information concerning status, connection and any subdomains.
- Display of the Industrial HiVision event list with filter function.
Notifications when an event occurs
Scanning of the device QR code to identify the device in the folder frame and for other device information as well as access to the device-specific website.
Forwarding location coordinates to Industrial HiVision.

You will find the HiMobile app as a free download on the HiVision website.

### Preparing Industrial HiVision for app access

- **Allow access to the Industrial HiVision web server:**
  
  Configuration > Preferences > Advanced > Mobile Devices > Remote Access > Enabled

- **Allow remote access to the Industrial HiVision proxy server:**
  
  Configuration > Preferences > Advanced > Mobile Devices > Remote Access

- **Setup a user in User Management with a user role, which contains the "Web Access" access right.**
  
  See “Basic setting: User Management” on page 263.

- **For mobile android devices**
  
  If a firewall is restricting the data traffic between the Internet and Industrial HiVision, you release ports 5228, 5229 and 5230. Industrial HiVision communicates with the GCM server (Google Cloud Messaging) via these ports.
  
  GCM is a Google service that Industrial HiVision uses to send messages on mobile android devices.

- **For mobile iOS devices**
  
  If a firewall is restricting the data traffic between the Internet and Industrial HiVision, you release ports 5223, 2195, 2194 and 443. Industrial HiVision communicates with APNs (Apple Push Notification Service) via these ports.
  
  APNs is an Apple service that Industrial HiVision uses to send messages on mobile iOS devices.

- **For mobile Windows devices**
  
  If a firewall is restricting the data traffic between the Internet and Industrial HiVision, you release http protocol port 80. Industrial HiVision communicates with the Microsoft Push Notification Service via this port.
**Preparing the app for access to Industrial HiVision**

After you first start the app, or the "Settings" menu in the app, you see the "Settings" dialog for entering the connection parameters.

- Enter the IP address or the host name of your network management station. You will find the IP address in Industrial HiVision in the following dialog:

  Configuration > Preferences > Advanced > Management Station > IP Address Management Station

  If your network management station has multiple network interface cards, you take the IP address of the network interface card by means of which HiMobile is to communicate with Industrial HiVision. If your network management station is hidden behind a firewall with the NAT function, you obtain the relevant IP address from the administrator of the firewall.

- Enter the port for the web server. You will find the "web server port" in Industrial HiVision in the following dialog:

  Configuration > Preferences > Advanced > Mobile Devices

- Enter the "User Name" and the "Password" for web access. You will find these data in Industrial HiVision in the following dialog:

  Configuration > Preferences > Basics > User Management

  Select a user from the "User Management", which has "Web Access" authorization in the "Access Roles". See "Basic setting: User Management" on page 263.

- Enter the device names. Industrial HiVision displays the device names of its mobile devices in the "Mobile Devices" dialog under

  Configuration > Preferences > Advanced > Mobile Devices.

**Identifying devices with the app**

Industrial HiVision allows you to store a QR code for each device. Print out this QR code and affix it to the relevant device.
The HiMobile QR Code Scanner allows you to scan this QR code on site in order to identify the device. To show the information on your mobile device, you scan in the QR code. Then HiMobile calls up the information for the device from the Industrial HiVision web server and displays the information on your mobile device.

- To generate the QR codes of devices, select a device or multiple devices of a device class, and to open the MultiConfig™ dialog, choose Configuration > MultiConfig™.
- In the MultiConfig™ dialog, choose Device Settings > Diagnostics > QR Code Generator in the menu tree.

The QR Code Generator dialog gives you the following options for saving the QR code:
- Change the initial setting for the path and file name for storing the QR code files.
- Define the size of the QR code in pixels.
- Save the entries as an initial setting

- To save the QR codes in the specified directory, click "Write".

The Configuration > Preferences > Advanced > Load/Save dialog allows you set the path globally with the file name and tokens as placeholders.

### Geographic location display of a device

Industrial HiVision allows you to display the geographic location of a device on a map, e.g. Google maps, on your network management station.

There are two options for entering the location:

- In the Industrial HiVision user interface.
  - To open the property dialog, double-click the "Location Coordinates" property of a device in the detail view.
  - Under "Value" in the "Current Value" row, enter the location coordinates, e.g. 48.743286,9.320326.

- In HiMobile
  - Select a device in order to access the properties view for a device.
  - Type "Location Coordinates" on the pen icon of the property in order to enter the geographic coordinates.

  With "Get My Location", your mobile device uses its potential methods, e.g. GPS, to determine your location coordinates. If you and your mobile device are in a different location, then you can enter the latitude and longitude coordinates manually. HiMobile transmits these data to the network management station.
7.10.3 Certificate for the https connection

To provide greater protection for the connection between your mobile device or a browser and Industrial HiVision, you require a new certificate. For this, you require a web server keystore. The web server keystore is a file that contains the key for the https connection. The following example also applies to Linux operating systems when you use a “/” instead of a “\”.

☐ In the command line interpreter of the operating system, go to the installation directory of Industrial HiVision.

☐ Generate a Industrial HiVision web server keystore in the command line interpreter of the MS-DOS Microsoft operating system with the following command:

```
lib\java_x86\bin\keytool -genkey -alias Industrial HiVision -keyalg RSA -keystore keystore -keysize 2048 -keypass password -storepass password
```

Respond to the request for your first name and surname with the unique domain name of the domain to which your network management station is connected.
You can enter any responses you want to the requests for your organizational unit, your city or community, and your federal state. Respond to the request for your country code with the two letters that make up the country code of your country.
You will find the “keystore” file in the directory from which you executed the command.

☐ To request a certificate from a certification body, you require a certificate signing request file (*.csr).

You generate this file in the command line interpreter of the operating system with the following command:

```
lib\java_x86\bin\keytool -certreq -alias Industrial HiVision -keystore keystore -file ihivision.csr -storepass password
```

You will find the *.csr file in the directory from which you executed the command.

☐ With this *.csr file you request a certificate from a certification body, such as Verisign.de.

The certification body supplies the signed certificate in the form of a file or an ASCII character string.
If you receive a file, rename this file to ihivision.crt.
If you receive an ASCII character string, copy this completely to a text file with the name ihivision.crt.
Import the certificate into the web server keystore in the command line interpreter of the operating system with the following command:
lib\java_x86\bin\keytool -import -trustcacerts -alias Industrial HiVision -file ihivision.crt -keystore keystore -storepass password

Save the “keystore” file in the installation directory of Industrial HiVision before replacing the existing file with the newly generated file.

Replace the “keystore” file in the installation directory of Industrial HiVision with the newly generated “keystore” file.

**Note:** The files contain confidential keys that are comparable to passwords. Protect these files from unauthorized access.

Alternatively you can create your certificate yourself - see, for example, www.openssl.org. For this, you import the required master certificate to the mobile device or browser by means of which you want to connect with Industrial HiVision.
Monitoring the network

7.10 Remote access to Industrial HiVision

User Manual  Industrial HiVision
Release 7.0  09/2016
8 References

The descriptions in the previous chapters have been task-oriented, while the preference chapter describes the individual dialogs and menu items in a function-oriented way. Here you will find descriptions of function details for performing basic tasks that are of lesser importance.
8.1 File

The "File" menu contains functions relating to file operations. Industrial HiVision performs file operations on the computer with whose "Hirschmann Industrial HiVision 7.0 Service" service your interface communicates. If you have installed the service and the user interface on different computers, you get the file selection dialog for the file selection (see figure 34). You double-click on a table row to go one level lower on the file tree structure. You click "Up" to go one level higher in the file tree structure. Above the table you see the path you are currently on.

Figure 34: File selection dialog for different computers
8.1.1 New project

You can use this selection field to create a new project in which you can save your network data.

**Note:** By selecting a new project you delete the current project. To save the data of the current project, you export this project under another name (see on page 203 “Save”) before selecting the new project.

8.1.2 New

You use this selection field

- to add a new folder
- to add a new device to the selected folder
- to add a new device from a list to the selected folder
- to add a new subdomain the selected folder
- to create a new connection
- to add counters with properties on the port level, e.g. for “In non Unicast Packets”.
- to add a text line
- to add a symbol. You can change the symbol in the Properties window of the symbol.

**Create Devices from a List**

Industrial HiVision allows you to scan IP addresses using a text or an Microsoft Excel csv file. The "Create Devices from List" dialog allows you to search for and upload the file to Industrial HiVision. If a device in the list is unreachable, then Industrial HiVision displays the device in the topology map as a generic device.
The "Create Devices from List" dialog allows you add the IP addresses contained in the file to the Preferences > Basics > Discover Devices > Network Scan table. When you mark the "Add IP addresses to 'Preferences - Basics - Discover Devices - Network Scan'" checkbox, Industrial HiVision enters the IP address ranges from the text file into the table.

When you mark both the "Add IP addresses to 'Preferences - Basics - Discover Devices - Network Scan'" and the "Combine consecutive IP addresses into ranges" checkboxes, Industrial HiVision enters the IP addresses to the table in the following manner:

- If the IP addresses in the file are within a range of addresses already present in the table, then Industrial HiVision merges the IP addresses into the existing address range.
- If the IP address range overlaps or is adjacent to a larger existing range, then Industrial HiVision uses the netmask from the existing range.
- When the function cannot use a netmask from any existent range, the function automatically assigns the default netmask value 255.255.255.0.
- The function merges single adjacent IP addresses into IP address ranges entered in the same file.

When you create the IP address file use the following formats:

- 192.168.1.10,
- # this is a single address
- 192.168.1.11
- # this is also a single address
- 192.168.1.12, 192.168.1.15,
- # this is a range of addresses
- 192.168.1.16, 192.168.1.20
- # this is also a range of addresses
- # this is a comment line
- # 192.168.1.1 this is also a comment line

**Note:** To separate the IP address ranges, use a comma instead of a space. The comma at the end of the line is optional, To insert text use the hash “#” symbol.
8.1.3 Connect...

With this selection you can connect the user interface with the service on your own computer (localhost) or with the service on a remote computer.

8.1.4 Open

You use this selection field to open a previously saved project in order to view it or make changes in it.

☐ Select the relevant path and the desired file within your folder structure.

   Note: Select a path to which both the Industrial HiVision service and you have access.

8.1.5 Save

You use this selection field to save your current network data and the configuration of Industrial HiVision into a current project file.

☐ Select File > Save, to overwrite the open project file with the current project and the current configuration of Industrial HiVision.
8.1.6  Save as...

You use this selection field to save your current network data and the configuration of Industrial HiVision into a project file.

☐ Select File > Save as...

☐ Select the relevant path within your folder structure and enter a project name.

**Note:** Select a path to which both the Industrial HiVision service and you have access.

☐ Click on "Save" to save the current project and the current configuration of Industrial HiVision in a new file.

8.1.7  Save Backup

Industrial HiVision lets you save the information you require to restore Industrial HiVision installation.

For this purpose, Industrial HiVision writes the following information in a ZIP file:

- PSM list and PSMs
- Configuration (service properties files)
- Project database
- Reporting database
- License files
- Log files
- User reports
- User scripts, tasks and task results
- info.txt file with version information

Upon summoning "Save Backup", Industrial HiVision opens a file selection dialog. You are able to specify the destination of the backup file here.
8.1.8 Load Backup

Industrial HiVision allows you to restore a damaged Industrial HiVision installation. For this purpose, a Industrial HiVision backup ZIP files contains the following information:

- PSM list and PSMs
- Configuration (service properties files)
- Project database
- Reporting database
- License files
- Log files
- User reports
- User scripts, tasks and task results
- info.txt file with version information

After starting "Load Backup", Industrial HiVision opens a file selection dialog. You are able to specify the location of the backup file.

Note: To load the backup file you require the same version of Industrial HiVision that you used to save the backup file. You will find version information in the info.txt file in the backup zip file.
8.1.9 Export...

With this selection you export the content of the detail display. Industrial HiVision exports graphics (topology representation) as a:

- PDF file,
- jpg file,
- png file and
- bmp file.

Industrial HiVision exports tables as a:

- PDF file
- HTML file
- CSV file (see on page 366 “CSV export”)

Choose File > Export… and select the file type in the "Save" window.

8.1.10 Export Events...

With this selection you export the complete event list as:

- PDF file
- HTML file
- CSV file (see on page 366 “CSV export”)

Choose File > Export Events… and select the file type in the "Save" window.
8.1.11 Print

With this selection you print the content of the detail display.

Select File > Print.
Industrial HiVision creates a temporary PDF file of the content of the detail display and opens this PDF file in the PDF display program, e.g. Acrobat Reader, that is installed on your management station.

8.1.12 Printing the event list

With this selection you print the complete event list.

Select File > Print Events.
Industrial HiVision creates a temporary PDF file of the content of the detail display and opens this PDF file in the PDF display program, e.g. Acrobat Reader, that is installed on your management station.

8.1.13 Exit and Stop Service

Available when running on the Windows operating system.
With this selection you exit both the program and, for the local service, the service. By exiting the service you also interrupt the monitoring of your network.
8.1.14 Exit

You use this selection field to quit the program. The service remains active in the background and continues to monitor your network.
8.2 Edit

The "Edit" menu contains functions relating to editing operations and device properties.

8.2.1 Undo

With this selection you undo the last change you made in the program.

8.2.2 Redo

With this selection you redo the last change you made in the program, which you had previously undone.

8.2.3 Edit mode

You use this selection field to activate/deactivate the edit mode. You will require the relevant access rights for this function, see “Basic setting: User Management” on page 263. To avoid writing conflicts, Industrial HiVision prevents the edit mode from being activated on multiple user interfaces at the same time.
8.2.4 Switch to the free version

With this selection you switch during the free 30-day trial period between the licensed version and the free version. Industrial HiVision offers 3 versions:

- **Licensed version**
  After you enter a license key, Industrial HiVision runs as the licensed version. As the licensed version, Industrial HiVision gives you the full function range.

- **Free 30-day trial version (licensed)**
  After a new installation or after an update, Industrial HiVision starts fully functional for the duration of the free 30-day trial period. During the last 7 days of the trial period, a message window tells you that the trial period is running out and that you can save the project file before the trial period expires. If Industrial HiVision is idle during this time, Industrial HiVision shows this message window when it starts again.

- **Free version**
  As the free version, Industrial HiVision offers the option of detecting devices of Hirschmann and performing updates on the detected devices.

8.2.5 Cut

You use this selection field to put data you have selected (screen element, components, devices with their settings) into the clipboard. The data is deleted, and you can add it in again at another position using the "Paste" menu item.

You can also copy the names of objects into other applications, such as a text editor.
8.2.6  Copy

You use this selection field to put data you have selected (screen element, components, devices with their settings) into the clipboard. The data remains where it is, and you can add a copy of it at another position using the "Paste" menu item. You can also copy the names of objects into other applications, such as a text editor.

8.2.7  Paste

You use this selection field to add the data (screen element, components, devices with their settings) in your clipboard at the position where your cursor is currently located.

8.2.8  Paste as link

You use this selection field to add the data (screen element, components, devices with their settings) in your clipboard as a link at the position where your cursor is currently located. Only a reference to the data is inserted. The data themselves remain in their original position (see on page 115 “Creating a link”).
8.2.9 Delete

You use this selection field to delete data you have selected (screen element, components, devices with their settings). When deleting devices, Industrial HiVision allows you to delete the device or move the device into the "Unused Devices" folder.

8.2.10 Rename

With this selection you rename a selected folder or a tagged device.

8.2.11 Select all

You use this selection field to select all parts inside the active folder.

8.2.12 Acknowledge Status Change

You use this selection field to acknowledge the status change of the selected components and their sub components.
8.2.13 Manage

With this selection you activate the monitoring of the selected devices (see on page 213 “Unmanage”).

8.2.14 Unmanage

With this selection you deactivate the monitoring of the selected devices. Industrial HiVision keeps the device, its configuration and its current values stored in the database. The monitoring of the device is off until you set it to "Manage" again (see on page 213 “Manage”). Industrial HiVision releases the license of this device and allows you to use this license for another device. Industrial HiVision displays a device in the "Unmanage" state in gray with a stop symbol.

8.2.15 Set devices and port names

With this selection you set the detail window to show
– the device name and port name of the selected devices, instead of
– the IP address and port numbers of the selected devices.
8.2.16 Set default device Icon

With this selection you take the symbol for display from the device class. If no default symbol exists for the device class, Industrial HiVision takes the device symbol entered in the preferences (see on page 288 “Display: Device Icon”).

8.2.17 Device Documentation

With this selection, Industrial HiVision generates a PDF file for

- every device selected, or for
- all devices.

The PDF file contains information about the device and its settings.

☐ Make a selection and specify the folder in which you want Industrial HiVision to save the PDF files.

8.2.18 Drawing Size

You use this selection field to adapt the size of the drawing area for the detail display to meet your requirements. Industrial HiVision provides you with three options for doing this:

- Reduce,
- Enlarge,
- Shrink to fit.
8.2.19 Background image

You use this selection field to load, remove or change the background image in your detail display. The following options are available:

- **Paste As Background**
  When you select "Paste As Background", you add the image in your clipboard to your detail display as a background image. If the clipboard is empty, this menu item is marked in grey and cannot be selected.

- **Select Background Image...**
  When you select "Select Background Image..." you add the image from a file to your detail display as a background image. Select the relevant path and the desired file within your folder structure.

  **Note:** High-resolution background images sap the resources of your network management station and therefore reduce the performance of your system.

- **Remove Background Image**
  When you select "Remove Background Image", you delete the background image in your detail display.
8.2.20 Search

The Find dialog allows you to search for components, MAC addresses or IP addresses in the display.

- Select the "Devices by IP Address" tab page if you are searching for an IP address or "Components by Name" if you are searching for part of a device.
- Enter
  - the IP address/MAC address or a part of it, or
  - the component name or a part of it without using wildcards.
- Select a device on the left of the tree diagram or a folder in which you want Industrial HiVision to search.
- Click "Find" to start searching.
Industrial HiVision shows the result of the search in a list of the search dialog. When you double-click on a line in this list, Industrial HiVision selects the component you want to find in the folder frame.

Figure 36: Edit:Find

8.2.21 Auto Topology

The Auto Topology function allows you to automatically create the links between the devices. For the Topology Discovery, Industrial HiVision uses the Forwarding Data Base (FDB) and the LLDP and SNMP functions of the devices.

IEEE 802.1AB describes the Link Layer Discovery Protocol (LLDP). LLDP enables the user to have automatic topology recognition for his LAN. Industrial HiVision detects redundancy mechanisms, such as RSTP, redundant network coupling or HIPER-Ring. Industrial HiVision represents every redundant connection as a separate connection.
Industrial HiVision can detect the terminal device topology across the subnetworks if the router separating the subnetworks supports the SNMP ipNetToPhysicalTable.

☐ Select Edit > Auto Topology...

☐ In the dialog for automatic topology discovery, you select how you want Industrial HiVision to execute the Auto Topology function.

<table>
<thead>
<tr>
<th>Selection</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entire Network</td>
<td>Detects the topology of the entire network, including switches, routers, WLAN and terminal devices and reads large data quantities from the devices. In large networks, Topology Discovery can take up a significant amount of time. In this case “Entire Network&quot; means the Layer 2 network that is connected with the network interface card of the network management station and all the reachable VLANs.</td>
</tr>
<tr>
<td>Infrastructure</td>
<td>Only detects the topology of the infrastructure devices based on LLDP. Is performed very quickly and sometimes with gaps.</td>
</tr>
</tbody>
</table>

*Table 18: Scope*

<table>
<thead>
<tr>
<th>Selection</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Devices without management</td>
<td>Industrial HiVision derives topology information from devices without the management function and from devices without an Industrial HiVision license from the information in known neighboring devices. Industrial HiVision represents these unknown devices as a cloud. A cloud can represent one or more unknown devices.</td>
</tr>
</tbody>
</table>

*Table 19: Nodes without management*
Click "OK"

Then Industrial HiVision queries the links in the network in accordance with the settings and displays the detected links in the interface.
**Note:** Topology Discovery

- Network components that do not conform to the LLDP specifications or cannot be managed via SNMP can lead to incorrect Auto Topology Discovery.
- An active DHCP request during the discovery procedure can corrupt the result of the discovery.
- VLAN routing can corrupt the result of the discovery. MACH 3000 M-Router modules work with VLAN routing.
- To detect subnetworks behind 1:1 NAT routers, select "Infrastructure" under "Scope" (see table 18).
- In order to identify the topology with VRRP routers correctly, Industrial HiVision requires at least one of the VRRP routers to be located in the same folder or subfolder, where you start the automatic topology function.
- Detecting devices of an LAN behind a wireless client device: The BAT-Geräte from Hirschmann have the “client bridge support” function.
  For Industrial HiVision to be able to detect devices of an LAN behind a wireless client device, activate the “client bridge support” function in the wireless client device and in the related WAN on the access point.
- Redundantly connected terminal devices can corrupt the result of the discovery.
- The topology discovery detects the topology at the time at which it is executed.
  Industrial HiVision displays other changes in the network (e.g. roaming) when you update the topology display.

### 8.2.22 Auto Layout

The Auto Layout function gives you the option of leaving the assignment of the devices to Industrial HiVision.

- Select **Edit > Auto Layout.**
- Click "OK" to get Industrial HiVision to reposition the objects in the detailed display.
8.2.23 Properties of a folder/device

The properties dialog contains the Properties, Subcomponents, Scan Range, Protocol and MAC/IP Addresses tab pages. The protocol and MAC/IP Addresses tab pages describe device properties.

Properties of a folder/device
The “Properties” tab page displays the general properties of the component display. You click on a symbol once to open a dialog for selecting an image for Industrial HiVision to use in the display. Industrial HiVision adapts the image size automatically. The status display is important for monitoring your network. Here you select whether Industrial HiVision determines the status of this component and whether Industrial HiVision forwards the status determined to the next highest level. In the basic setting, Industrial HiVision determines the status and forwards it to the next highest level.

Figure 37: Properties of a folder/device
**Subcomponents of a device/folder**

The “Subcomponents” tab page shows a table of the entire parts of the component from which you opened the properties dialog. Along with the names of the parts, the table also contains the values of the different properties of these parts.

![Figure 38: Subcomponents of a folder/device](image-url)

Figure 38: Subcomponents of a folder/device
Scan range of a folder

The "Scan Range" tab page enables you to define IP address ranges. Industrial HiVision shows newly detected devices with IP addresses from one of these IP address ranges in this folder (see on page 315 “Scan Ranges”).

Figure 39: Scan ranges of a folder
The “Protocols” tab page shows a table of the protocols that are supported and their properties. Depending on the devices, Industrial HiVision supports the protocols:

- Ping
- SNMP V1
- SNMP V3
- HiDiscovery
- EtherNet/IP
- Modbus/TCP

Industrial HiVision supports the Modbus/TCP command `Read Device Identification (43 / 14)` exclusively.

Industrial HiVision uses the highest possible protocol (sequence: SNMP V3, SNMP V1, Modbus/TCP, Ping) to monitor a device.

You use "Reload" to get Industrial HiVision to query protocols of the device again.

Figure 40: Protocols of a device
**IP address of a device**

The tab page allows you to change the IP address and the SNMP port number for current devices for Industrial HiVision in this dialog. You require this function to re-access with Industrial HiVision a known device whose IP address was changed directly on the device. If you want to change the IP address on a device, you select the device and use the **Configuration > IP Configuration** (see on page 321 “IP Configuration”).

*Figure 41: IP address for a current device*
**MAC/IP addresses of a device**

This tab page shows you a list of the IP addresses in the device and their related MAC addresses. The list contains:

<table>
<thead>
<tr>
<th>Designation</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>MAC Address</td>
<td></td>
</tr>
<tr>
<td>IP Address</td>
<td></td>
</tr>
<tr>
<td>Netmask</td>
<td></td>
</tr>
<tr>
<td>Hostname</td>
<td>Host name from the /config/hosts.txt file in the installation directory if</td>
</tr>
<tr>
<td></td>
<td>– the file exists,</td>
</tr>
<tr>
<td></td>
<td>– there is an entry and</td>
</tr>
<tr>
<td></td>
<td>– the determination of a device name is activated in the basic settings.</td>
</tr>
<tr>
<td></td>
<td>Otherwise, the field remains empty.</td>
</tr>
<tr>
<td>DNS Name</td>
<td>Name from the Domain Name Service</td>
</tr>
<tr>
<td>Port No</td>
<td>Port number of the protocol.</td>
</tr>
<tr>
<td>Port</td>
<td>Device port</td>
</tr>
<tr>
<td>Management</td>
<td>Industrial HiVision communicates with the management of the device by</td>
</tr>
<tr>
<td></td>
<td>means of the IP address in this row.</td>
</tr>
<tr>
<td>User Generated</td>
<td>The device in this row was generated by the user. Industrial HiVision has</td>
</tr>
<tr>
<td></td>
<td>not detected this device yet.</td>
</tr>
<tr>
<td>Router Entry</td>
<td>The IP address in this row comes from the routing table of the device.</td>
</tr>
</tbody>
</table>

![Figure 42: MAC/IP address and name of a device](image-url)
8.2.24 Properties of a component detail

In the “Properties of a component detail” dialog, you are at the lowest level of the status determination. In addition to the properties that are on higher levels, this dialog contains a specifically determined value. If you want to observe this value, you can query it at freely specified intervals and log it. Value range for the polling interval: ≥5 seconds.

You can edit the name of the property if you have previously permitted renaming in the settings (see on page 291 “Advanced:Program Access”).

To perform logging, select History > Record. Select "Show" to open another window to show the history. You can use the tab page selection in this window to choose between tabular and graphic views.

The graphic view is available if the property is of the counter type.

With "Buffer Size" you specify how many lines the protocol buffers. If you also want to display this value in the bubble help of a higher-level component, you select the component in the "Show Value in Tooltip of" selection menu (see figure 43).

In the "Status Config" dialog, you specify how a change in this value affects the display of the status.
Aside from monitoring your network, Industrial HiVision also allows you to configure the following properties on the component detail level, if the device supports this option:

- **Port Name**
  Assign the port any readable name.
- **Port Status**
  Switch the port on or off.
- **Autonegotiation**
  Switch the autonegotiation function on or off.
- **Device Name**
  Assign the device any readable name.
- **Contact**
  Name the contact person for the device.
8.2 Edit

- Location
  Name the location of the device.
- Signaling
  To identify a specific device among several devices in the same location.

To configure a component detail property,

- select the “Properties” dialog for the component detail.
- Edit the value and click "Write".

![Figure 44: Configuring detail properties](image)

Figure 44: Configuring detail properties
**Specified values**

The "Status Config" dialog shows you the possible values of the component detail. Use the drop-down menu to assign the statuses you require to the values. The operators provide you with further options for the definition of the status configuration.

![Example for the status display of default values](image)

*Figure 45: Example for the status display of default values*
### List values
The "Status Config" dialog shows you a list with current values of the component detail. Use the drop-down menu to assign the statuses you require to the values. In contrast to “Defined values”, the values are variable and you can use “Current values” to read in the currently available values, use "New" to enter your own values in the list and use "Delete" to delete values from the list.

Application example: You want an error message when unauthorized stations login to an access point. Enter the permitted stations in the list and set “Other Value” to “Error” (see figure 46).

![Status display for list values](image)

**Figure 46: Status display for list values**
**Numeric values**

The "Status Config" dialog allows you to enter threshold values numerically. Use the drop-down menus to select the statuses which Industrial HiVision should assign to the device when these threshold values are exceeded or not reached.

![Status display for numeric values](image)

*Figure 47: Status display for numeric values*
**Alphanumeric character string**

The "Status Config" dialog allows you to assign an alphanumeric value to the device detail. Use the drop-down menus to select the statuses which Industrial HiVision should assign to the device for other character strings. Example: Enter at one port the MAC address of the connected device. Assign the status "OK" if the MAC address of the connected device is the same. Assign the status "Error" if the MAC address of the connected device is different. As soon as the MAC address changes, you get an error message.

![Image](image_url)

*Figure 48: Status display for alphanumeric values*

### 8.2.25 Properties of a connection

The properties dialog of a connection consists of 2 tab pages: "Connection" and "Properties" You can access a third property, the history of the connection, by double-clicking on the connection.
### Connection

On the "Connection" tab page you select the ports to which the connection is connected. To give you a better overview, the dialog provides you with an option to select the ports that will appear in the selection display.

If the speed display is activated, when the speed is increasing Industrial HiVision increases the line thickness in 2-point steps at 10, 100, 1000, 10000 MBit/s. If the speed display is activated, Industrial HiVision displays the current connection setting in the bubble help.

If the speed display is deactivated, Industrial HiVision displays the current speed setting even if you have activated the speed display in the connection properties dialog (see on page 283 “Display:Device”).

With automatic display of the connection medium via the connection end icon, Industrial HiVision selects the respective icon. Industrial HiVision allows you to define the connection end icon for a connection yourself. This option enhances clarity when conditions prevent determination of the medium.

If observing the connection is important for you, you can query the following standard parameters at freely specified intervals:

- Link status
- Load (incoming load)
  - If a terminal device on a connection does not supply a value for the incoming load, then Industrial HiVision displays the outgoing load of the other end of the connection as the incoming load at this end.
- Port redundancy
- WLAN port properties

Industrial HiVision uses "Record" "Load History" to store the value of the queried incoming load on an ongoing basis.

### Properties

The "Properties" tab page for the connection allows you to give the connection any name you want and to specify the status handling.

The status display can be used for monitoring your network. Here you select whether Industrial HiVision determines the status of this connection and whether Industrial HiVision forwards the status determined to the next highest level. In the basic setting, Industrial HiVision determines the status and forwards it to the next highest level, as soon as you have assigned the connected ports to the connection (see below).
Under “Availability”, you can find the fields for entering the MTBF and MTTR values that Industrial HiVision uses for calculating availability (see on page 348 “Calculate Availability”).

8.2.26 Adding a component detail to a port

Industrial HiVision provides the monitoring of many component details for the individual components. Industrial HiVision provides an overview of a selection of these details.

☐ To add another component detail to a port, right-click on the empty space in the component detail display.

☐ Select New > Property.

Industrial HiVision then provides you with a list of additional component details. A component detail is available as a "Delta" type and "Absolute" type.

▶ Delta: The monitoring refers to the difference between the values for two consecutive inquiries. The symbol of the delta property is a triangle in the top right corner.

▶ Absolute: The monitoring refers to the absolute value for each particular inquiry.
8.2.27 Add to reporting

The reporting function allows you to manage long-term statistics outside the database of the network management system program.

You can add the following to the reporting function:

- Pollable device details
- Connections between 2 devices, at both ends of which Industrial HiVision has detected a link status.

To add a device detail or a connection to the reporting function, click with the right mouse button on the device detail or the connection and select "Add to Reporting ...".

The dialog allows you to use "Record" to activate/deactivate the reporting for this property or this connection. If you deactivate the reporting, the entry remains in the reporting function (see on page 248 “Reporting”). For the reporting, you have the choice of recording the value or recording the status.

"Start" and "Stop" allow you to define when the recording starts and when it stops. With the default setting, the recording begins right after you click "OK" and continues for as long as the Industrial HiVision service is running.
If you previously activated the polling for the property or the connection, or if you changed the polling interval, this setting is kept. Otherwise Industrial HiVision activates the polling and sets the polling interval to the minimum value of 30 seconds.

Polling interval setting:
- Minimum value: 30 seconds
- Possible values: multiples of 30 seconds

![Add property to reporting](image)

*Figure 50: Add property to reporting*
8.2.28 Device and Port Signaling

The signaling function allows you to identify a device or port using the LEDs of the device. When making new connections, this function allows you to verify the proper device and port. You can also activate the function using HiMobile.

Note: The Device and Port Signaling function is available on Platform 4 devices beginning with software version 09.0.03.

Signaling devices and ports
To activate the signaling function on a device use the following steps:

- Verify that Industrial HiVision is in the "Edit Mode".
- Double click on the device on which you wish to activate the signaling function.
- Open the "List" tab.
- Right click on the "Signaling" entry.
- Select "Properties" from the pull down list.
- In the "Value" frame, in the "Current Value" pull down list, select the "On" option.
- Click the "Write" button.

The table in the "List" tab displays the Signaling function as "On", and the LEDs on the device blink for 10 seconds. After 10 seconds the entry changes to “Off”.

The steps to activate the signaling function on a port are similar as the steps described above. The only difference is that you highlight the port in the menu tree for which you wish to activate the "Signaling" function.
Figure 51: Signaling properties dialog

- **Signaling function support**
  
The following list contains the devices and software that support the “Signaling” function:

<table>
<thead>
<tr>
<th>Type of device</th>
<th>Since Version</th>
<th>Device Signaling</th>
<th>Port/Connection Signaling</th>
</tr>
</thead>
<tbody>
<tr>
<td>Classic Switch</td>
<td>09.0.01</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>HiOS</td>
<td>04.0.00</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>HiSecOS</td>
<td>03.0.00</td>
<td>X</td>
<td></td>
</tr>
</tbody>
</table>

*Table 23: Signaling support software*
8.3 View

You use the "View" function to navigate through the history of the content of the detail display frame.

8.3.1 Select VLAN

This function allows you to see the VLAN membership of the detected devices and links based on the colors in which they are displayed.

☐ Select View > Select VLAN.
   Industrial HiVision opens a dialog for selecting a VLAN.
☐ In the drop-down menu, select the VLAN ID for the VLAN whose VLAN membership you want to see.
   Industrial HiVision displays the devices and links that belong to other VLANs in light gray. The devices of the selected VLAN remain in color or in dark gray.
At the top of the folder frame, Industrial HiVision displays the selected VLAN.

8.3.2 Refresh VLANs

This function allows you to refresh the VLAN information on the Hirschmann devices.
☐ To refresh the VLAN information select a node in the project tree.
☐ On the menu bar, select View > Refresh.
   Industrial HiVision refreshed the information in the subcomponents of the selected node.
8.3.3 Protocol Statistics

The Protocol Statistics give you an overview of the response time behavior of the devices with Industrial HiVision with regard to the protocol communication. This overview helps you find out whether the response time behavior is the cause if Industrial HiVision cannot set up the communication with individual devices.

You can specify the number of samples from which Industrial HiVision calculates the movable average response time for both ICMP and SNMP.
- Open the Configuration > Preferences > Services dialog.
- You can specify the number of ICMP samples using the "ICMP Statistics - Moving Average Number of Samples" parameter.
- You can specify the number of SNMP samples using the "SNMP Statistics - Moving Average Number of Samples" parameter.

The dialog displays the moving average as 0 until Industrial HiVision calculates the first average.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device</td>
<td>IP address of the device to which the entries in this line apply</td>
</tr>
<tr>
<td>Protocol</td>
<td>Relevant protocol via which Industrial HiVision communicates with the device</td>
</tr>
<tr>
<td>Requests</td>
<td>Number of requests from Industrial HiVision since the last reset</td>
</tr>
<tr>
<td>Responses</td>
<td>Number of responses from the device since the last reset</td>
</tr>
<tr>
<td>Timeouts</td>
<td>Number of cases in which the device required longer for a response than was entered in the settings</td>
</tr>
<tr>
<td>Errors</td>
<td>Number of packets deviating from the standard</td>
</tr>
<tr>
<td>Msg Loss [%]</td>
<td>Pkt. loss [%] = packet loss [%] = 1-(replies/requests) * 100</td>
</tr>
<tr>
<td>Avg Resp [ms]</td>
<td>Average value of response times</td>
</tr>
<tr>
<td>MAvg Resp [ms]</td>
<td>Movable Average value of response times.</td>
</tr>
<tr>
<td>Min Resp [ms]</td>
<td>Minimum wait period for a response</td>
</tr>
<tr>
<td>Max Resp [ms]</td>
<td>Maximum response time for a reply</td>
</tr>
<tr>
<td>Std Dev</td>
<td>Standard deviation of the response times = measurement for the variation</td>
</tr>
<tr>
<td>Try 1</td>
<td>Number of responses received after the first request attempt.</td>
</tr>
</tbody>
</table>

Depending on your settings in the SNMP configuration in Industrial HiVision, Industrial HiVision creates columns with "Try" 2, "Try" 3, etc. The "Try" 2 column then only contains the number of responses received after the 2nd request attempt.

Table 24: Log statistics
Industrial HiVision provides you with a portion of the protocol statistics as detailed information for each device. You will find "Avg Resp [ms]" and "Std Dev" in the log properties of a device. You can use the reporting function to analyze the behavior of individual devices more precisely. To do this, you add these log details in a report.

With "Export" you can save the complete table as a:

- PDF file
- HTML file
- CSV file (see on page 366 “CSV export”)

With "Print" you can print the complete table. Industrial HiVision creates a temporary PDF file of the content of the list and opens this PDF file in the PDF display program, e.g. Acrobat Reader, that is installed on your management station.

With "Reload" you get Industrial HiVision to update the values in the tables of this dialog.

With "Reset" you get Industrial HiVision to reset the table values to “0”.

### 8.3.4 Filter Events for Object

With "Filter Events for Object" you filter the events list based on the device selected.

### 8.3.5 Back

You use "Back" to return to the previous view of the detail display frame.
8.3.6  **Forward**

You use "Forward" to go to the next view of the detail display frame.

8.3.7  **Up**

You use "Up" to go to the next highest level of the detail display frame.

8.3.8  **Home View**

With "Home View" Industrial HiVision enlarges the window to the size of the entire screen, and in the detail view it displays the content that you defined with "Set Home View Settings".

8.3.9  **Set Home View Settings**

With "Set Home View Settings" you define the content of the detail view that Industrial HiVision displays when you select the "Home View".
8.3.10 Geographical Location View

Industrial HiVision allows you to display the location of a device on a map.

Right-click on a device in the detail view and select "Geographical Location View".

If you have met the following conditions, Industrial HiVision shows you the location of the device on a map.

- The coordinates are entered in the "Location Coordinates" property of the device.
  See “Properties of a component detail” on page 227.
- Under Configuration > Preferences > Advanced > External Applications, the map display application for the URL is entered under "Geographical Location View".

8.3.11 Zoom

Use "Zoom" to increase the size of the display in the detail frame in steps of 10 %.
8.4 Configuration

8.4.1 Monitor

The "Monitor" dialog lists in a table the monitoring functions for the components currently being monitored:

- Property
- Value of the property
- Take the value from an alarm message (trap) relating to this property
- Query the value of this property periodically from the device
- Query interval
- Record history for this property
- Size of the Ring memory for the history recording (number of entries)
- Derive status of property from the value of the property
- Propagate status to the next highest level

Double-click on a row in the table to edit the status configuration of the property.
### Figure 52: Configuration: Monitoring

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
<th>Check</th>
<th>Poll Interval</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuration Status</td>
<td>Saved</td>
<td>☑</td>
<td>5 Min</td>
<td>OK</td>
</tr>
<tr>
<td>Temperature</td>
<td>47</td>
<td>☑</td>
<td>30 Sec</td>
<td>OK</td>
</tr>
<tr>
<td>Configuration File</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>In Load</td>
<td>0.0</td>
<td>☑</td>
<td>30 Sec</td>
<td>OK</td>
</tr>
<tr>
<td>Link Up</td>
<td></td>
<td>☑</td>
<td>30 Sec</td>
<td>OK</td>
</tr>
<tr>
<td>Max Response Time</td>
<td>8</td>
<td>☑</td>
<td>30 Sec</td>
<td>OK</td>
</tr>
<tr>
<td>Min Response Time</td>
<td>4</td>
<td>☑</td>
<td>30 Sec</td>
<td>OK</td>
</tr>
<tr>
<td>Message Loss</td>
<td>0</td>
<td>☑</td>
<td>30 Sec</td>
<td>OK</td>
</tr>
<tr>
<td>Std. Deviation</td>
<td>0</td>
<td>☑</td>
<td>30 Sec</td>
<td>OK</td>
</tr>
<tr>
<td>Avg Response Time</td>
<td>1</td>
<td>☑</td>
<td>30 Sec</td>
<td>OK</td>
</tr>
<tr>
<td>Probability</td>
<td>Yes</td>
<td>☑</td>
<td>20 Sec</td>
<td>OK</td>
</tr>
<tr>
<td>Message Loss</td>
<td>0</td>
<td>☑</td>
<td>30 Sec</td>
<td>OK</td>
</tr>
<tr>
<td>Avg Response Time</td>
<td>0</td>
<td>☑</td>
<td>30 Sec</td>
<td>OK</td>
</tr>
<tr>
<td>Reachability</td>
<td>Yes</td>
<td>☑</td>
<td>2 Hours</td>
<td>OK</td>
</tr>
<tr>
<td>HTTP Rule</td>
<td>Unsecure</td>
<td>☑</td>
<td>1 Days</td>
<td>OK</td>
</tr>
<tr>
<td>Unused Active Ports</td>
<td>Secure</td>
<td>☑</td>
<td>1 Days</td>
<td>OK</td>
</tr>
<tr>
<td>SNMP v1/2</td>
<td>Secure</td>
<td>☑</td>
<td>1 Days</td>
<td>OK</td>
</tr>
<tr>
<td>Telnet</td>
<td>Secure</td>
<td>☑</td>
<td>1 Days</td>
<td>OK</td>
</tr>
<tr>
<td>HTTPS</td>
<td>Secure</td>
<td>☑</td>
<td>1 Days</td>
<td>OK</td>
</tr>
<tr>
<td>Modbus</td>
<td>Secure</td>
<td>☑</td>
<td>1 Days</td>
<td>OK</td>
</tr>
<tr>
<td>Modbus IP</td>
<td>Secure</td>
<td>☑</td>
<td>1 Days</td>
<td>OK</td>
</tr>
<tr>
<td>Modbus TCP</td>
<td>Secure</td>
<td>☑</td>
<td>1 Days</td>
<td>OK</td>
</tr>
<tr>
<td>Modbus SSL</td>
<td>Secure</td>
<td>☑</td>
<td>1 Days</td>
<td>OK</td>
</tr>
<tr>
<td>Modbus UDP</td>
<td>Secure</td>
<td>☑</td>
<td>1 Days</td>
<td>OK</td>
</tr>
<tr>
<td>Modbus XML</td>
<td>Secure</td>
<td>☑</td>
<td>1 Days</td>
<td>OK</td>
</tr>
<tr>
<td>Modbus SMTP</td>
<td>Secure</td>
<td>☑</td>
<td>1 Days</td>
<td>OK</td>
</tr>
<tr>
<td>Configuration Status</td>
<td>Saved</td>
<td>☑</td>
<td>5 Min</td>
<td>OK</td>
</tr>
</tbody>
</table>
8.4.2 PSM Manager

Product-Specific Modules (PSMs) describe the properties of a device which Industrial HiVision can read for monitoring or write to for configuration. The PSM Manager gives you the opportunity to update PSMs or import additional PSMs beyond the ones included with delivery and remove them again.

- Industrial HiVision assigns the device class “Switch” to devices for which Industrial HiVision has no PSM.
- During import, Industrial HiVision compares the version of the PSM to be imported with any existing PSM. If the PSM to be imported already exists, Industrial HiVision opens a dialog. The dialog offers you the opportunity to keep or overwrite an existing PSM.

**Note:** Industrial HiVision accepts the changes made after a restart of the service.
8.4.3 Reporting

The reporting function allows you to manage long-term statistics outside the database of the network management system program.

Monitor

This table lists the properties that you selected for monitoring (see on page 236 “Add to reporting”).

- To change an entry in this table, select the entry and click "Edit".
- To delete one or more entries in this table, select the entry or entries and click "Delete".
  - If entries are contained in templates, Industrial HiVision refuses the deletion of these entries.
  - Delete these entries in the template table so that you can delete the entries in the monitoring table.
- To check whether the entries are still valid, as they could have changed during the editing in this dialog, click on "Refresh".
  - An entry is valid if Industrial HiVision can access and query the component.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Record</td>
<td>Activate this entry. If you close this dialog, then click “OK” or “Apply” in the “Monitor” dialog, Industrial HiVision starts the recording according to the settings below.</td>
</tr>
<tr>
<td>Recording start now</td>
<td>If you close this dialog, then click “OK” or “Apply” in the “Monitor” dialog, Industrial HiVision starts the recording.</td>
</tr>
<tr>
<td>Recording start time</td>
<td>If you close this dialog, then click “OK” or “Apply” in the “Monitor” dialog, Industrial HiVision starts the recording at this time.</td>
</tr>
<tr>
<td>Recording stop indefinite</td>
<td>After the recording starts, Industrial HiVision continues the recording indefinitely until this entry is deleted or changed.</td>
</tr>
<tr>
<td>Polling interval</td>
<td>Time interval at which Industrial HiVision cyclically queries the value from the device.</td>
</tr>
</tbody>
</table>

Table 25: Editing an entry in the monitoring table

Note: Industrial HiVision can record values as long as Hirschmann Industrial HiVision 7.0 Service is active. When you stop Hirschmann Industrial HiVision 7.0 Service, the recording also stops until Hirschmann Industrial HiVision 7.0 Service is started again.
8.4 Configuration

Templates
This dialog allows you to define the format of reports.

- Click "New" to define a new template.
- Click "Edit" to change a template.
- Click "Delete" to delete one or more templates.
- Click "Display Report" to check how a template looks.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Name</td>
<td>Name to identify this template.</td>
</tr>
<tr>
<td>Report Header</td>
<td>Header that Industrial HiVision writes above the report.</td>
</tr>
<tr>
<td>Report Type</td>
<td>Output format of the report.</td>
</tr>
<tr>
<td></td>
<td>Options: PDF, Excel</td>
</tr>
<tr>
<td>Report Layout</td>
<td>Layout of the report.</td>
</tr>
<tr>
<td></td>
<td>Possible: Diagram for report type “PDF”, table</td>
</tr>
<tr>
<td>Diagram type for report layout “PDF”</td>
<td>Options for layout of diagram.</td>
</tr>
<tr>
<td></td>
<td>Possible: Line (for presenting numeric values), bar</td>
</tr>
<tr>
<td>Data</td>
<td>Selection of properties that you previously added to the reporting</td>
</tr>
<tr>
<td></td>
<td>(see on page 236 “Add to reporting”)</td>
</tr>
</tbody>
</table>

Table 26: Defining a new template

- To avoid gaps in line graphs, combine only properties with the same polling intervals.
- To improve the appearance of diagrams, Industrial HiVision fills the gaps between the data with repetitions of the latest data. You can recognize the values inserted for filling-out purposes in table reports and Excel files by their grey color.

Scheduling
This dialog allows you to get Industrial HiVision to generate reports for defined time periods.

- Click "New" to define a new time period.
- Click "Edit" to change a time period.
- Click "Delete" to delete one or more time periods.
Industrial HiVision distinguishes between 3 different time period types:

- Absolute start and end times (Single Shot)
- Absolute start and relative end times (Cumulative)
- Relative start and end times (Recurring)

Absolute start and end times (Single Shot)
Industrial HiVision generates a report from the data that lies between the start time and the end time.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Name</td>
<td>Industrial HiVision provides a selection of existing templates.</td>
</tr>
<tr>
<td>From</td>
<td>The first time this dialog is opened, Industrial HiVision displays the time at which Industrial HiVision began recording the data for the selected template. If the report to be generated should start with data from a later point in time, you enter this time here. Possible: Point in time after recording has started and before report generation.</td>
</tr>
<tr>
<td>Until</td>
<td>End time of the reporting period. Possible: Point in time after the start time.</td>
</tr>
</tbody>
</table>

Table 27: Scheduling with absolute start and end times

Absolute start and relative end times (Cumulative)
Industrial HiVision generates several reports. The report period begins at the same start time in each case. The report period ends at a later time in each case and thus comprises increasingly large periods.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Bedeutung</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start of the reporting period.</td>
<td>The first time this dialog is opened, Industrial HiVision displays the time at which Industrial HiVision began recording the data for the selected template. If the report to be generated should start with data from a later point in time, you enter this time here. Possible: Point in time after recording has started and before report generation.</td>
</tr>
<tr>
<td>Offset to Execution</td>
<td>Designates the relative end of the data to be included in the report. The relative end of the data to be included in the report relates to the time at which the report was generated. The offset to execution is the amount of time between the relative end of the data to be included in the report and the time at which the report is generated. Possible: Amount of time between the start of recording and the first report generation.</td>
</tr>
</tbody>
</table>

Table 28: Scheduling with absolute start and relative stop times
Relative start and stop times (repeating)

Industrial HiVision generates several reports. Each report starts after the end of the preceding report. The reports contain data from successive periods of equal length.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Bedeutung</th>
</tr>
</thead>
<tbody>
<tr>
<td>First Execution</td>
<td>Time at which Industrial HiVision is to generate the first report.</td>
</tr>
<tr>
<td>Repetition</td>
<td>Amount of time between the generation of a report and the generation of the following report.</td>
</tr>
</tbody>
</table>

Table 28: Scheduling with absolute start and relative stop times

- **Generated reports**

  This dialog lists the generated reports. Industrial HiVision stores the generated reports in the installation directory in the directory `\var\report_files`.  
  - To display a report, select the report and click "View".  
  - To save a report, select the report and click "Save".  
  - To delete one or more reports, select the reports and click "Delete".  
  - To refresh the list, click "Refresh". After refreshing, Industrial HiVision adds to the list those reports generated since the last refresh.
Industrial HiVision displays the path where Industrial HiVision stores the reports below the table. For remote connections, the specified path refers to the file system on which Hirschmann Industrial HiVision 7.0 Service is running.

The data recorded by the reporting function are snapshots of a moment in time. They represent the value of a property as saved by Industrial HiVision at a particular point in time. Individual values have no bearing on the values from other points in time.

### 8.4.4 Scheduler

Scheduler offers the possibility of having repeating tasks of Industrial HiVision carried out automatically.

#### Tasks

This table shows you already defined tasks that Industrial HiVision carries out according to the stored schedule.

- To define a new task, click "New".
- To change a task, click "Edit".
- To delete one or more tasks, click "Delete".

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Task Name</td>
<td>Any name to identify this task.</td>
</tr>
<tr>
<td>Device</td>
<td>Selection of the device on which Industrial HiVision will run the task.</td>
</tr>
<tr>
<td>Task Type</td>
<td>Industrial HiVision makes the following types of tasks available:</td>
</tr>
<tr>
<td></td>
<td>▶ Standard</td>
</tr>
<tr>
<td></td>
<td>▶ Advanced</td>
</tr>
<tr>
<td></td>
<td>▶ Save Device Configuration</td>
</tr>
<tr>
<td></td>
<td>Depending on the selection, the subsequent part of this dialog changes.</td>
</tr>
</tbody>
</table>

*Table 30: Defining new tasks*
The "Scripts" dialog offers you the opportunity to add your own scripts to the selection of scripted actions.

- To define a new script, click "New".
- To change or import a script, click "Edit".
- To delete one or more scripts, click "Delete".
- To duplicate a script, click "Duplicate".

### Parameter

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Script Name</td>
<td>Any name to identify this script.</td>
</tr>
<tr>
<td>Content</td>
<td>Import script or enter script as text.</td>
</tr>
</tbody>
</table>

**Table 31: Define new scripts**
8.4 Configuration

**Schedules**

The “Schedules” dialog offers you the opportunity to define a schedule for carrying out a task.
- To define a new task, click "New".
- To change a task, click "Edit".
- To delete one or more tasks, click "Delete".

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Task name</td>
<td>List of defined tasks for selection in the &quot;Tasks&quot; dialog.</td>
</tr>
<tr>
<td>Execution</td>
<td>Type of execution: once or several times with entry of the start date and repeat interval for repeated execution.</td>
</tr>
<tr>
<td>Repetition</td>
<td>Entry of the repetition conditions for repeated execution: Number of repetitions, end date.</td>
</tr>
</tbody>
</table>

Table 32: Define a new schedule

**Note:** You can only schedule 1 task for a device.

**Results**

The "Results" table lists the results of the executed tasks.
- To view a marked result, click "View".
- To delete a result, click "Delete".
- To refresh the results list, click "Refresh".

**Example of Scheduling an Event for a Single Device**

This example demonstrates how to schedule an event to save a device configuration. If Industrial HiVision detects an error during the configuration saving process, then the detected error is entered in a log.

Industrial HiVision saves the log file in the following location:

\log\services\HiVisionKernelDB.0.stderr.log

**Note:** If the "Save Device Configuration" task fails during device configuration retrieval, then proceed as follows:
- Verify that Industrial HiVision can reach the selected device.
- Verify that the protocols, SNMP and HTTP or HTTPS, are active on the device.
Verify that Industrial HiVision has administration rights for SNMP, HTTP, and HTTPS on the selected device.

Verify that the selected device supports the “Save configuration to PC”, or “Export configuration” functions.

To schedule an event in Industrial HiVision for saving the configuration file for a single device, proceed as follows:

- Open Industrial HiVision and verify that the "Edit Mode" is active.
- To open the "Scheduler" dialog, click Configuration > Scheduler.

The following work steps pertain to the "Tasks" tab:

- To open the "New Entry" dialog, click the "New" button.
- Enter a name that describes the event for example, "Save Device Configuration".
- Select a device from the "Device" list.
- In the "Task Type" field, select the "Save Device Configuration" option from the drop down list.

When the selected device supports the function the fields in the "Save Config" frame are active. In the "Save Config" frame, enter the appropriate information in the following fields:

- In the "Destination folder", enter or browse to the location where you wish to save the configuration.
- Industrial HiVision enters DeviceConfig_<IP Address> in the "File name" field.
- The "On multiple task execution" field allows you to select how Industrial HiVision handles multiple files. To maintain a history of the configuration changes, select "Add timestamp to target file name".
- The "Reporting" field contains the "Suppress report creation for successfully completed task" checkbox. When active, the function creates a status report for every save configuration event that was performed (default setting).

- Click the "OK" button.

The following work steps pertain to the "Schedules" tab:

- To open the "New Entry" dialog, click the "New" button.
- In the "Task" field, open the "Name" drop down list and select the task created in the previous work steps.
- To have Industrial HiVision save the device configuration multiple times, in the "Execution" field, select "Multiple execution".
- You can leave the current date and time in the "Start Date" field (default setting).
- Change the "Interval" setting to 1 and the units to "Days".
To have Industrial HiVision save the device configuration every day until you change this setting, in the "Repetition" field, select the "Repeat indefinitely" option (default setting).

Click the "OK" button.

**Example of Scheduling an Event for Multiple Devices**

You can also schedule an event to save the configuration of multiple devices. If Industrial HiVision detects an error during the configuration saving process, then the detected error is entered in a log.

The log file is in the following location:
\log\services\HiVisionKernelDB.0.stderr.log.

**Note:** If the "Save Device Configuration" task fails during device configuration retrieval, then proceed as follows:

- Verify that Industrial HiVision can reach the selected device.
- Verify that the protocols, SNMP and HTTP or HTTPS, are active on the device.
- Verify that Industrial HiVision has administration rights for SNMP, HTTP, and HTTPS on the selected device.
- Verify that the selected device supports the “Save configuration to PC”, or “Export configuration” functions.

To schedule an event in Industrial HiVision for saving the configuration file for multiple devices, proceed as follows:

- Open Industrial HiVision and verify that the "Edit Mode" is active.
- In the "Map" tab, select the devices that you want to save the configuration. You can also select devices from the "List", "Devices", and "Security" tabs.
- Right-click a device.
- In the drop down menu, select the "Schedule Saving Device Configuration" option. The "Schedule Saving Device Configuration" dialog opens. In the "Device" field, Industrial HiVision highlights the devices that you selected in the "Map" tab.
In the "Save Config" field, enter the appropriate information in the following fields:
- In the "Destination folder", enter or browse to the location in which you wish to save the configuration.
- Industrial HiVision enters a DeviceConfig_<IP Address> in the "File name" field.
- The "On multiple task execution" field allows you to select how Industrial HiVision handles multiple files. To maintain a history of the configuration changes, select "Add timestamp to target file name".

The "Reporting" field contains the "Suppress report creation for successfully completed task" checkbox. When active, the function creates a status report for every save configuration event that was performed (default setting).

The "Reporting" field also contains the "Schedule Execution" function. The function allows you to schedule a save configuration file event. When the function is active, Industrial HiVision saves the configuration of the devices in a single file.

To have Industrial HiVision save the device configuration multiple times, in the "Execution" field, select "Multiple execution".

You can leave the current date and time in the "Start Date" field (default setting).

Change the "Interval" setting to 1 and the units to "Days".

Verify that the "1 minute delay between start of tasks" function is active. The function allows Industrial HiVision to add a delay between saving the configuration of the devices.

To have Industrial HiVision save the device configuration every day until you change this setting, in the "Repetition" field, select the "Repeat indefinitely" option (default setting).

Click the "OK" button.
8.4.5 Preferences

The “Preferences” window enables you to enter basic program settings. These settings relate to monitoring functions, management functions, display options, access rights and others.

- Click "OK" to accept changes in the setting dialogs and to close the window.
- Click "Apply" to accept changes in the setting dialogs before you switch to another setting dialog.
- Click "Cancel" to close the window. Changes not written using "Apply" are lost.

Importing and Exporting the Preference Settings

Industrial HiVision allows you to import and export the preference parameter settings. Industrial HiVision exports the preference file with a .prefs extension. You can use the file for a backup or importing the preference settings to a new management station. The application will restart after importing preferences settings.

For security reasons, Industrial HiVision excludes the following parameters from the export file:

- Passwords
- Password dependent preferences
- User Management settings
- Licenses
- Device Credentials
- Mobile Device Credentials

Note: Industrial HiVision displays an information message allowing you to apply the settings before you export the preference file.

Basics: discover devices

You use this dialog to specify which way Industrial HiVision should detect the devices in your network structure. Industrial HiVision enters newly detected devices in the default map entered. If you have not entered an activated default map in the network scan table (see below), then Industrial HiVision shows newly detected devices in the “New Devices” folder.
The search function in the tool bar helps you to find devices already detected.

Industrial HiVision provides the following options for the "Discovery Mode":

- **Standard**
  Industrial HiVision uses the option you select to detect devices.

- **Monitoring Mode**
  Industrial HiVision exclusively evaluates cold start "Cold Start Trap" and ARP answers to discover devices.

- **Rogue Device Detection**
  Industrial HiVision uses the option you select to detect devices and places newly discovered devices in the "Rogue Devices" folder.

Industrial HiVision provides the following options for discovering devices:

- Detecting devices using traps
- Detecting devices using the HiDiscovery protocol
- Detecting devices via a defined IP address range (Network Scan)
- Detecting newly created devices

Detecting devices using traps.
After they are switched on, the devices send a switched-on message to the network management station entered in the device.
Then Industrial HiVision reads the properties of the devices:
- Read device again: Industrial HiVision treats the device like a new device and reads in the entire properties and the structure of the device (new/removed model or power unit) again.
- Read properties again: Industrial HiVision reads the known properties in again.

Example: You switch on a device with 2 power supplies for the duration of some maintenance work. How does Industrial HiVision behave after the device is switched on if a voltage supply is missing?
- With the "Reload Device" setting, Industrial HiVision represents the device with one power unit and the color green.
- With the "Reload Properties" setting, Industrial HiVision represents the device with two power units, with one power unit in red.

Industrial HiVision displays the newly detected devices in the corresponding folder.

This method of detecting devices is suitable for use during ongoing monitoring in networks where you need to manage the bandwidth.
Detecting devices using the HiDiscovery protocol
The HiDiscovery protocol uses the MAC address to communicate with Hirschmann devices in the subnetwork on which the HiDiscovery protocol is active. The following Hirschmann device families support the HiDiscovery protocol.

- MACH
- GREYHOUND
- PowerMICE
- MICE
- RS
- RSR
- RSP
- GECKO
- OCTOPUS
- EES
- EAGLE
- BAT (without BAT-C)
- RR-EPL

This method enables you to detect devices in your network to which you have not yet assigned a valid IP address. Industrial HiVision displays the devices in the corresponding folder. This method is suitable for when you start up a newly installed network and want to assign the IP address to the new devices. Select this method for a limited time in order to spare your network an unnecessary network load.

☐ For the polling interval you enter the desired number in the related white field and select the units for this number – seconds, minutes, hours or days – in the selection field.

    Default setting: 5 minutes.

    Keep in mind how this affects your system resources (see on page 176 “Effect on system resources”).

Detecting devices using a defined IP address range
Using “Network Scan”, Industrial HiVision periodically sends ping requests to the devices with an IP address in the defined IP address ranges and displays the new devices that respond in the destination folder entered.

A firewall blocks the ping requests.
In order for Industrial HiVision to be able to discover devices behind a transparent firewall, activate "evaluate ARP". A transparent firewall forwards an ARP response. If the ping response does not come within a predetermined time, Industrial HiVision evaluates the ARP response.
The Network Scan method is suitable for monitoring a running network. Adapt the frequency of the requests to the bandwidth of your network.

- For the request interval you enter the desired number in the related white field (polling interval) and select the units for this number – seconds, minutes, hours or days – in the selection field. Default setting: 15 minutes.
  Keep in mind how this affects your system resources (see on page 176 “Effect on system resources”).

- Click "New" to enter an IP address range. Entering the IP address range includes
  - the first IP address of the query range
  - the last IP address of the query range
  - the related network mask
  - the activation/deactivation of this range for the query
  - the name you want to give the range
  - the default map in which you want Industrial HiVision to show a newly detected device.
  You can enter overlapping IP address ranges, then Industrial HiVision puts a copy of a device in each of the relevant folders.

The table shows the IP address ranges already created.

- Select a row in the table and click on "Edit" to edit this IP address range.
- Select a row in the table and click "Delete" to delete this row from the table.
- Select a row in the table and click on "Duplicate" to duplicate this IP address range so that you can then modify the copy.

Detecting newly created devices
Here you enter the initial setting for the dialog for entering the IP address which appears when you create a new device (see on page 111 “Creating new devices”).
Figure 54: Configuration::Preferences::Basics::Discover Devices
**Basic setting: User Management**

The User Management is based on a role model. You specify role names in the "Access Roles". You assign these roles the function of this role via the assignment of access authorizations. You can naturally assign the available rights to an administrator, whereas an observer can login, they cannot receive rights with which they are able to change anything.

Industrial HiVision provides the following access roles "Access Roles":

- Login
- Edit Mode
- User Management
- Web Access

Once you have created the "Access Roles", create the users and allocate them one or more of the roles set up above. This assignment depends on the method Industrial HiVision is supposed to use to verify a user's authorization.

Industrial HiVision uses three "Policies" to verify the authorization of a user:

- **Local Users**, local user name with role assignment.
  Industrial HiVision transfers the role names created above into the user table header. Thus allowing you to easily assign roles to a user name.

  Give the administrator of your LDAP server the information on Industrial HiVision users and their "Access Roles".
  Give your LDAP server administrator the following user data to enter into the LDAP server:
  - User Name
  - Password
  - Access Roles

  Give your RADIUS server administrator the following user data to enter into the RADIUS server:
  - User Name
  - Password
  - Access Roles

At the end of the User Management you can specify, which methods Industrial HiVision should use in order to verify the authorization of a user. As long as the "Selected Order" field is blank, Industrial HiVision is freely accessible.
Industrial HiVision uses the first entry in this field for an authorization check. If the test for the 1st method is unsuccessful, Industrial HiVision verifies the authorization according to the 2nd method. If Industrial HiVision cannot run any of the authorization checks successfully, Industrial HiVision denies access.

To allow HiMobile users access to the Industrial HiVision application, proceed as follows:

- Open Industrial HiVision.
- Verify that the "Edit Mode" is active.
- Open the Configuration > Preferences > Basics > User Management dialog.
- To create an access role for the HiMobile users, click the "New" button.
- In the "Role Name" field, enter HiMobile.
- In the "Permissions" frame, mark the "Login" and "Web Access" checkboxes.

**Note:** Hirschmann recommends that you deactivate the "Edit Mode" and "User Management" options for the HiMobile users.

- Click "OK".
- Open the Configuration > Preferences > Advanced > Services Access dialog.
- Verify that the "Web Server" option is active.
- Create a certificate and import it into your mobile device (see on page 196 “Certificate for the https connection”)

### Basic Settings: Event Forwarding

This dialog gives you the option of making settings for forwarding events to a syslog server.

With "Forward events to syslog server" you switch on/off the event forwarding function globally. When event forwarding is switched on, Industrial HiVision sends a syslog message to the syslog server entered in this dialog as soon as an event occurs.

With "Forward internal events", e.g. "Industrial HiVision Started", Industrial HiVision also sends syslog messages for Industrial HiVision internal events.

With "Event Type", you specify at what evaluation level of an event Industrial HiVision sends a syslog message.

In the "Forward events for devices" table, you enter the device whose events should lead to a syslog message.
In the "Syslog servers" table, you enter the data of the syslog server to which Industrial HiVision should send syslog messages.

*Figure 55: Configuration:Preferences:Basic Settings:Forward Events*
**Basics: Event Actions**

In this dialog you define the actions you want Industrial HiVision to perform when particular events occur.

![Figure 56: Configuration:Preferences:Basics:Event actions](image)

**Actions**

Actions describe what Industrial HiVision can carry out:

- Open the message window on the screen
- Send an SMS
- Play Sound
Send an e-mail

Execute a program (see note in “Installation under Windows”). In the figure below (see figure 57), you will find the user program “siren.exe” as an example.

☐ Click on "New" to specify the actions which you then want to assign to the events.
For actions that might not execute on the first try, such as a busy line when sending an SMS, Industrial HiVision gives you the option of repeating the action.

The "Send SMS" action requires
– that your network management station is connected to the telephone network, e.g. via a modem and
– that the SMS program is configured correctly.
Enter the telephone number of the recipient under "Recipient". If you enter the telephone number of your modem as the "Sender", then Industrial HiVision sends it with the message. You can thus recognize Industrial HiVision as the sender in the display of your mobile phone.
As the "Service Provider" you enter the available service which you configured in your SMS program (if available).

Under Preferences > Advanced > External Applications, check that the entries for the required external applications are present and that they meet your requirements.
The table shows the actions already created.
☐ Select a row in the table and click "Edit" to edit this action.
☐ Select a row in the table and click "Delete" to delete this row from the table.
☐ Select a row in the table and click "Duplicate" to duplicate this action so that you can then modify the copy.
Alarm
Industrial HiVision offers the possibility to perform an action when certain events occur or in the absence of confirmation of certain events. Under "Type", you choose when Industrial HiVision should perform the action.
Under "Alarm", enter any name for the event that is to trigger an action. Under "Filter", you define the event that is to trigger the actions selected below. Industrial HiVision allows wildcards for defining the filters.

<table>
<thead>
<tr>
<th>Designation</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Selection of the status type (error, warning, ...)</td>
</tr>
<tr>
<td>Category</td>
<td>Event of a particular category (status better, new device, ...)</td>
</tr>
<tr>
<td>User</td>
<td>Logon name from the network management station</td>
</tr>
<tr>
<td>Source</td>
<td>Cause of the event</td>
</tr>
<tr>
<td>Component</td>
<td>Component of the cause of the event</td>
</tr>
<tr>
<td>Message</td>
<td>Text describing the event</td>
</tr>
</tbody>
</table>

*Table 33: Filter criteria*
To simplify things, "Import..." provides you with the events that have already occurred from the list in the event frame.

Select a row and click "OK". Industrial HiVision copies the properties of the selected event into the filter frame.

The "Message" row enables you to enter the message text for actions. You can use the filter keywords with a $ sign as a prefix as a variable entry. Enter the keywords in upper-case characters. Example: If you enter "$TIME" in the message, Industrial HiVision enters the time the event occurred in the message. The keywords that Industrial HiVision provides you with are listed in the "Message" row of the bubble help.

The "Time" frame offers you the opportunity to set a time period during which Industrial HiVision responds to an event with an action.

In the "Actions" frame, you have the option of selecting one or more of the actions already created. Industrial HiVision executes these actions when the event defined above occurs or when confirmation of the event is absent within the time specified in "Type".
Figure 58: Configuration:Preferences:Basics:Event actions:Alarm messages
Basic settings: User defined actions

User-configurable actions give you the opportunity of starting actions on other devices from your network management station, for example.

<table>
<thead>
<tr>
<th>Location</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Desktop</td>
<td>Industrial HiVision starts the application on the computer on which the Industrial HiVision interface is running. The service can run on another computer. You choose “Desktop” when the application that Industrial HiVision starts expects an interaction. Application example: Starting a Telnet client</td>
</tr>
<tr>
<td>Service</td>
<td>Industrial HiVision starts the application on the computer on which the service is running. This selection gives you the option of configuring devices that only permit configuration from the IP address of the network management station. Application example: Configuration scripts which you want to call up from multiple interfaces (and also from applets) or use to run batch files (see “Example of interface”).</td>
</tr>
<tr>
<td>Browser</td>
<td>Industrial HiVision starts the application with the URL. Example: To open the graphical user interface of a device in the browser, enter the following further down under “Parameters”: <a href="http://10.0.1.13">http://10.0.1.13</a>.</td>
</tr>
</tbody>
</table>

Table 34: Location of execution of a user-defined action

Example of interface: “Call up Telnet client”
You want to use a Telnet client, e.g. “Putty”, to access a known device such as a switch.

- In the Industrial HiVision menu bar, select Configuration > Preferences.
- In the settings dialog, select Basics > User defined Actions.
- To define a new user-configurable action, click “New”.
- To call up the Telnet client, enter any name, e.g. “Manage Switch via Telnet”.
- Available for

  In this line, you select the symbol with which you wish to start the action. Industrial HiVision places the action in the selection list according to the definition. You can find the action under "Actions" by right-clicking this symbol. As you want to call the action later at device level, choose the object type "Device".

  As the "Device Type", choose "Switch".

-
You want to start the Telnet client on a computer on which the Industrial HiVision graphical user interface is running. The Telnet client expects an interaction with the administrator of the switch. Therefore you select "Desktop" as the "Location of Execution" (see table 34).

Under "Application", enter the path of the application and the application or select the application in the file selection dialog by clicking "...".
To select the Telnet client Putty, enter the following for the example:
C:/Data/Software/putty.exe.

The "Parameters" line gives you the option of transferring parameters to the application with tokens. Enter the following in the example:
- Call up Telnet
- The token for the IP address of the device

$"-telnet $IP_ADDR"

Example for service: "Switch port on/off"
You have a visitors' room with Ethernet connections. The room can be accessed by anybody. Therefore you would like to enable a port that is connected to this Ethernet connection exclusively when you actually have visitors.

To do this, write two small batch files with the SNMP commands for switching the port on/off:

1st batch file: Port-on.bat
<installation folder>\bin\SnmpSet -c private $IP_ADDR
1.3.6.1.2.1.2.2.1.7.$USER integer 1

2nd batch file: Port-off.bat
<installation folder>\bin\SnmpSet -c private $IP_ADDR
1.3.6.1.2.1.2.2.1.7.$USER integer 2

Save the two batch files on your network management station, e.g. under C:/Data/PortOnOffBatch

In the Industrial HiVision menu bar, select Configuration > Preferences.
In the settings dialog, select Basics > User defined Actions.
To define a new user-configurable action, click "New".
Enter the name of your choosing for the 1st batch file, for example "Switch on visitor port".
Available for
In this line, you select the symbol with which you wish to start the action. Industrial HiVision places the action in the selection list according to the definition. You can find the action under "Actions" by right-clicking this symbol.
As you want to call the action later at device level, choose the object type "Device".

In this example the port for the visitors' connection is connected to a RS30 rail switch. Therefore, under "Device Type" you select "OpenRail, Mach 4000, Octopus".

You would like to execute the batch files on a computer on which the service of Industrial HiVision is running. Industrial HiVision passes the interface number of the port as a command parameter when calling up the batch file. Then the batch files run automatically. Therefore you select "Service" as the "Location of Execution" (see table 34).

Under "Application", enter the path of the application and the application or select the application in the file selection dialog by clicking ....
Enter the following for the example:
C:/Data/LANmanagementBatch/Port-on.bat.

The "Parameters" line gives you the option of transferring parameters to the application with tokens. Enter the following in the example:
- The token for the IP address of the device
- The object ID for switching on the port (1.3.6.1.2.1.2.2.1.7)
- The token for the port
$IP_ADDR 1.3.6.1.2.1.2.2.1.7.$USER 2

The "Parameters" line gives you the option of entering a parameter for transferring to the application when the action is called.
For our example:
Enter the interface number of the port:

You can find further function details under "Advanced":

- **Token Language**
  Industrial HiVision transfers the token content to the application in this language. This applies to the tokens: "Status (textual)", "Value" and "Name".
- **Query password when calling action**
  If more than 30 minutes elapse between password entry and the next call of the action, then Industrial HiVision queries the password again.
- **Display settings for the content of the application event**
- **Display settings for the display type of the application event**

Only In Case Of Failure: There has been a failure if the return value of the application has a value other than 0.
Example for browser: “Call up web browser”
You want to access the Web server of your Industrial HiVision service to read the event list.

☐ In the Industrial HiVision menu bar, select Configuration > Preferences.
☐ In the settings dialog, select Basics > User defined Actions.
☐ To define a new user-configurable action, click "New".
☐ To call up the Telnet client, enter any name, e.g. “Event list”.
☐ Available for
   In this line, you select the symbol with which you wish to start the action. Industrial HiVision places the action in the selection list according to the definition. You can find the action under "Actions" by right-clicking this symbol.
   As you want to call the action later at device level, choose the object type "Device".
☐ As the "Device Type", choose "Windows PC".
You want to view the event list in your web browser. Therefore you select "Browser" as the "Location of Execution" (see table 34).

The "Parameters" line gives you the option of transferring parameters to the application with tokens. Enter the following in the example:
- Call up the Web browser
- The token for the IP address of the computer on which the service of Industrial HiVision is running.
- The port for the Web server of Industrial HiVision
- The Web page you want to view

http://$IP_ADDR:11151/events
Basics: License

You require a license key to operate Industrial HiVision. The number of devices you can display depends on the license key. You thus have the option of adapting the amount you invest in Industrial HiVision to the growth of your network.

After a new installation or an update, you require new license keys. Industrial HiVision puts devices for which no license exists into the “Unmanaged” state. When you have entered a license key for these devices, you can put these devices into the “Managed” state again (see on page 213 “Manage”).

Industrial HiVision uses a seal to represent devices without a valid license.

Figure 60: Device without Industrial HiVision license key.

- Click "New" and enter the license key in the entry window. If you have the license key in electronic form, then you can use copy and paste to save having to type it in.
- Complete the entry using "OK".
- You add new license keys and update licenses in the same way.

After you enter a license key, Industrial HiVision displays this license key in a row of the table.

<table>
<thead>
<tr>
<th>Designation</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Key</td>
<td>Key number</td>
</tr>
<tr>
<td>Version</td>
<td>Software version number of Industrial HiVision</td>
</tr>
<tr>
<td>Expires</td>
<td>Date upon which the validity of the license ends</td>
</tr>
<tr>
<td>Type</td>
<td>Full version or update version</td>
</tr>
<tr>
<td>Devices</td>
<td>Number of devices covered by the license</td>
</tr>
<tr>
<td>Hardware Key</td>
<td>Hardware key that you entered when requested to enter the license key.</td>
</tr>
<tr>
<td></td>
<td>If the hardware key of this license key matches the hardware key under this license table, then you can use this license key on this network management station.</td>
</tr>
</tbody>
</table>

Table 35: Entries in the license table
A full license allows you to monitor a particular number of devices in Industrial HiVision. A full license is linked to the version of Industrial HiVision at the time of purchase.

**Note:** To determine the hardware key, Industrial HiVision uses a number of hardware components of its network management station. These hardware components include the network interface cards. For you to be able to replace hardware components, Industrial HiVision compares specific combinations of the hardware components in order to determine the hardware key.

As long as at least one of the network interface cards in the network management station that was installed when the license key was requested is active, Industrial HiVision detects the correct key. In this case, Industrial HiVision requires that other hardware components are still installed.

When Industrial HiVision detects that the management station is without an active interface card the "Hardware Key" field displays this message. "The Hardware Key is not valid. It contains no network interface." To display the hardware key, add or activate a network interface.

**Leased licenses**

When you have a hierarchical network structure and have leased licenses to subdomains, the bottom part of the license dialog contains a table for displaying the leased licenses.

This table contains 3 columns:
- Subdomain name
- IP Address
- Leased licenses

---

<table>
<thead>
<tr>
<th>Designation</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>License Holder</td>
<td>Name that you entered when requested to enter the license key.</td>
</tr>
<tr>
<td>Registration Code</td>
<td>Registration code you received upon purchase of a full version, upgrade or maintenance schedule. You used this registration code to request the license key.</td>
</tr>
</tbody>
</table>

*Table 35: Entries in the license table*
- **Display:Language**
  This dialog gives you the option to choose the language of the graphical user interface and the date formats.
  Default settings:
  - Language: system language of your computer.
  - Date format of the interface: year-month-day
  - Date format of the service: year-month-day
**Display:Event**
This dialog gives you the option of entering initial settings for the displaying of events.

**Events in the event list** (see figure 5):

- **Maximum number of events you can display**
  Use the drop-down menu to select the maximum number of events which Industrial HiVision should display in the event list. If more events occur than the number specified, then Industrial HiVision discards the older events (first in, first out).
  Default setting: 1000
  Value range: ≤50000

- **Event display**
  You use "Show Event List and Summary" to display/hide the event list and the event summary in the main window.
  Default setting: display.

- **Event log in file**
  With "Logging Enabled" you can set Industrial HiVision to write every event that occurs in the event log file. Industrial HiVision writes the event log file in the language of the operating system.
  You will find the HiVisionEvents0.log event log file in the installation directory of Industrial HiVision under \log\events. If the HiVisionEvents0.log file exceeds a size of 1 MB, then Industrial HiVision renames the HiVisionEvents0.log file as HiVisionEvents1.log. Industrial HiVision writes new events in the new HiVisionEvents0.log file.
  If the size of the HiVisionEvents0.log file exceeds 1 MB again, Industrial HiVision renames
  - the HiVisionEvents1.log file as HiVisionEvents2.log
  - the HiVisionEvents0.log file as HiVisionEvents1.log.
  etc.
  Industrial HiVision can write up to 1000 log files. If other events occur, Industrial HiVision overwrites the HiVisionEvents999.log file in accordance with the scheme described above.
Logfile path
As an alternative to the installation directory, this line gives you the option of choosing a path on which Industrial HiVision writes the event log file.

**Note:** Delays or interruptions while writing to a network drive can block the Industrial HiVision service.

**Note:** Delays and interruptions in the network can result in gaps in the content of the event log file.

**Note:** As the service writes the log file, the local system account requires write permission for this directory.

Status change caused by status propagation
A status change for a property of a component/folder is an event which Industrial HiVision can display as an entry in the event list. Use the drop-down menu to choose between:
- No event, if you only want to display the status changes on the lowest level as an entry. The status changes which are propagated upwards from the lowest level are hidden by Industrial HiVision as an event entry.
- Info event, if you want Industrial HiVision to display the status changes as entries in the event list. The event entries caused by a propagated status change are assigned the type “Info” (see on page 80 “Number of events”).
- Event severity from status, if you want Industrial HiVision to display the status changes as entries in the event list. The event entries caused by a propagated status change are assigned the type corresponding to the propagated status change on this level.
Default setting: No event.

Source
For an event that relates to a device, Industrial HiVision adds to the event list the device name with the location that you entered in the "Location" device property.
Events on the Industrial HiVision website
(see on page 190 “Events on the website”)

- Days in event log
  On the event website, Industrial HiVision displays the events for the number of previous days that you enter here.
  Default setting: 7 days

- Automatic page refresh every [min.]
  Industrial HiVision refreshes the event website periodically. Here you enter the length of the period in minutes.
  Default setting: 5 minutes

“I'm alive” event:
(see on page 168 “Industrial HiVision “I'm alive” event”)

- Send “I'm alive” events
  When this is active, Industrial HiVision periodically sends the event defined as the ""I'm alive" Event" action.
  Default setting: inactive

- Send interval
  Default setting: 1 minute

- Send warning events since last “I'm alive” event
  When this is active, Industrial HiVision also sends, along with the “I'm alive” event, the events with a warning status that Industrial HiVision registered since it sent the last “I'm alive” event.
  Default setting: inactive
Figure 61: Configuration:Preferences:Display:Event
Display: Device
This dialog allows you to specify the displaying of the devices in the network, the connections between the devices and the labeling.

Symbol
Click on the relevant white radio button to select between:
- Realistic: display the device as a product image
- Abstract: display the function of the device using a symbol
Default setting: Realistic

Status Visualisation
Here you specify how Industrial HiVision optically displays the status of the devices or a status change on the screen. Industrial HiVision provides the following display options:
- Flash after status change
- Acknowledged OK with Color
- Status Symbol in Icon
- Filled Background
- Frame
- Icon and Text Flash as well
Default setting: colored background and frame activated.

Font
Enter the font size (in points) and the font type for the labeling of the devices and the connections between the devices. Default setting: font size = 13, font type = Arial.

Device Appearance
Specify the icon size and the maximum width (in pixels) with which Industrial HiVision displays the devices in the network on the screen. Default setting: icon size = 48, max. width = 150.
Connection Appearance
- Specify whether and how Industrial HiVision labels connections between the devices in the network on the screen. You use the “Labeling” drop-down menu to select when you want Industrial HiVision to label a connection with the status of the connection. Options: always, never, under mouse pointer. Default: never.
- You use the “Labeling terminal points” drop-down menu to select when you want Industrial HiVision to label the terminal points of the connection. Options: always, never, under mouse pointer. Default: under mouse pointer.
- The settings for “Line Thickness” provide you with a better overview of the connection speed and the connection status in the topology view. If the speed display is activated, when the speed is increasing Industrial HiVision increases the line thickness in 2-point steps at 10, 100, 1000, 10000 MBit/s. If the speed display is activated, Industrial HiVision displays the current connection setting in the bubble help. If the speed display is deactivated, Industrial HiVision displays the current speed setting even if you have activated the speed display in the connection properties dialog (see on page 234 “Connection”). If the status display is activated, when the status weighting increases Industrial HiVision increases the line thickness in 2-point steps. Default setting: status.
- The “Minimum Line Thickness” is the minimum thickness applied by Industrial HiVision when increasing the line thickness depending on the speed. Possible: 1, 3, 5. Default setting: 1.

Preview
The preview frame shows you how your settings affect the display.

<table>
<thead>
<tr>
<th>Display</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>OK Acknowledged</td>
<td>Status has not changed and is OK</td>
</tr>
<tr>
<td>OK Status Changed</td>
<td>Status has changed and is OK</td>
</tr>
<tr>
<td>Warning Acknowledged</td>
<td>Status has not changed. There is a warning message</td>
</tr>
</tbody>
</table>

Table 36: Preview for displaying devices and connection lines
If you click on "Reset to Defaults", the changes you made are reset to the default settings.

Table 36: Preview for displaying devices and connection lines

<table>
<thead>
<tr>
<th>Display</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Warning Status Changed</td>
<td>Status has changed. There is a warning message</td>
</tr>
<tr>
<td>Error Acknowledged</td>
<td>Status has not changed. There is an error</td>
</tr>
<tr>
<td>Error Status Changed</td>
<td>Status has changed. An error has occurred</td>
</tr>
</tbody>
</table>

Figure 62: Configuration:Preferences:Display:Device
## Display: Appearance

This dialog allows you to alter the text display and the tab page selection:

- **Text placement in the tool bar**
  Default setting: text alongside symbol.

- **Font size**
  Default setting: depends on the screen resolution.

- **Display password as stars (not readable) when dialogs are opened in which you enter or can see passwords.**
  Default setting: passwords as stars.

- **Tab page selection:**
  Depending on the context, Industrial HiVision provides you with various tab pages.
  - Select "Saved settings" to display the tab page last opened in this view when you open the view.
  - Choose "Default settings" so that Industrial HiVision selects the tab page with the list display below the device level.
  - Choose "Don't apply" so that when Industrial HiVision changes to another device or component detail, it keeps the current display type (list or topology display).
  Default setting "Saved settings".

![Image of Display: Appearance dialog]

*Figure 63: Configuration: Preferences: Display: Appearance*
Display: Status Colors

This dialog allows you to assign a color to every status. You can select the colors for the foreground and the background.

<table>
<thead>
<tr>
<th>Status</th>
<th>Foreground</th>
<th>Background</th>
</tr>
</thead>
<tbody>
<tr>
<td>OK</td>
<td>Black</td>
<td>Green</td>
</tr>
<tr>
<td>Warning</td>
<td>Black</td>
<td>Yellow</td>
</tr>
<tr>
<td>Error</td>
<td>White</td>
<td>Red</td>
</tr>
<tr>
<td>Unavailable</td>
<td>Black</td>
<td>gray</td>
</tr>
<tr>
<td>No Status</td>
<td>Black</td>
<td>White</td>
</tr>
</tbody>
</table>

Table 37: Default setting of the status colors

- If you click on "Reset to Defaults", the changes you made are reset to the default settings.

Figure 64: Configuration: Preferences: Display: Status Colors
Display: Device Icon

This dialog enables you to assign defined default icons to different device types when devices are detected.

- Click on “New” to define a new default icon assignment or select a row in the table and click on “Edit” to edit this entry.

Industrial HiVision provides the following methods for differentiating the device types:

- System Object Identifier (SysOID)

<table>
<thead>
<tr>
<th>Method</th>
<th>SysOID</th>
</tr>
</thead>
<tbody>
<tr>
<td>SysOID</td>
<td>Manufacturer ID</td>
</tr>
<tr>
<td>Icon</td>
<td>Click on “?” to search your file system for an image file for the icon.</td>
</tr>
</tbody>
</table>

- EtherNet/IP

Along with entering the parameters in the dialog, Industrial HiVision allows you to load the parameters from an EDS file (electronic data sheet).

<table>
<thead>
<tr>
<th>Method</th>
<th>EtherNet/IP</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vendor Code</td>
<td>Manufacturer ID in the device description based on EtherNet/IP.</td>
</tr>
<tr>
<td>Product Type</td>
<td>Product type in the device description based on EtherNet/IP. An “*” in this field means “all product types”.</td>
</tr>
<tr>
<td>Product Code</td>
<td>Product code in the device description based on EtherNet/IP. An “*” in this field means “all products”.</td>
</tr>
<tr>
<td>Icon</td>
<td>Click on “?” to search your file system for an image file for the icon.</td>
</tr>
</tbody>
</table>

- Modbus/TCP

<table>
<thead>
<tr>
<th>Method</th>
<th>Modbus/TCP</th>
</tr>
</thead>
<tbody>
<tr>
<td>VendorName</td>
<td>Manufacturer ID in the device description based on Modbus/TCP.</td>
</tr>
<tr>
<td>Product Code</td>
<td>Product code in the device description based on Modbus/TCP. An “*” in this field means “all products”.</td>
</tr>
<tr>
<td>Icon</td>
<td>Click on “?” to search your file system for an image file for the icon.</td>
</tr>
</tbody>
</table>

- MAC address

<table>
<thead>
<tr>
<th>Method</th>
<th>MAC Address</th>
</tr>
</thead>
</table>
In the table, you can:
– add new entries
– edit existing entries
– delete existing entries
– duplicate existing entries
– add new EtherNet/IP entries by loading EDS files. Industrial HiVision loads the EDS files selected together with the corresponding icon files. Industrial HiVision also finds icons in manufacturer-specific subfolders.

In the device detection, and for selected devices with Edit > Set Default Device Icon, Industrial HiVision checks the device type. Industrial HiVision assigns the device the first icon that Industrial HiVision finds in the table.
You can use "Up" and "Down" to change the sequence of the entries in the table.
The icons already defined in Industrial HiVision for Hirschmann devices are hidden at the top of the table. Thus Industrial HiVision assigns the correct icons to the Hirschmann devices.
Figure 65: Assignment table for device icons
Advanced: Program Access

Expire Time for Edit Mode
With the Expire Time you define how long Industrial HiVision stays in the Edit Mode after you have made an entry. When this time has expired, Industrial HiVision switches to the “Run Mode”. Possible settings: 5 to 60 minutes or “Permanent”.

Web Access
"Generate an Event for every Successful Web Access" allows you to also generate an event for every successful Web access, in addition to unauthorized access attempts.

"Allow Renaming" allows you to rename a property of component details, e.g. to change “In Load” to “Volume of Incoming Data”.

"Auto Reload" allows you to get Industrial HiVision to
– query the current values for a property dialog when it opens this dialog and/or
– query the current values of the content of the detail frame when it opens this frame.
"If Value Older than" allows you to make the automatic querying of the values to be displayed dependent on the age of these values.

Include device passwords in documentation
"Device Documentation" allows you create the device documentation with a readable or a hidden password.
Default setting: password hidden.

<table>
<thead>
<tr>
<th>SNMP V1</th>
<th>admin, MD5: ******, DES: ******</th>
<th>public, private</th>
</tr>
</thead>
<tbody>
<tr>
<td>SNMP V3</td>
<td>admin, MD5: ******, DES: ******</td>
<td>admin, MD5: private, DES: private</td>
</tr>
</tbody>
</table>

Table 38: Example device documentation with a readable and a hidden password.

Note: If you have forgotten your password, then quit Industrial HiVision. Logon to Windows as an administrator or to Linux as a root and start Industrial HiVision again. Restarting Industrial HiVision as an administrator or as a root enables you to make a new entry without the password being queried first.
Advanced: Services Access

The "Services Access" dialog allows you to activate and deactivate various methods of accessing network management from another computer. When a firewall separates your Industrial HiVision services from a client, add a rule to the firewall to forward data between the services and client. See “Using Industrial HiVision with Firewalls” on page 61.

- **Web Server**
  This service allows you to access your network management server via a Web browser using another computer. The address of the Web server is:
  
  protocol://IP address of the network management station:port number, e.g.
  
  When setting up a secure connection using https, Industrial HiVision uses a Hirschmann certificate that classifies your browser as invalid. If you want to use this service, then you trust this connection, add an exception to your browser and save it.
  
  If you wish to specify a different value that Industrial HiVision uses to connect to the "Web Server", then unmark the "Use Default Values" checkbox and enter the desired value in the "Port" field. Marking the "Use Default Values" checkbox resets the value in the "Port" field to the default value, 11165.

- **Project Data Server**
  With "Remote Access" you allow Industrial HiVision interfaces running on other computers to have access to the local Industrial HiVision service.
  
  If you allow "Services Access", then the local interface, exactly like the interface of the external computer, is connected via the network connection instead of via internal IP address 127.0.0.1. A result of this is that the internal interface also loses the connection to the service if the network connection is interrupted.
  
  Port displays the port via which Industrial HiVision interfaces running on other computers can access the local Industrial HiVision service.
  
  Subdomain interface
  
  If you activate the subdomain interface, you allow another network management station to access the local application Industrial HiVision as a superdomain.
  
  Password:
  
  If you use this management station as a subdomain, then this dialog gives you the option to enter the password for access to the subdomain interface. See “Connect subdomains to superdomains” on
The OPC server allows you to activate the Industrial HiVision OPC server (see on page 183 “Structure of the transfer data for OPC”). With "Global Write" you allow object values to be written in Industrial HiVision via an OPC write command (see on page 181 “Link to process visualization system”).

When using HTTP to connect to the Industrial HiVision OPC UA server, configure the OPC UA client to access the server on the port displayed in the "OPC UA Server Port (http)" field.

When using HTTPS to connect to the Industrial HiVision OPC UA server, configure the OPC UA client to access the server on the port displayed in the "OPC UA Server Port (https)" field.

![Services Access](image)

*Figure 66: Configuration > Preferences > Advanced > Services Access*
Advanced: Device Credentials
Industrial HiVision supports you in communicating with SNMP devices by means of automated password usage.

"Device Credentials"
When setting up the communication with an SNMP device, Industrial HiVision tries to get access using known passwords and user names. For an attempt with an incorrect password, Industrial HiVision gets an authentication trap from the relevant device. For an attempt with a correct password, Industrial HiVision gets a reply to an SNMP query and enters the correct password and user name into the upper table of this dialog.

SNMP Guess List
When setting up the communication with an unknown SNMP device, Industrial HiVision attempts to authenticate itself with the login data from the SNMP guess list. You use "New" to create a new entry in the table. A selected table entry you
– change using "Edit"
– delete using "Delete" or
– duplicate using "Duplicate"

"Hide Passwords"
allows you to display passwords unreadable, as stars. When you open this dialog, the setting for this field depends on the setting in the "Display:Appearance" dialog.
Along with the automatic password usage, Industrial HiVision also gives you the option of manually entering the SNMP configuration for individual SNMP devices.

- For the SNMP configuration, click "New" to open the input dialog.
- Enter the IP address of the device for which you want to enter the SNMP access configuration.
- Select the SNMP version that supports the device.
- Depending on the SNMP version selected, you enter the required access information:

<table>
<thead>
<tr>
<th>SNMP version</th>
<th>Designation</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>V1</td>
<td>Read Password</td>
<td>Password with which you can get read access to the device</td>
</tr>
<tr>
<td>V1</td>
<td>Write Password</td>
<td>Password with which you can get write/read access to the device</td>
</tr>
<tr>
<td>V3 (easy)</td>
<td>User name</td>
<td>User name with which you can access the device</td>
</tr>
<tr>
<td>V3 (easy)</td>
<td>Password</td>
<td>Password belonging to the user name.</td>
</tr>
<tr>
<td>V3 (complete)</td>
<td>User name</td>
<td>User name with which you can access the device</td>
</tr>
<tr>
<td>V3 (complete)</td>
<td>Authentication</td>
<td>SHA, MD5 method for authentication of the message</td>
</tr>
</tbody>
</table>

Table 39: SNMP configuration entries
Under "Advanced" you will find SNMP-specific exchange parameters. The default settings are sufficient for many requirements.

- With "Timeout [s]" you specify how long Industrial HiVision should wait for the response to an SNMP query. If there is no response, then Industrial HiVision repeats the SNMP query.
- With "Retries" you specify how often Industrial HiVision should repeat the SNMP query if there is no response. For each repetition, Industrial HiVision doubles the timeout time, Industrial HiVision sends a new query.
- With "Port No" you select the protocol port of the device to which Industrial HiVision sends an SNMP query.
- Hide Passwords allows you to display passwords for this table entry unreadable, as stars.

### Table 39: SNMP configuration entries

<table>
<thead>
<tr>
<th>SNMP version</th>
<th>Designation</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>V3 (complete)</td>
<td>Password</td>
<td>Password for the authentication</td>
</tr>
<tr>
<td>V3 (complete)</td>
<td>Encryption</td>
<td>DES, AES128, symmetrical encryption algorithm</td>
</tr>
<tr>
<td>V3 (complete)</td>
<td>Password</td>
<td>Password for the encryption</td>
</tr>
</tbody>
</table>

V3 (complete) Password: for the authentication
V3 (complete) Encryption: DES, AES128, symmetrical encryption algorithm
V3 (complete) Password: for the encryption
Figure 68: Configuration:Preferences:Advanced:Device Credentials:New
Advanced: Management Station

In this dialog you enter the default setting for IP parameters. Industrial HiVision enters these default settings when you open dialogs where IP parameter entries are expected, e.g. IP configuration of devices which Industrial HiVision detected using HiDiscovery.

"IP Address Prefix":
Here Industrial HiVision enters the prefix of its own IP address.

"Default Netmask":
Here Industrial HiVision enters the network mask of its own IP address.

"Default Gateway":
Here Industrial HiVision enters the prefix of the gateway which your network management station also uses.

"IP Address Management Station":
If your network management station has a number of IP addresses, then Industrial HiVision enters these IP addresses in the drop-down menu.
☐ Select the address you want to use as a trap destination address.

"Network Card Management Station":
If your network management station has a number of network cards, then Industrial HiVision enters these cards in the drop-down menu.
☐ Select the card which you want the HiDiscovery protocol to access.
Figure 69: Configuration:Preferences:Advanced:Management Station
**Advanced: OPC-SNMP**

The OPC server of Industrial HiVision allows you to use an OPC client query to determine SNMP values for devices. In the **Advanced > OPC-SNMP** dialog you enter the SNMP attributes whose values you want to determine. In the table, you can

- add new entries
- edit existing entries
- delete existing entries
- duplicate existing entries

In the "Edit" and "New" dialogs, you can enter the SNMP attributes directly, or select them from an MIB.

To select an SNMP attribute from an MIB, you click on "Select MIB Attribute..." to open the "MIB Viewer" dialog and select an SNMP attribute. You can use the "MIB Manager" to load additional MIBs.

Give the entry a brief, meaningful name, as this will be used later on for the query in the OPC tag.

If you use an Object Identifier (OID) in the OPC tag, you enter the complete OID, including any existing instance.

The OPC tag for an OPC client query is, for example:

```
Industrial_HiVision.snmp.get.10:0:1:159,161,ifAdminState
```

Whereby:

- **10:0:1:159** is the IP address of the device, with a colon instead of a dot as a separator
- **161** is the SNMP port
- **ifAdminState** is the name of the SNMP attribute, as configured in the settings
Figure 70: Configuration:Preferences:Advanced:OPC-SNMP
Advanced: Service Parameters

The Industrial HiVision program starts its own service. Your PC operating system displays this Industrial HiVision service for you.

The Industrial HiVision service is made up of the following services:

- **Device Discovery**
  - **Scan Rate [devices/min]**
    This service performs the network scan (see on page 258 “Basics: discover devices”). The scan rate limits the number of pings/minute. (default setting: 600)
  - **Simultaneously Discovered Devices**
    This setting allows you to modify the network load during the device discovery. Here you enter the number of devices that Industrial HiVision simultaneously queries during the device discovery. (default setting: 20)
  - **SNMP Guessing Packet Rate [pkts/s]**
    With this setting you define up to how many guess packets per second Industrial HiVision sends to an unknown SNMP device to discover the login data. (default setting: 100)

- **Web Server**
  - **Web Server Root Directory**
    The parameter displays the Industrial HiVision web server base directory.
  - **Web Server Session Timeout [min]**
    This parameter allows you to specify the maximum idle time for web server sessions. (default setting: 20)
Device Availability
These settings allow you to adjust Industrial HiVision to the ping response behavior of your devices.

- **Ping Timeout [s]**
  If the ICMP device responds to a ping request within this period, then Industrial HiVision classifies the device as still present, if it responded to the last request.

- **Max. Ping Response Time [ms]**
  If the ICMP device responds to a ping request within this period, then Industrial HiVision detects that the device is present again, if it did not respond to the last request.

Lower values improve the performance of Industrial HiVision. If the values are too low, the ping response may come too late and Industrial HiVision displays the device as “unreachable”. With large subnetworks that can show short term interrupts, you should use smaller values. Larger values can cause status changes to be displayed late in Industrial HiVision.

Simultaneously Discovered Devices: This setting allows you to modify the network load during the device discovery. Here you enter the number of devices that Industrial HiVision simultaneously queries during the device discovery.
Reporting
- Reliability Polling Intervals
  The value queried was recorded a longer time ago than the maximum number of polling intervals x the polling interval [s] of the property query (see on page 227 “Properties of a component detail”).
- Replication Lock for Reporting Events [s]:
  The retry block helps you to reduce how often repeating events are recorded in the event list (default setting: 3600).
  Industrial HiVision records reporting events of the "Warning" and "Error" types if their last recording was further back than the duration of the retry block.
  Industrial HiVision considers a change after the program is restarted.

Statistics
- ICMP Statistics - Moving Average Number of Samples
  The entry specifies the moving average which is computed based on a subset of response times (default setting: 5).
  The moving average is included as a property type per device in protocol properties and can be added to the reporting tool.
- SNMP Statistics - Moving Average Number of Samples
  The entry specifies the moving average which is computed based on a subset of response times (default setting: 10).
  The moving average is included as a property type per device in protocol properties and can be added to the reporting tool.
Figure 71: Configuration:Preferences:Advanced:Services
Advanced: External Applications
Industrial HiVision uses external auxiliary programs for the following functions:

- Telnet
- SSH
- Browser
  Auf Linux-Systemen benutzt Industrial HiVision als Standard-Browser den Mozilla Firefox. Wenn Sie einen anderen Browser einsetzen möchten, dann tragen Sie den Pfad zu Ihrem Browser in die Zeile "Browser" ein.
- Ping
- PDF Viewer
- Mail Server
  To carry out email configuration
- Geographical Location View
  URL entry for summoning the geographic location display program, e.g. maps.google.
  http://maps.google.de/maps?q=$LATITUDE,$LONGITUDE($NAME)&z=19
  See “Geographical Location View” on page 244.
Advanced: Device/Port Names

With this dialog you manipulate the names of the devices and ports in the respective Properties dialog and thus their representation in the user interface.

You first select whether Industrial HiVision displays the devices and ports with their preset names, or whether Industrial HiVision determines the names from the device.

When adding new devices to Industrial HiVision, the "Device/Port Names" frame allows you to select the method in which Industrial HiVision displays the device names.

- The "Basics": "Use default names or entered names" function allows Industrial HiVision to display new devices with the IP address.
- The "Basics": "Set names from device in Industrial HiVision" function allows Industrial HiVision to display the name of the new devices.

Note: The "Reset to Defaults" button only resets the dialog to the default settings.

To change the manner in which Industrial HiVision displays the device name, use the following steps:

- Delete the device from Industrial HiVision.
- Change the "Device/Port Names" dialog for the desired results.
- Rescan the network for the device.

Determining device names

<table>
<thead>
<tr>
<th>Method</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Query DNS</td>
<td>when it detects a new device, Industrial HiVision determines the device name from the Domain Name Server.</td>
</tr>
<tr>
<td>Query now</td>
<td>For the devices already detected, Industrial HiVision determines the device name from the Domain Name Server. This procedure can take some time.</td>
</tr>
<tr>
<td>Use name from host file</td>
<td>For the devices already detected, Industrial HiVision reads the device name from the hosts file. The hosts file is the <code>hosts.txt</code> text file in the <code>config</code> subdirectory of the installation directory. The hosts file contains a row for each device with the IP address and the name, separated by a tab.</td>
</tr>
<tr>
<td>Read in now</td>
<td>For the devices already detected, Industrial HiVision reads the device name from the hosts file.</td>
</tr>
</tbody>
</table>

Industrial HiVision writes the host name and the DNS name into the MAC/IP address assignment table (see on page 319 “MAC/IP List”).
"Set Device Name"
This frame enables you to choose which name Industrial HiVision puts into the name field of the device property for the device. Industrial HiVision displays this name in the folder frame and in the detail display. Possible parameters are:
– DNS Name,
– Host Name,
– System Name,
– Location, and
– Contact.
By selecting it and clicking on the arrow buttons, you move the potential names between the "Possible Parameters" and "Used Parameters" frames. Industrial HiVision takes the name at the top in the "Used Parameters" frame. If the relevant entry is empty for a device, Industrial HiVision takes the name in the next position. If Industrial HiVision does not find an entry for the device, then Industrial HiVision takes the management IP address of the device.

"Port Name"
"Set Port Name" allows you to take the port name entered in the device into the name field of the port properties, as long as port names are entered in the device. Industrial HiVision displays these names in the folder frame and in the detail display. If there is no setting here, Industrial HiVision displays the IP address for devices and the port number for ports.

**Note:** When it detects a device/port, Industrial HiVision takes the name selection that is set. If you subsequently change this selection, it becomes effective after you have reset the device/port name. To do this, you select the relevant devices and right-click "Set Device and Port Names".
Advanced: Load/Save

This dialog allows you to enter the following parameters:
– Enter the IP address of a tftp server available in the network
– File name with path
– URLs.

Industrial HiVision automatically takes this over into the dialogs in which you perform file transfer actions, e.g. loading/saving configurations in the MultiConfig™ dialog.

This spares you having to enter the URL and the file name multiple times when you call up the “MultiConfig™” dialog.

<table>
<thead>
<tr>
<th>Placeholder</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>$INSTALL</td>
<td>Installation folder of Industrial HiVision on the network management station.</td>
</tr>
<tr>
<td>$TFTP_SERVER</td>
<td>IP address of the tftp server that you entered in the Configuration &gt; Preferences &gt; Advanced &gt; Load/Save dialog.</td>
</tr>
</tbody>
</table>

Table 40: Placeholders supported
This dialog allows you to use Industrial HiVision to manage and monitor devices behind a 1:1 NAT router.

**Advanced: 1:1 NAT devices**

This dialog allows you to use Industrial HiVision to manage and monitor devices behind a 1:1 NAT router.

---

### Table 40: Placeholders supported

<table>
<thead>
<tr>
<th>Placeholder</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>$IP_ADDRESS</td>
<td>IP address of the device from which Industrial HiVision reads the configuration, or onto which Industrial HiVision writes the configuration. Industrial HiVision applies the IP addresses from the table of the Object frame.</td>
</tr>
<tr>
<td>$CURRENT_DATE</td>
<td>Current date of the network management station.</td>
</tr>
<tr>
<td>$CURRENT_TIME</td>
<td>Current time of the network management station.</td>
</tr>
<tr>
<td>$EXTENSION</td>
<td>File name extension:</td>
</tr>
<tr>
<td></td>
<td>- <code>cfg</code> for binary file</td>
</tr>
<tr>
<td></td>
<td>- <code>cli</code> for script file</td>
</tr>
<tr>
<td></td>
<td>- <code>html</code> for HTML file</td>
</tr>
</tbody>
</table>

---

Figure 73: Configuration:Preferences:Advanced:Load/Save
For Industrial HiVision to be able to detect the devices behind the 1:1 NAT routers, you enter the MAC addresses of the ports (of the 1:1 NAT routers) that are connected to the network management station in this list. You will find the port MAC address in the properties dialog of the 1:1 NAT router, on the "MAC/IP Addresses" tab.

![Image: Configuration:Settings:Advanced:1:1 NAT devices]

**Advanced:Mobile Devices**

When you send a HiMobile request to Industrial HiVision for the first time, Industrial HiVision registers your mobile device - see Configuration > Preferences > Advanced > Mobile Devices. In the "Push Notification" column, you activate/deactivate the sending of push notifications to the registered device. Default setting: active

To delete a registered device, you select the row in the table and click "Delete".

Industrial HiVision sends push notifications to the devices with an active entry in this table. To send push notifications, Industrial HiVision requires Internet access.
After a restart or an update of Industrial HiVision, if the entry for your mobile device is missing from the list, close HiMobile on your mobile device. To register the mobile device at Industrial HiVision, start HiMobile. In the event actions, you define when Industrial HiVision sends which push notifications.

(see on page 266 “Basics: Event Actions”)
8.4.6 Status configuration

With this dialog you can perform the status configuration of a component detail device overlapping for the devices in a device class, or for the entire devices.

The dialog shows a table of the device classes and their possible properties.

- Select "Combine Entries" to aggregate the properties of all device classes, or deselect "Combine Entries" to display the property per device class in the table.

- Double-click on a row in the table.

Industrial HiVision opens the corresponding status configuration dialog.

- Assign the desired status to the values and click "OK".

- Select "Overwrite all Properties" to also change the properties of those devices that you configured individually before.

Industrial HiVision accepts this status configuration for the devices in this class.

This function is useful, for example, if you require the highest availability within a HIPER Ring. Then the default setting "Warning" is too low for a loss of redundancy functionality. In the status configuration dialog, you can use a single step to set the status for "No redundancy" to "Error" for the devices in a class.
Figure 75: Status configuration
* Double-click on a row
8.4.7 Scan Ranges

This dialog allows you to enter the scan range for a selected folder.

- After selecting a folder in the folder frame, or when the detail display is active, you select Configuration > Scan Ranges or right-click on Scan Ranges in the selection menu.

- To enter an IP address range, click "New". Entering the IP address range consists of
  - the first IP address of the query range
  - the last IP address of the query range
  - the related network mask
  - the activation/deactivation of this range for the query and
  - the name you want to give to the range.

Industrial HiVision has already entered the selected folder or the active detail display as the target folder.

The table shows the IP address ranges already created.

- Select a row in the table and click on "Edit" to edit this IP address range.

- Select a row in the table and click "Delete" to delete this row from the table.

- Select a row in the table and click on "Duplicate" to duplicate this IP address range so that you can then modify the copy.
**Figure 76: Scan ranges for a folder**

**Note:** Keep in mind that the network masks in this dialog correspond with the network masks within your network, so that the detection executes properly. If the network mask within your network is bigger than the network mask of a scan range, Industrial HiVision skips the highest IP address within the network mask of the scan range during the scan network, because this IP address is a broadcast address.

If the network mask within your network is smaller than the network mask of a scan range, Industrial HiVision scans the highest IP address within the network mask of the network. Because this IP address is a broadcast address, all the devices reply and Industrial HiVision recognizes a device that does not exist.
8.4.8 User defined properties

This dialog allows you to enhance and monitor the properties of any SNMP-capable devices in Industrial HiVision (see on page 173 “Description of user-defined properties”).

- In the menu bar, choose Configuration > User defined Properties to open the "User defined Properties" dialog.

You can edit, delete or duplicate a selected user-defined property. When you select a user-defined property, "Delete" remains grayed-out if this property is assigned to a higher-level property.

Creating a new user-defined property
You will find an application example in the chapter “Setting up the network monitoring” (see on page 173 “Application example for user-defined properties”).

<table>
<thead>
<tr>
<th>Name</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>A freely-selectable, unique name for this property starting with &quot;UserDef_ &quot;, e.g. “UserDef_ICMP-Message”.</td>
</tr>
<tr>
<td>Identifier</td>
<td>A freely-selectable name that Industrial HiVision uses for the display in the user interface.</td>
</tr>
<tr>
<td>Symbol</td>
<td>A pixel file is selected that Industrial HiVision displays as a symbol for the property in the user interface.</td>
</tr>
<tr>
<td>Higher-level property</td>
<td>The higher-level property of the new property, e.g. the property “Speed” belongs to the higher-level property “Port”.</td>
</tr>
<tr>
<td>MIB variable/OID</td>
<td>MIB variable/OID (object identification) that you can select by clicking on the three dots in the MIB browser.</td>
</tr>
<tr>
<td>Instance</td>
<td>Assignment of the MIB variants to a device detail, e.g. “0” for the time. Alternatively, Industrial HiVision determines the type itself, e.g. “ModuleNumber”.</td>
</tr>
<tr>
<td>Type</td>
<td>Industrial HiVision selects the type (e.g. MAC address, integer) automatically if Industrial HiVision can determine the type.</td>
</tr>
<tr>
<td>Mapping</td>
<td>Assignment of a numerical value to a meaning, e.g. “0 = false” or “1 = true”. Industrial HiVision determines this value from the MIB.</td>
</tr>
<tr>
<td>Factor</td>
<td>Factor for converting a unit, e.g. Celsius to Fahrenheit.</td>
</tr>
<tr>
<td>Offset</td>
<td>Offset for converting a unit, e.g. Celsius to Fahrenheit.</td>
</tr>
</tbody>
</table>

Table 41: “New Entry” dialog for a user-defined property.
8.4.9 Multi-configuration

The multi-configuration function (MultiConfig™) allows you to perform configurations on the device and in Industrial HiVision for:

- one or more devices
- one or more device properties, also device overlapping
- one or more device details, also device overlapping

You will find more information with application examples in chapter “Configuring the network”.
8.4.10 MAC/IP List

MAC/IP Addresses
This dialog shows you a list of the IP addresses detected by Industrial HiVision and their related MAC addresses. The list contains:

<table>
<thead>
<tr>
<th>Designation</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>MAC address</td>
<td></td>
</tr>
<tr>
<td>IP address</td>
<td></td>
</tr>
<tr>
<td>Network mask</td>
<td></td>
</tr>
<tr>
<td>Host name</td>
<td>Host name from the /config/hosts.txt file in the installation directory if</td>
</tr>
<tr>
<td></td>
<td>– the file exists,</td>
</tr>
<tr>
<td></td>
<td>– there is an entry and</td>
</tr>
<tr>
<td></td>
<td>– the determination of a device name is activated in the basic settings.</td>
</tr>
<tr>
<td></td>
<td>Otherwise, the field remains empty.</td>
</tr>
<tr>
<td>DNS Name</td>
<td>Name from the Domain Name Service</td>
</tr>
<tr>
<td>Port number</td>
<td>Port number of the protocol.</td>
</tr>
<tr>
<td>Port</td>
<td>Device port</td>
</tr>
<tr>
<td>Management</td>
<td>Industrial HiVision communicates with the management of the device by</td>
</tr>
<tr>
<td></td>
<td>means of the IP address in this row.</td>
</tr>
<tr>
<td>User Generated</td>
<td>The device in this row was generated by the user. Industrial HiVision has</td>
</tr>
<tr>
<td></td>
<td>not detected this device yet.</td>
</tr>
<tr>
<td>Router Entry</td>
<td>The IP address in this row comes from the routing table of the device.</td>
</tr>
</tbody>
</table>

With "Export" you can save the complete list as:

- PDF file
- HTML file
- CSV file (see on page 366 “CSV export”)

With "Print" you can print the complete list. Industrial HiVision creates a temporary PDF file of the content of the list and opens this PDF file in the PDF display program, e.g. Acrobat Reader, that is installed on your management station.

MAC/IP Address Pair Security
This dialog lets you monitor the assignment of MAC addresses to IP addresses and allows you to detect IP address duplicates.
Industrial HiVision is familiar with three types of table entries.

- Existent
  This entry comes from an existing and discovered device in the network. If you remove this device from the topology, then Industrial HiVision removes this device from the list. Industrial HiVision includes this entry in the event examination.

- User Generated
  A user created or edited this entry at this point. This entry stays in the list until the user manually deletes it from the list. Industrial HiVision includes this entry in the event examination.

- Excluded
  A user created or edited this entry at this point. This entry stays in the list until the users manually delete it from the list. Industrial HiVision excludes this entry from the event examination.

The selection under "Display" allows you to filter the table contents according to type.

- Activate "Configure Schedule for Checking" to enable monitoring. As soon as you leave the dialog with "OK", Industrial HiVision opens the "Scheduler" dialog. This is where you specify the monitoring criteria.
  See “Scheduler” on page 252.

### 8.4.11 Refresh

"Refresh" enables you to have Industrial HiVision read values from properties of a previously selected device, folder or property itself. After Industrial HiVision has read in the values, Industrial HiVision refreshes the display.

- In Edit mode, when a device or folder within a device is updated Industrial HiVision reads in the existing properties within and below the respective device or folder.
  Thus, for example, you can make a module visible in Industrial HiVision after adding the module to the hardware.

- In Run mode, when a device or folder within a device is updated Industrial HiVision reads in exclusively the existing properties within the respective device or folder.
When updating a property, Industrial HiVision reads in the values of the property.

### 8.4.12 IP Configuration

This dialog enables you to configure the IP parameters of a device detected by HiDiscovery without an IP address, or to change IP parameters already configured.

You open the dialog for the IP configuration by right-clicking on the device and selecting IP configuration.

When you open the dialog, Industrial HiVision queries the device using the HiDiscovery protocol. If the query is successful, Industrial HiVision shows the parameters of the device and the “Signal” button. If the device does not respond to the HiDiscovery query, then Industrial HiVision queries the device via SNMP. If the SNMP query is successful, Industrial HiVision shows the parameters of the device.

- You click on “Signal” to switch on the flashing LEDs on the device for the identification of the device. Click on “Signal” again to switch the flashing off again.
- Prerequisites for this function:
  - The device has activated HiDiscovery
  - You have chosen the network interface card for this network in the Configuration > Preferences > Advanced > Management Station dialog under “Default Network Interface Card (HiDiscovery):”.
- In the “Name” row, you can enter a name for the device.
- In the “IP address” row, you can assign a new IP address to the device.
- In the “Network Mask” row, you can assign a new network mask to the device.
- In the “Gateway” row, you can assign a new gateway IP address to the device.
- If you click once on “Default Values”, Industrial HiVision enters the default values from “Advanced:Management Station” on page 298 in the IP configuration rows.
If you click on "OK", Industrial HiVision transfers the name and the IP configuration to the device.

Click on "Cancel" to close the dialog and keep the original entries.

Figure 77: IP configuration of a device
8.4.13 Trap destination

To open the dialog for the trap destination, you right-click on the device and select "Trap Destination".

When the dialog is opened, Industrial HiVision queries the trap settings of the device and displays whether the device sends traps to the IP address displayed.

- Select “Send Traps” if you want the device to send traps when defined events occur.
- In “to IP Address” you select the IP address of your network management station, on which you are operating Industrial HiVision.
- If you want this trap configuration to be saved on the device into the permanent memory select “Save Config on Device”.

![Figure 78: Trap destination of a device](Image)

**Note:** If your Windows firewall is activated and no Windows Trap Service is installed, the firewall can block you from receiving traps. However, if you still want to receive traps, you add the /services/HiVisionKernelDb.exe file in the Industrial HiVision installation directory to the firewall settings as an executable file. The Windows Trap Service is installed if you find "SNMP Trap Connection: Trap Service" under Help > Kernel Info in Industrial HiVision.
8.5 Tools

In the “Tools” menu you will find various tools enabling you to access devices in your network using Ping, graphical user interface, CLI, SNMP browser or the HiDiscovery Scan.

8.5.1 Dashboard

The Industrial HiVision "Dashboard" is a valuable fault-finding tool which allows an administrator to view the network statistics and useful information about the performance of the network in real time.

Industrial HiVision allows you to create multiple dashboards with various information, then preview the dashboards as a slide show. The function also allows you to save and load the dashboard layouts.

The main window contains a time slider. The time slider allows you to adjust how long the slide show displays each page.

When you close the Industrial HiVision application, the application saves the size and position of the dashboard. The application also saves other active dashboard options such as the full screen mode, timer slider status, and the play or pause status.
Note: If the dashboard does not display the "New", "Delete", and "Save" buttons, then click the "Edit Mode" button in the Industrial HiVision dialog.

Dashboard: Widget Display and Configuration

Industrial HiVision allows you to customize the dashboards to suite your requirements. Using the drag and drop function you can specify the type and position of the widgets that a dashboard displays. You can also specify the number of rows and columns of cells for each dashboard.

The background color of the widget represents the worst state displayed in the widget. The background colors indicate the same statuses as in the Graphical User Interface (GUI) of Industrial HiVision. The user can specify the background colors (see “Display:Status Colors” on page 287).

Dashboard: Widget Size

The dashboard allows you to increase or decrease the size of widgets.
To increase the size of a widget, verify that you have cells free on the right or below the widget that you wish to enlarge. If there are no free cells available, then add the required number of cells using the "Grid" buttons.

Highlight the widget you wish to enlarge, then using the "Widget Size" plus "+" button increases the size of the widget. The size of the widget increases one cell each time you click the plus "+" button.

Dashboard: Properties Button

Some widgets allow you to configure which parameters to monitor. To specify which parameters the widget monitors click the "Properties" button, then enter the values in the "Parameters" dialog. The widgets also allow you to drag parameters from various tabs in the GUI or the folder frame and drop them into the widget.

The following widgets allow you to specify parameters to monitor:
- Connection Status
- Moving Avg Ping Response Time
- Numeric Property
- Top 10 Moving Avg Response Time (no drag and drop)

Dashboard: Viewing Modes

Industrial HiVision allows you to view a slide show of the dashboard pages using the following methods.
- When you click the “Full Screen” button , the dashboard changes to the full screen mode and the slide show is in the “Pause” mode.
- You can also open the slide show using the “Play” button . If you open the slide show using the “Play” button, then the dashboard changes to the full screen mode and the slide show begins to display the pages of the current user.

In the “Full Screen” mode the dashboard also has a tool bar containing the following control functions.
- To stop the slide show at the current page, click the “Pause” button .
- To restart the slide show, click the “Play” button .
- If you wish to open a specific page, then you can select the page from the pull down list.
Note: To display the tool bar, move the mouse to the top of the screen.

To exit the full screen mode, click the “Restore” button or press the “Esc” button on the keyboard.

Dashboard: Renaming

The dashboard function allows you to change the name of existing pages.

To change the name of an existing page, use the following work steps:
- Click the "Rename" button.
- Enter the new name in the "Dashboard Name" field.
- Click the "OK" button.

Device Summary Widget

The widget displays a summary of the devices contained in the entire project. The summary displays devices according to the state of the device. The widget only displays the state of managed and licensed devices.

Industrial HiVision includes the device and copies of devices in the summary. When you add a copy of a device to Industrial HiVision, the Device Summary widget counts the device twice. The reason that the widget counts the device twice is because the status of the copy can differ from the original. The Device Summary widget excludes links from the count.

The widget displays the state of the device regardless of whether the state of the device is confirmed or not (see “Acknowledge events” on page 82).

After each name in every field is an arrow. The arrow displays the trend of the field since the last update. For example: the “Warning” field in the previous scan displayed 3, the current scan returns 2. The field displays a down arrow in this case.
Connection Summary Widget

The widget displays a summary of the connections contained in the entire project. The summary displays connections according to the state of the connection.

The widget displays the state of the connections regardless of whether the state is confirmed or not (see "Acknowledge events" on page 82).

After each name in every field is an arrow. The arrow displays the trend of the field since the last update. For example, the “Warning” field in the previous scan displayed 3, the current scan returns 2. In this case, the field displays a down arrow.
Connection Status Widget

You can add multiple "Connection Status" widgets to the dashboard. The "Connection Status" widget displays the link state and load of selectable connections as graphs. The graphs display the load values and link state in separate diagrams. The widget frame displays the color of the current connection status. The widget retrieves the connection status from the Industrial HiVision database. If Industrial HiVision detects an error on the connection for any reason, then the widget frame displays the color specified for a detected error.

Figure 80: "Connection Status" widget with "Top to bottom" function activated.
When you create a new widget, the widget is in the unconfigured state. For example, you have not yet associated the widget with a connection from a project. In this state the widget displays empty diagrams.

To configure the widget, use the following steps:

- Drag and drop the widget to a cell in the dashboard.
- To open the "Widget Parameters" dialog, click the "Properties" button on the right side of the dashboard.
- Enter the desired history duration, in the "History Size" field. The "History Size" range is from 1 min to 2 h. Default value is 30 min.
- Using the pull-down list, select the unit of measure.
- Assign a connection to the widget. In the "Connection" field highlight a connection, click the "OK" button.

**Note:** If you select an item that is not a connection, the widget displays "Widget Configuration Error".

The widget collects the "In Load" and "Out Load" data from the server and displays it on a history graph. The history graph slowly scrolls across the widget allowing you to read the information. The widget displays the graph until you close the widget or specify a different connection.

The "Widget Parameters" dialog also allows you to configure the visual aspects of the widget. To configure the widget to display the lower "Out Load" diagram directly underneath the upper "In Load" diagram, mark the "Top to bottom" checkbox. To change the load graph from a solid bar type to a stacked bar type, mark the "Stacked" checkbox. Each bar displays the status of the data set according to the diagram type for example, solid or stacked bars. The widget stores and displays the status configuration of each data set.

**Note:** The solid bar diagram draws the bar using the color that represents the status of the value at that time. The stacked bar diagram displays the parts of the bar that are below, between or above the thresholds in a different color. This makes it possible to display changes in the status configuration.

The widget uses the same thresholds configured in the graphical user interface. See "Properties of a connection" on page 233.
The widget attempts to determine the load in both directions using various means. The widget obtains the values from the database in the following order:

- In Load property values from both end ports of the connection. The legend displays the direction of the traffic.
- If one side does not provide an "In Load" property, then the widget uses the "Out Load" property of the opposite side. The legend displays the direction of the traffic.
- If only one side of the connection is a port, then the widget uses the "In Load" and "Out Load" of this port. The legend displays the name of the end point with either "In Load" or "Out Load" appended.
- If the direction of traffic cannot be determined, the diagram and the legend remains empty.

If you change the connection associated with a widget, then the widget reflects the changes immediately. If you delete the connection, then the widget displays "Widget Configuration Error".
Kernel Status Info Widget

The "Kernel Status Info" widget displays information about the Industrial HiVision kernel.

Additional information about the Industrial HiVision kernel is located in a following chapter, See “Kernel Info” on page 357.

The widget displays the following information:

- **Kernel uptime**
  The elapse time since Industrial HiVision was started.

- **Memory Usage**
  The percent of memory that the services are using. Industrial HiVision calculates the percent of memory as follows:
  \[
  \text{percent} = \frac{\text{actual memory used}}{\text{reserved memory}}
  \]

- **Polling Operations per Minute**
  The specified number of operations that the kernel can perform in a minute.

- **Polling Operations last Minute**
  The number of operations that the kernel was able to perform in the last minute.

- **Polling Operations dropped**
  The number of operations that the services dropped in the last minute.
  You can influence the number of polling operations dropped by changing the number of polling operations monitored or changing the polling interval.

**Note:** For further information about configuring the parameters that the kernel polls See “Monitor” on page 245.
### Project Status Info Widget

The widget allows you to display unacknowledged errors and warnings detected in your network. The Industrial HiVision kernel monitors the devices in your network for changes. The widget polls the kernel in 1 second intervals and displays the results on the page. If a status of a device in your network changes to warning or error, then the widget displays the status in your slide show. The arrows on the right of each field displays the trend of the field status.

The widget displays the following project parameters:

- **Number of Devices**
  The field displays the number of devices in your project. The field does not include deleted or unused devices.

- **Unmanaged Devices**
  The field displays the number of unmanaged devices in your project.

- **Unacknowledged Warnings**
  The field displays the number of unacknowledged warning events. If the widget displays an unacknowledged warning, then you can pause the slide show and investigate the cause.

- **Unacknowledged Errors**
  The field displays the number of unacknowledged error events. If the widget displays an unacknowledged error, then you can pause the slide show and investigate the cause.

For further information about unacknowledged events see “Event line” on page 79.

### Security Summary Widget

The “Security Summary” widget displays the security relevant parameters.
The "Vulnerable Devices" field displays the number of devices that are vulnerable to attack. Vulnerable devices have at least 1 function enabled that is recommended to be disabled, such as the http or SNMP v1/v2 protocols. The widget also counts devices which have the security functions disabled. The number displayed in the widget represents the number of devices in your project with a security status worse than OK.

The Industrial HiVision GUI "Security Status" tab identifies which devices the widget has included in the results and the security risks. To decrease the number of devices in the count and increase network security, disable/enable the functions identified in the "Security Status" tab. You can also use the MultiConfig "Security Lockdown" function.

The "Rogue Devices" field displays the number of devices in the rogue device map See "Detecting rogue devices" on page 161. When the number of rogue devices is more than 0, the widget displays the color that you specified as "Warning".

**Note:** The widget displays a warning triangle to the right of the "Rogue Devices" field. The triangle is to remind you to activate the function. The widget hides the triangle after you activate the "Rogue Device Detection" function.

The "Config. Signature Changes" field displays the number of devices with a configuration change. The field counts every change even when the changes were returned to the original value.

In order for the widget to display the properties, specify a reference value and configure status calculation as follows:

- Open the "Properties" tab in the Industrial HiVision Graphical User Interface (GUI).
- Open the "Property:" drop down list, select "Configuration Signature".
- Highlight the device or devices in the table without an active "Configuration Signature".
- The devices with an active "Configuration Signature" have a check mark in the "Status" column. You can filter the table to locate the devices that require activation. To filter the table, click on the "Status" column header until the table displays the entries at the top.
- Open the "Status Config" dialog using Configuration > MultiConfig™ > Status Config.
- Mark the "Set current to reference" checkbox.
- Mark the "Value is Reference Value" checkbox.
- Open the "Value is Reference Value" drop down list, select "OK".
Mark the "Other Value" checkbox.
Open the "Other Value" pull down list, select "Warning" or "Error".
To save the changes, click the "Write" button.

Note: The widget displays a warning triangle to the right of the "Config. Signature Changes" field. The triangle is to remind you to configure the function. The triangle is hidden after you configure the references for every device.

The status of the "Config. Signature Changes" field is either OK for the value zero or the worst status of the configured Configuration Signature properties.

The arrows indicate the trends of the individual fields.

Security Summary Widget

The "Security Summary" widget displays the security relevant parameters.

The "Vulnerable Devices" field displays the number of devices that are vulnerable to attack. Vulnerable devices have at least 1 function enabled that is recommended to be disabled, such as the http or SNMP v1/v2 protocols. The widget also counts devices which have the security functions disabled. The number displayed in the widget represents the number of devices in your project with a security status worse than OK.

The Industrial HiVision GUI "Security Status" tab identifies which devices the widget has included in the results and the security risks. To decrease the number of devices in the count and increase network security, disable/enable the functions identified in the "Security Status" tab. You can also use the MultiConfig "Security Lockdown" function.
The "Rogue Devices" field displays the number of devices in the rogue device map See “Detecting rogue devices” on page 161. When the number of rogue devices is more than 0, the widget displays the color that you specified as “Warning“.

**Note:** The widget displays a warning triangle to the right of the "Rogue Devices" field. The triangle is to remind you to activate the function. The widget hides the triangle after you activate the “Rogue Device Detection” function.

The "Config. Signature Changes" field displays the number of devices with a configuration change. The field counts every change even when the changes were returned to the original value.

In order for the widget to display the properties, specify a reference value and configure status calculation as follows:

- Open the "Properties" tab in the Industrial HiVision Graphical User Interface (GUI).
- Open the "Property:" drop down list, select "Configuration Signature".
- Highlight the device or devices in the table without an active "Configuration Signature".
  The devices with an active "Configuration Signature" have a check mark in the "Status" column. You can filter the table to locate the devices that require activation. To filter the table, click on the "Status" column header until the table displays the entries at the top.
- Open the "Status Config" dialog using Configuration > MultiConfig™ > Status Config.
- Mark the "Set current to reference" checkbox.
- Mark the "Value is Reference Value" checkbox.
- Open the “Value is Reference Value” drop down list, select “OK”.
- Mark the "Other Value" checkbox.
- Open the "Other Value" pull down list, select "Warning" or "Error".
- To save the changes, click the "Write" button.

**Note:** The widget displays a warning triangle to the right of the "Config. Signature Changes" field. The triangle is to remind you to configure the function. The triangle is hidden after you configure the references for every device.

The status of the "Config. Signature Changes" field is either OK for the value zero or the worst status of the configured Configuration Signature properties.
The arrows indicate the trends of the individual fields.

**Numeric Property Widget**

The "Numeric Property" Widget allows you to track the status of parameters containing numeric values. The widget allows you to track up to 10 numeric parameters.

The procedure for using the "Widget Parameters" dialog to enter the parameters that you want to monitor is described in the following steps:

- To open the "Widget Parameters" dialog, click the "Properties" button.
- Specify the length of time that you want to monitor the devices in the "History Size" field. (Default: 30)
- Specify the "History Size" units of measure for the length of time that you want to monitor the parameters. (Default: "Minutes")
- Select up to 10 parameters from the project tree.
- You can specify a different name for the widget in the "Title" field.
- Click "OK".
The following list contains some of the numerical parameters that the widget can monitor:

- **Ports:**
  - In Load
  - Out Load
  - Speed

- **Agent:**
  - Number of Users

- **Protocol:**
  - Moving Avg Response Time
  - Avg Response Time
  - Min Response Time
  - Max Response Time
  - Std. Deviation
  - Message Loss

**Note:** It is possible that 2 devices have the same value for a parameter for example, devices 10.0.1.10, 10.0.1.17 and 10.0.1.200 have a temperature of 38° and 39°. In this case, one trace covers the other. See the blue, yellow and orange traces in the "Numeric Property" figure below.

### Moving Avg Ping Response Time Widget

The "Moving Avg Ping Response Time" widget allows you to display the response time of a ping request for up to 10 devices. You can enter the devices using either drag and drop or the "Widget Parameters" dialog.
The procedure for using the "Widget Parameters" dialog to enter the devices that you want to monitor is described in the following steps:

- To open the "Widget Parameters" dialog, click the "Properties" button.
- Specify the length of time that you want to monitor the devices in the "History Size" field. (Default: 30)
- Specify the "History Size" units of measure for the length of time that you want to monitor the devices. (Default: "Minutes")
- Select up to 10 devices from the project tree.
- Click "OK".

The procedure for using the drag and drop method to enter the devices that you want to monitor is described in the following steps:

- Open the GUI Map tab.
- Highlight the device or devices you want to monitor.
- Drag and drop the highlighted devices in the "Moving Avg Ping Response Time" widget.

**Note:** Each time you select new devices to monitor, the widget replaces the current devices with the newly selected devices.

For further information about ICMP moving averages
See “Advanced: Service Parameters” on page 302.

---

**Top 10 Moving Avg Response Time Widget**

The widget displays the moving average response time of up to 10 devices. The devices with the higher moving average response time are displayed at the top of the chart.
To configure the widget, open the "Widget Parameters" dialog using the "Properties" button. The dialog allows you to specify which protocol the widget displays. You can select from the following protocols using the drop down list:

- Ping (default setting)
- SMNP V1
- SMNP V3

The widget displays a trend arrow next to the IP address of each device. The trend arrow indicates the movement in position of a device, with reference to the other devices displayed in the widget, since the last poll.

The information provided in the widget helps you to plan for optimal performance in your network. For example, the widget displays which device has a high average response time. A high average response time can cause a bottle neck in your network. If a device with a high response time is in the middle of your network, then the device can effect the other devices in your network. Replacing the slow device allows the data stream to be transmitted unhindered.

The following list contains some possible causes of high response times:

- Device is overwhelmed with data being sent to the CPU.
  - Receiving and forwarding data is the primary task of a network device.
  - Processing management requests are secondary tasks.
- The path to the device is slow.
  - Slow connection
  - Slow connection of neighbor
  - Old fiber or Ethernet cable

**Note:** When you configure the widget for the first time, there is a possibility that the widget displays high response times. In this case, allow the display to stabilize before taking action. If after 1 minute the average response time for a device remains high, then consider taking action.
8.5.2 Web interface

The “Web interface” tool enables you to open, from the Industrial HiVision interface, the Web-based interface of the device selected in the window in the web browser.
8.5.3 Device configuration

The “Device Configuration” tool enables you to open, from the Industrial HiVision the Web-based interface of the device selected in the window, as a Java application. Here, Industrial HiVision uses the login name and the password from the SNMP configuration settings (see on page 294 “Advanced: Device Credentials”). Thus, Industrial HiVision spares you having to login and you go directly to the start page of the device.

The following series of devices support this function:
- MACH 4000
- MACH 1000
- MACH 100
- GREYHOUND
- PowerMICE
- MS20/MS30
- MSP
- RS20/RS30/RS40
- RSP/RSPS/RSPL
- RSR20/RSR30
- RED
- EES20/EES25
- OCTOPUS
- EAGLE 20
- Magnum 12KX
- TCSESM
- TCSESM-E
- TCSG
- TCSN
- TCSEFEC
- ESM 801-TG
- ESM 802-TG
- ERT
- AFF650
- AFS650/655
- AFS66x
- AFS670/675
- AFS677
- AFR677
**Note:** Industrial HiVision allows you to use the graphical user interface of Hirschmann products with the "Device Configuration" function independent of other applications, such as a browser or an installed Java environment. Hirschmann has developed Industrial HiVision as an application that enables you to use the graphical user interface easily with the "Device Configuration" function in a closed network. When Industrial HiVision sets up a secure connection with HTTP or SSH, Industrial HiVision does not check the identity of the device with which Industrial HiVision is connecting. Additionally, Industrial HiVision does not display the identity of the device to the user. Someone attacking the network could take advantage of this omission of a check to access sensitive information.

**Recommended actions** Use Industrial HiVision in a closed network. Do not use the "Device Configuration" function and "MultiConfig™" dialogs that use https in an open network. Perform an update of Industrial HiVision as soon as a newer version is available.

### 8.5.4 CLI

The “CLI” tool allows you to create a connection to the selected device from the Industrial HiVision interface. Industrial HiVision opens its own window. Industrial HiVision automatically checks whether the device allows an SSH session or a Telnet session. Industrial HiVision preferably establishes an SSH session.

**Note:** Under Linux, the CLI tool requires that Telnet and SSH clients are installed and that the environment variable PATH contains the name of the directory in which the “xterm” program is installed.
8.5.5 SNMP browser

The “SNMP browser” tool enables you to read and write the MIB of a selected device. Industrial HiVision displays the MIB in a new window.

**Note:** The SNMP browser is a freely usable additional software. The SNMP browser is not subject to the system test.

8.5.6 Ping

The “Ping” tool enables you to send a Ping query to the devices selected in the window. Industrial HiVision opens a separate Ping window.

**Note:** Under Linux, the Ping tool requires that the environment variable PATH contains the name of the directory in which the “xterm” program is installed.

8.5.7 HiDiscovery Scan

HiDiscovery enables you to recognize the devices in the network that support the HiDiscovery protocol, as long as these devices have activated the HiDiscovery protocol. You select the HiDiscovery tool to start a search for new devices using the HiDiscovery protocol.
8.5.8  **Scan Network**

Scan Network enables you to detect all the devices within an IP address area of the network specified under “Basics: discover devices” on page 258. You select the Scan Network tool to start a search for new devices.
8.5.9 Demo network

The "Demo Network" program supplied allows you to simulate a network on your computer in order to familiarize yourself with Industrial HiVision without being connected to a network.

Select Tools > Demo Network network to start the simulation of the demo network.

In the state on delivery, the device discovery is activated by a trap, and Industrial HiVision detects the demo devices. Industrial HiVision displays the demo devices in the "New Devices" folder. Because the demo network functions without a network connection, the demo network is simulated via the local host interface with the IP address 127.0.0.1 and differentiates the devices through the port numbers: 127.0.0.1:9003, 127.0.0.1:9004, 127.0.0.1:9005. The simulation replicates the following management functions of the devices:

- Topology discovery based on LLDP
- Line interruptions
- Line interruption in the MRP
- Missing power unit
- Network load at device 9010
- Switch signal contact on/off
- Change device temperature
8.5.10 Calculate Availability

Due to their physical properties, each component in the network has a limited lifetime. The MTBF is the mean time between failures. Repairs of the components also take a certain amount of time. The MTTR is the mean time to repair.

Industrial HiVision calculates the availability of a path based on the MTBF and MTTR values of the affected transmission components along that path. Industrial HiVision also considers redundant paths here.

The type of a connected device affects the availability of the network. A redundantly connected switch/router has a bigger effect on the availability of the network than a redundantly connected terminal device.
If the calculated availability values do not fulfill your requirements, you can carry out the following measures, among others, to increase availability:

- Set up redundant path
- Reduce downtimes by, for example, keeping replacement devices at the ready

### Prerequisites for calculating availability

- For Windows operating systems:
  To calculate the availability, Industrial HiVision uses Microsoft .NET Framework version 2.0 or higher.
  This program is part of the default installation of the Windows operating systems named in the system requirements.
  This software is required for proper calculation of availability on your network management station.
- For Linux operating systems:
  Install MONO 2.0.
  Check whether these programs are installed on your network management station.
- Note for Debian 6.0 and Ubuntu 12.04 (LTS):
  Install libmono2.0-cil and libmono-winforms20-cil.

Before calculating the availability, Industrial HiVision executes the following checks:

- Are the MTBF/MTTR values of all connections greater than 0?
- Do all objects (devices, clouds) have the properties MTBF/MTTR and are their values greater than 0?

If Industrial HiVision finds objects with missing specifications, Industrial HiVision displays them in a window. As soon as you have entered the required information, you can start the calculation again.

### Availability classes as per AEC

<table>
<thead>
<tr>
<th>Availability class</th>
<th>Designation</th>
<th>Availability in %</th>
<th>Annual downtime</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 (AEC-0)</td>
<td>Conventional</td>
<td>99.0</td>
<td>3.7 days</td>
</tr>
<tr>
<td>2 (AEC-1)</td>
<td>Highly reliable</td>
<td>99.9</td>
<td>8.8 hours</td>
</tr>
<tr>
<td>3 (AEC-2)</td>
<td>High availability</td>
<td>99.99</td>
<td>52.2 minutes</td>
</tr>
<tr>
<td>4 (AEC-3)</td>
<td>Fault resilient</td>
<td>99.999</td>
<td>5.3 minutes</td>
</tr>
<tr>
<td>5 (AEC-4)</td>
<td>Fault tolerant</td>
<td>99.9999</td>
<td>32 seconds</td>
</tr>
<tr>
<td>6 (AEC-5)</td>
<td>Disaster tolerant</td>
<td>99.999997</td>
<td>3 seconds</td>
</tr>
</tbody>
</table>

*Table 42: Availability classes as per AEC*
If you want to start the calculation even without the missing information, click “Use default values.” In this case, Industrial HiVision applies the default values wherever entries are missing.

### Prepare calculation of availability

The following example describes how to prepare the calculation of the availability of a connection between 2 devices. You will find the currently available MTBF values of the Hirschmann devices in the installation path of Industrial HiVision under: /data/doc/MTBF-Products.PDF.

- Select the device level in the topology view.
- Enter the MTBF/MTTR values of the connections.
  - Right-click on the connection and select "Properties...".
  - In the Properties dialog, select the "Properties" tab.
  - Under "Availability", enter the MTBF/MTTR values.
  - Click "OK"

- Add the user-defined properties “MTBF”, “MTTR” and “Node type” to the device properties of the one device.
  - Double-click on one of the two devices to go one level deeper in the detail view.
  - To add the user-defined properties “MTBF” and “MTTR”, right-click an empty space in the detail view. Select New > Property.
  - In the "New Property" dialog hold down the “Ctrl” button and click “MTBF” and “MTTR”.
  - Click "OK"
  - To enter the MTBF value, open the properties dialog by double-clicking the property “MTBF”.
  - Enter the value in the “Current Value” line and click "Write".
  - Click "OK"
  - Enter the value for MTTR in the same way.

- Add the device properties of the other device accordingly.

If one of the two devices is a redundantly connected terminal device, then assign it the property “Node type” with the value “Terminal device” in the same way (see above, MTBF and MTTR).
As an alternative to individual device configuration, Industrial HiVision provides the option of multi-configuration, which has the advantage that both devices can be configured with the MTBF/MTTR properties in one operation:

☐ Select the device level in the topology view.

☐ Enter the MTBF/MTTR values of the connections.
   - Click on the connection with the right mouse button and select "MultiConfig™".
   - In the MultiConfig™ dialog, select "Container Properties" in the menu tree.
     You will then find the table with the related connections in the object frame, and the table for the properties in the function frame.
   - Under “Availability”, enter the MTBF/MTTR values.
   - Click "Write".

☐ Add the user-defined properties “MTBF” and “MTTR” to the device properties of the devices.
   - To select both devices, hold down the “Ctrl” button and click on the two devices at the ends of the connection.
   - To open the MultiConfig™ dialog, right-click on a selected device and choose “MultiConfig™”.
   - In the MultiConfig™ dialog, choose Program Settings > New Property in the menu tree.
     You will then find the table with the related devices in the object frame, and the table for the properties in the function frame.
   - To create a new entry for the MTBF value in the table, click "New".
   - Select the property “MTBF” and click "OK".
   - To create a new entry for the MTTR value in the table, click "New".
   - Select the property “MTTR” and click "OK".
   - Click "Write".

☐ To open the dialog for entering the MTBF values, select the “All Properties” tab in the detail display.
   - In the “Property” input field, select the property “MTBF (Device)”.
   - Select the relevant devices.
   - To open the MultiConfig™ dialog, right-click on a selected device and choose „MultiConfig™“.
   - To enter the MTBF value, click on “Property Value” in the menu tree in the MultiConfig™ dialog.
- In the “Value” input field, enter the MTBF value.
- Click "Write".

□ To open the dialog for entering the MTTR values, select the “All Properties” tab in the detail display.
- In the “Property” input field, select the property “MTTR (Device)”.
- Select the relevant devices.
- To open the MultiConfig™ dialog, right-click on a selected device and choose “MultiConfig™”.
- To enter the MTTR value, click on “Property Value” in the menu tree in the MultiConfig™ dialog.
- In the “Value” input field, enter the MTTR value.
- Click "Write".
### Calculating availability

The following example describes how you can calculate the availability after the preparations made beforehand.

- Select the device level in the topology view.
- To select the connections of the two devices, hold down the “Ctrl” button and click on the two devices at the ends of the connection.
- To open the dialog for calculating availability, select **Tools > Calculate Availability** in the menu bar.
  - If an MTBF/MTTR property is missing for some objects, then Industrial HiVision opens the availability dialog with a table of the devices for which these properties are missing. This table also contains devices for which these properties have the value 0. Check whether the objects, e.g. devices, connections, for which you want to calculate the availability are missing. If such objects are missing, you can start the calculation of the availability by clicking on “Use Default Values.” Industrial HiVision then uses any MTBF/MTTR values entered for the calculation, and otherwise the default MTBF/MTTR standard values.

**MTBF** = 30000 h for devices, 100000 h for connections  
**MTTR** = 24 h for devices and connections  
The actual values for the devices/connections differ from these standard values.
Using standard values allows you, for example, to calculate the difference in the availability of two alternative routes.

- If the objects in the view have MTBF/MTTR properties, Industrial HiVision performs the calculation and displays the result in a dialog. In the "Detail frame" of the dialog, Industrial HiVision displays the paths that Industrial HiVision included in the calculation. During the calculation, Industrial HiVision writes details of the availability calculation in a log file. You will find this log file in the directory `<Installation path>/log/availability`. The name of the log file is made up of the name of the loaded project file and a time stamp.

**Note:** Availability calculation  
Industrial HiVision performs the availability calculation under the assumption that the devices in the network are transmitting between all their ports. Therefore, redundantly connected terminal devices, routing, and VLANs can corrupt the results. Remedy for redundantly connected devices: Create the "Node Type" property in the device and set its value to "Device".
**Note:** Parallel connections
Industrial HiVision combines parallel connections between two devices into one path to optimize the calculation. The paths appear as a single path in the list of paths in the dialog and in the log file.
8.6 Help

In the help menu you will find the online help and the version information for this program.

8.6.1 Online help F1

You can access the online help using the "F1" button on your keyboard or by calling the menu Help > Online Help. The online help contains the entire contents of the manual, with a table of contents, contents register, search function, and navigation help. In the individual dialogs, you click "Help" to go directly to the page of the manual that relates to the dialog.

8.6.2 Readme

You open the Readme file with Help > Readme. It contains information for installing Industrial HiVision.
8.6.3  Release notes

You open the release notes file with Help > Release Notes. It contains information on this installed version of Industrial HiVision.

8.6.4  Tutorial

With Help > Tutorial you open an exercise with guidelines for your first familiarization with Industrial HiVision in the browser. This exercise takes you through the important and latest functions of Industrial HiVision.

8.6.5  Online

You will find further information under Help > Online. You can select:

- Hirschmann to open the Hirschmann website.
- Hirschmann Competence Center to open the Hirschmann Competence Center website.
8.6 Help

8.6.6 Kernel Info

Under Help > Kernel Info, you will find the information that a service technician requires for a service task.

The kernel is the core of the Industrial HiVision application. The purpose of the kernel is to collect information from the network devices and the user interface. The kernel saves the information in a database. The user interface sends a request to the kernel, such as the device status. The kernel retrieves the information from the database and answers the request.
8.6.7 About

- **Program information**
  You will find information on the program version and the publisher under Help > About > Program Info.
- **EULA**
  You will find information on license agreements under
  Help > About > EULA

- **License**
  You will find information on program licenses under
  Help > About > License
Appendix

A Appendix
A.1 FAQ

Answers to frequently asked questions can be found at the Hirschmann HiVision Website:

www.hivision.de
A.2 System requirements

(see on page 20 “System Requirements”)

## A.3 Monitored properties

### A.3.1 Monitored properties in the basic setting

Properties that Industrial HiVision monitors using traps or polling in the basic setting you will find in the following table.

Industrial HiVision lists all traps in the event list.

**Note:** Keep in mind how this affects your system resources (see on page 176 “Effect on system resources”).

<table>
<thead>
<tr>
<th>Property</th>
<th>Trap</th>
<th>Polling</th>
<th>Polling interval</th>
</tr>
</thead>
<tbody>
<tr>
<td>AutoConfiguration Adapter status</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fan Status</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Power Supply Status</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Relay Status</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Port Link</td>
<td>x</td>
<td>*</td>
<td>30 seconds</td>
</tr>
<tr>
<td>Port In Load</td>
<td></td>
<td>*</td>
<td>30 seconds</td>
</tr>
<tr>
<td>Port Out Load</td>
<td></td>
<td>*</td>
<td>30 seconds</td>
</tr>
<tr>
<td>Port Admin</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Port Oper Status</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>WLAN Station</td>
<td>x</td>
<td>**</td>
<td>30 seconds</td>
</tr>
<tr>
<td>WLAN access points</td>
<td>x</td>
<td>**</td>
<td>30 seconds</td>
</tr>
<tr>
<td>Signal to Noise Ratio</td>
<td>x**</td>
<td></td>
<td>30 seconds</td>
</tr>
</tbody>
</table>

* In the default setting, polling is enabled for ports that have a cable connection in Industrial HiVision.
** In the default setting, polling is enabled for ports that have a wireless connection in Industrial HiVision.
*** The higher protocol supported by the device
### Table 43: Monitored properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Trap</th>
<th>Polling</th>
<th>Polling interval</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spanning Tree Status</td>
<td>x</td>
<td>*</td>
<td>30 seconds</td>
</tr>
<tr>
<td>Rapid Spanning Tree Status</td>
<td>x</td>
<td>*</td>
<td>30 seconds</td>
</tr>
<tr>
<td>Multiple Spanning Tree Status</td>
<td>x</td>
<td>*</td>
<td>30 seconds</td>
</tr>
<tr>
<td>Protocol Ping Reachability</td>
<td>x</td>
<td></td>
<td>30 seconds</td>
</tr>
<tr>
<td>Protocol SNMPv1 Reachability</td>
<td>x***</td>
<td></td>
<td>2 hours</td>
</tr>
<tr>
<td>Protocol SNMPv3 Reachability</td>
<td>x***</td>
<td></td>
<td>2 hours</td>
</tr>
<tr>
<td>HIPER Ring Status</td>
<td>x</td>
<td>*</td>
<td>30 seconds</td>
</tr>
<tr>
<td>HIPER Ring Coupling Status</td>
<td>x</td>
<td>*</td>
<td>30 seconds</td>
</tr>
<tr>
<td>Dual Homing Status</td>
<td>x</td>
<td>*</td>
<td>30 seconds</td>
</tr>
<tr>
<td>Ring Coupling Enabled</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ring Manager Enabled</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Dual Homing Enabled</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Router Redundancy Mode</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Router Redundancy Status</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Temperature</td>
<td>x</td>
<td>x</td>
<td>5 minutes</td>
</tr>
<tr>
<td>Configuration Status</td>
<td>x</td>
<td>x</td>
<td>5 minutes</td>
</tr>
<tr>
<td>Configuration Signature</td>
<td>x</td>
<td></td>
<td>1 hour</td>
</tr>
<tr>
<td>Configuration File</td>
<td>x</td>
<td>x</td>
<td>24 hours</td>
</tr>
<tr>
<td>Http</td>
<td>x</td>
<td></td>
<td>24 hours</td>
</tr>
<tr>
<td>Telnet</td>
<td>x</td>
<td></td>
<td>24 hours</td>
</tr>
<tr>
<td>SNMP V1/V2</td>
<td>x</td>
<td></td>
<td>24 hours</td>
</tr>
<tr>
<td>Tftp</td>
<td>x</td>
<td></td>
<td>24 hours</td>
</tr>
<tr>
<td>IEC61850</td>
<td>x</td>
<td></td>
<td>24 hours</td>
</tr>
<tr>
<td>Profinet IO</td>
<td>x</td>
<td></td>
<td>24 hours</td>
</tr>
<tr>
<td>EtherNet/IP</td>
<td>x</td>
<td></td>
<td>24 hours</td>
</tr>
<tr>
<td>Unused Active Ports</td>
<td>x</td>
<td></td>
<td>24 hours</td>
</tr>
<tr>
<td>802.1X Port Access Control Enabled</td>
<td>x</td>
<td></td>
<td>24 hours</td>
</tr>
<tr>
<td>ANY Rule Status</td>
<td>x</td>
<td></td>
<td>24 hours</td>
</tr>
</tbody>
</table>

* In the default setting, polling is enabled for ports that have a cable connection in Industrial HiVision.

** In the default setting, polling is enabled for ports that have a wireless connection in Industrial HiVision.

*** The higher protocol supported by the device.
A.4 CSV export

If you are working with CSV files across different languages, you require the corresponding character sets. Industrial HiVision uses the following codes when exporting data to a CSV file:

<table>
<thead>
<tr>
<th>Language</th>
<th>Character set</th>
</tr>
</thead>
<tbody>
<tr>
<td>German, English, French,</td>
<td>Latin-8859-1</td>
</tr>
<tr>
<td>Spanish, Italian, Portuguese,</td>
<td></td>
</tr>
<tr>
<td>Indonesian</td>
<td></td>
</tr>
<tr>
<td>Greek</td>
<td>Windows-1253</td>
</tr>
<tr>
<td>Korean</td>
<td>Johab</td>
</tr>
<tr>
<td>Japanese</td>
<td>Shift-JIS</td>
</tr>
<tr>
<td>Chinese</td>
<td>GB2312</td>
</tr>
<tr>
<td>Russian</td>
<td>Cyrillic-8859-5</td>
</tr>
</tbody>
</table>

Table 44: Character sets for CSV export

A.4.1 Microsoft Excel before 2010

To import to Microsoft Excel, you choose:

- In Excel, choose the menu item
  
  Data: Import External Data: Import Data

- Select the file and click “Open”.

- In the Text Conversion Assistant - Step 1, choose “Separate” for the original data type.

- In the Text Conversion Assistant - Step 1, choose “Separate” for the original data type.

- In the Text Conversion Assistant - Step 2, choose “Tab stop” and “Semicolon” as the separators.
A.4.2 Microsoft Excel 2010

To import to Microsoft Excel, you choose:

☑ In Excel, select the Data:From Text menu item.
☑ Select the file and click “Import”.
☑ In the Text Conversion Assistant - Step 1, choose “Separate” for the original data type.
☑ In the Text Conversion Assistant - Step 2, choose “Tab stop” and “Semicolon” as the separators.
☑ In the Text Conversion Assistant - Step 3, choose the “Standard” column for the data format.
☑ Click “Finish”.

## A.5 Language support

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>German</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>English</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Spanish</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>French</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Italian</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Russian</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Chinese</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Korean</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Japanese</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Greek</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Portuguese</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Indonesian</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Table 45: Language support*
A.6 Ports used

To communicate between the user interface and the services Industrial HiVision uses specific protocol ports in your network. The following table contains the ports and their usages.

When a firewall separates your Industrial HiVision services from a client, add a rule to the firewall to forward data between the services and client. See "Using Industrial HiVision with Firewalls" on page 61.

<table>
<thead>
<tr>
<th>Ports used</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>11163</td>
<td>CORBA Naming Service</td>
</tr>
<tr>
<td>11164</td>
<td>Traps from demo agent to the Industrial HiVision service</td>
</tr>
<tr>
<td>11165</td>
<td>HTTP/HTTPS server</td>
</tr>
<tr>
<td>11166</td>
<td>Communication between the interface und service. Industrial HiVision also used this port for communication between service and subdomains.</td>
</tr>
<tr>
<td>11167</td>
<td>Communication with the OPC UA HTTP Server</td>
</tr>
<tr>
<td>11168</td>
<td>Communication with the OPC UA HTTPS Server</td>
</tr>
</tbody>
</table>

Table 46: Ports used
A.7 Maintenance

Hirschmann is continually working on improving and developing their software. Check regularly whether there is an updated version of the software that provides you with additional benefits. You find information and software downloads on the Hirschmann product pages on the Internet (www.hirschmann.com).
A.8 Literature references

- “Optische Übertragungstechnik in industrieller Praxis”
  Christoph Wrobel (ed.)
  Hüthig Buch Verlag Heidelberg
  ISBN 3-7785-2262-0

- Hirschmann Manual
  “Basics of Industrial ETHERNET and TCP/IP”
  280 710-834

- “TCP/IP Illustrated”, Vol. 1
  W.R. Stevens
  Addison Wesley 1994
  ISBN 0-201-63346-9

- Hirschmann “Installation” user manual

- Hirschmann “Basic Configuration” user manual

- Hirschmann “Redundancy Configuration” user manual

- Hirschmann “Routing Configuration” user manual

- Hirschmann “GUI Graphical User Interface” reference manual

- Hirschmann “Command Line Interface” reference manual


- Hirschmann Manual “HiOPC Server Interface”
A.9 Copyright of Integrated Software

Industrial HiVision includes a number of open source components. The creators of these components have released these components under a variety of licenses. You will find these licences in the installation path of Industrial HiVision under \data\doc\thirdpartylicenses.txt
# Index

## B Index

<table>
<thead>
<tr>
<th>B</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>.NET 2.0</td>
<td>date 81</td>
</tr>
<tr>
<td>1:1 NAT router</td>
<td>Data Access V1 to V3 181</td>
</tr>
<tr>
<td>Absolute</td>
<td>Date format 278</td>
</tr>
<tr>
<td>Abstract</td>
<td>DCOM 181</td>
</tr>
<tr>
<td>Access point</td>
<td>Default device icons 60</td>
</tr>
<tr>
<td>Access Rights</td>
<td>Default icon 107, 288</td>
</tr>
<tr>
<td>Access station</td>
<td>Default Map 258</td>
</tr>
<tr>
<td>Action</td>
<td>Default setting 138, 283, 287</td>
</tr>
<tr>
<td>Action</td>
<td>Device delete 212</td>
</tr>
<tr>
<td>Action</td>
<td>Delta 235</td>
</tr>
<tr>
<td>Action</td>
<td>Device discovery method 105</td>
</tr>
<tr>
<td>Action</td>
<td>Device discovery method 105</td>
</tr>
<tr>
<td>Action</td>
<td>Device documentation 131, 214, 291</td>
</tr>
<tr>
<td>Action</td>
<td>Device information 193</td>
</tr>
<tr>
<td>Auto Layout</td>
<td>Device name 114, 125, 308</td>
</tr>
<tr>
<td>Auto Layout</td>
<td>Device password 291</td>
</tr>
<tr>
<td>Auto Topology</td>
<td>Device Signal 238</td>
</tr>
<tr>
<td>B</td>
<td>ED</td>
</tr>
<tr>
<td>Background</td>
<td>Distributed Component Object Model 181</td>
</tr>
<tr>
<td>Background</td>
<td>DNS 114</td>
</tr>
<tr>
<td>Background image</td>
<td>Domain 114, 113, 113, 113</td>
</tr>
<tr>
<td>Bandwidth</td>
<td>Domain Name Server 114</td>
</tr>
<tr>
<td>Basic settings</td>
<td>Domains 51</td>
</tr>
<tr>
<td>Browser</td>
<td>Draw 113</td>
</tr>
<tr>
<td>Bubble help</td>
<td>Duplex 95</td>
</tr>
<tr>
<td>Buffer size</td>
<td>E-mail 267</td>
</tr>
<tr>
<td>C</td>
<td>EULA 359</td>
</tr>
<tr>
<td>Certificate</td>
<td>Edit mode 44, 77, 209</td>
</tr>
<tr>
<td>Component detail</td>
<td>EDS 288</td>
</tr>
<tr>
<td>Configuration signature</td>
<td>EDS file 289</td>
</tr>
<tr>
<td>Connection</td>
<td>Electronic data sheet 288</td>
</tr>
<tr>
<td>Connection</td>
<td>Email 306</td>
</tr>
<tr>
<td>Connection line</td>
<td>Email configuration 306</td>
</tr>
<tr>
<td>Connection properties</td>
<td>Errors 98</td>
</tr>
<tr>
<td>Connection status</td>
<td>EtherNet/IP 107, 224</td>
</tr>
<tr>
<td>Contents register</td>
<td>Event 98, 266, 268, 279, 281, 323</td>
</tr>
<tr>
<td>Copy</td>
<td>Event display 279</td>
</tr>
<tr>
<td>Ctrl+E</td>
<td>Event line 66, 79</td>
</tr>
<tr>
<td>Date format</td>
<td>Event list 66, 192, 206, 279, 304</td>
</tr>
<tr>
<td>Default device icons</td>
<td>Event log 82</td>
</tr>
<tr>
<td>Default icon</td>
<td>Event log file 98, 279</td>
</tr>
</tbody>
</table>
Index

Exit 207, 208
Export 206

F
FAQ 379
FDB 217
File Selection Dialog 200
Filter 268
Fingerprint 157, 157
Firewall 193, 193, 193
Firewall rules 149
Font 283, 283
Font size 286
Foreground 287
Forwarding Data Base 217
Free version 59, 210
Frequency of requests 106
Frequency of the requests 261

G
Gateway 298, 321
Gateway IP address 125
GCM server 193
Geographic location display 195, 195
Geographical location 244
Geographical location view 244, 306
GPS 195
Graphical user interface 325
GREYHOUND 260

H
HiDiscovery 224, 260
HiMobile access to Industrial HiVision 264
History 227, 233, 245
Hosts file 114

I
I'm alive 281
ICMP 173
Icon 107, 107
Icon file 289
Icon size 283
Identification 321
Import 269
Initial setting 149, 298
IOS 193, 193
IP Address 321
IP address 105, 111, 125, 260
IP address prefix 298
IP address range 106
IP configuration 47, 125, 321

K
Key 158

L
Language 278
LDAP 44
License 46, 51, 59, 210
License Agreements 359
License files 204, 205
License key 276
Lightweight Directory Access Protocol 44
Line thickness 284
Load backup 205
Location display 195, 195
Location view 244
Log file 280
Log statistics 241
Login name 44
MAC address 105, 108, 260, 288
Main window 66
Management IP address 114
Manual 355
Microsoft Push Notification Service 193
Mobile application 192
Mobile device 311, 311
Mobile devices 192
Modbus/TCP 108, 224, 288
Module number 114
Monitor 245, 248
MONO 2.0 349
Moving 117
MTBF 235, 348
MTTR 235, 348

N
Name 114
Names 307
NAT 310
Navigation field 66
Navigation help 355
Netmask 321
Network card 298
Network load 170, 179, 180

libmono 349
<table>
<thead>
<tr>
<th>Network management interface</th>
<th>103</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network mask</td>
<td>125, 261, 298, 315</td>
</tr>
<tr>
<td>Network plan</td>
<td>109</td>
</tr>
<tr>
<td>Network Scan</td>
<td>259, 260</td>
</tr>
<tr>
<td>Network scan</td>
<td>106, 346</td>
</tr>
<tr>
<td><strong>O</strong></td>
<td></td>
</tr>
<tr>
<td>Object identifier</td>
<td>300</td>
</tr>
<tr>
<td>OID</td>
<td>174</td>
</tr>
<tr>
<td>Online help</td>
<td>75, 355</td>
</tr>
<tr>
<td>OPC</td>
<td>48</td>
</tr>
<tr>
<td>OPC server</td>
<td>300</td>
</tr>
<tr>
<td>OPC service</td>
<td>181</td>
</tr>
<tr>
<td>OPC write command</td>
<td>293</td>
</tr>
<tr>
<td>Open</td>
<td>203</td>
</tr>
<tr>
<td><strong>P</strong></td>
<td></td>
</tr>
<tr>
<td>Password</td>
<td>44, 154, 286, 291, 294, 295, 296</td>
</tr>
<tr>
<td>PDF Viewer</td>
<td>306</td>
</tr>
<tr>
<td>Ping</td>
<td>224, 306</td>
</tr>
<tr>
<td>Ping server</td>
<td>302</td>
</tr>
<tr>
<td>Polling</td>
<td>177, 179, 179, 237, 364</td>
</tr>
<tr>
<td>Polling interval</td>
<td>179, 260, 281</td>
</tr>
<tr>
<td>Port Names</td>
<td>114, 308</td>
</tr>
<tr>
<td>Port number</td>
<td>114, 296</td>
</tr>
<tr>
<td>Port security</td>
<td>158, 159</td>
</tr>
<tr>
<td>Prefix</td>
<td>298</td>
</tr>
<tr>
<td>Print</td>
<td>207</td>
</tr>
<tr>
<td>Process visualization</td>
<td>181</td>
</tr>
<tr>
<td>Product image</td>
<td>283</td>
</tr>
<tr>
<td>Product-Specific Modules</td>
<td>72, 247</td>
</tr>
<tr>
<td>Program</td>
<td>27</td>
</tr>
<tr>
<td>Project database</td>
<td>204, 205</td>
</tr>
<tr>
<td>Properties</td>
<td>221, 227, 233</td>
</tr>
<tr>
<td>Protocol</td>
<td>224</td>
</tr>
<tr>
<td>Protocol port</td>
<td>296</td>
</tr>
<tr>
<td>PSM</td>
<td>72, 247</td>
</tr>
<tr>
<td>PSM Manager</td>
<td>72, 247</td>
</tr>
<tr>
<td>Push Notification</td>
<td>167, 311</td>
</tr>
<tr>
<td><strong>Q</strong></td>
<td></td>
</tr>
<tr>
<td>QR code</td>
<td>193, 194</td>
</tr>
<tr>
<td><strong>R</strong></td>
<td></td>
</tr>
<tr>
<td>RADIUS</td>
<td>45</td>
</tr>
<tr>
<td>Realistic</td>
<td>283</td>
</tr>
<tr>
<td>Redundant network management system</td>
<td>43</td>
</tr>
<tr>
<td>Refresh</td>
<td>164</td>
</tr>
<tr>
<td>Refresh VLAN</td>
<td>240</td>
</tr>
<tr>
<td>Registration code</td>
<td>277</td>
</tr>
<tr>
<td>Remote access</td>
<td>33, 292</td>
</tr>
<tr>
<td>Remote Authentication Dial-In User Service</td>
<td>45</td>
</tr>
<tr>
<td>Repetition</td>
<td>296</td>
</tr>
<tr>
<td>Reporting</td>
<td>72, 170, 236, 248</td>
</tr>
<tr>
<td>Request interval</td>
<td>261</td>
</tr>
<tr>
<td>Restart</td>
<td>144</td>
</tr>
<tr>
<td>Retry block</td>
<td>304</td>
</tr>
<tr>
<td>Roaming</td>
<td>117</td>
</tr>
<tr>
<td>Rogue device</td>
<td>161</td>
</tr>
<tr>
<td>Running mode</td>
<td>77</td>
</tr>
<tr>
<td><strong>S</strong></td>
<td></td>
</tr>
<tr>
<td>Save</td>
<td>129, 203, 204</td>
</tr>
<tr>
<td>Save backup</td>
<td>204</td>
</tr>
<tr>
<td>SCADA</td>
<td>181</td>
</tr>
<tr>
<td>Scan Network</td>
<td>125</td>
</tr>
<tr>
<td>Scan rate</td>
<td>180, 302</td>
</tr>
<tr>
<td>Scheduler</td>
<td>72</td>
</tr>
<tr>
<td>Scheduling</td>
<td>252</td>
</tr>
<tr>
<td>Search function</td>
<td>355</td>
</tr>
<tr>
<td>Security</td>
<td>40, 154</td>
</tr>
<tr>
<td>Security lock-down</td>
<td>158</td>
</tr>
<tr>
<td>Security status</td>
<td>184</td>
</tr>
<tr>
<td>Security status display</td>
<td>155</td>
</tr>
<tr>
<td>Security-Status</td>
<td>97</td>
</tr>
<tr>
<td>Server</td>
<td>33</td>
</tr>
<tr>
<td>Server IP Address</td>
<td>33</td>
</tr>
<tr>
<td>Service</td>
<td>26, 81, 200, 207, 292, 302</td>
</tr>
<tr>
<td>Service technician</td>
<td>357</td>
</tr>
<tr>
<td>Signal</td>
<td>321</td>
</tr>
<tr>
<td>Signature</td>
<td>42</td>
</tr>
<tr>
<td>Smartphone</td>
<td>192</td>
</tr>
<tr>
<td>SMS</td>
<td>266</td>
</tr>
<tr>
<td>Software Backup</td>
<td>30, 31</td>
</tr>
<tr>
<td>Sound</td>
<td>167, 266</td>
</tr>
<tr>
<td>Speed</td>
<td>284</td>
</tr>
<tr>
<td>SSH</td>
<td>306</td>
</tr>
<tr>
<td>State on delivery</td>
<td>162</td>
</tr>
<tr>
<td>Status</td>
<td>162, 283, 287</td>
</tr>
<tr>
<td>Status configuration</td>
<td>114, 117, 162</td>
</tr>
<tr>
<td>Status determination</td>
<td>112</td>
</tr>
<tr>
<td>Status propagation</td>
<td>112, 165, 221, 234</td>
</tr>
<tr>
<td>Status symbols</td>
<td>137</td>
</tr>
<tr>
<td>Subdomain</td>
<td>46</td>
</tr>
<tr>
<td>Subdomain interface</td>
<td>292</td>
</tr>
<tr>
<td>Subdomain password</td>
<td>292</td>
</tr>
<tr>
<td>Subdomains</td>
<td>51, 54, 56, 292</td>
</tr>
<tr>
<td>Superdomains</td>
<td>54, 292</td>
</tr>
<tr>
<td>Switched-on message</td>
<td>105, 259</td>
</tr>
</tbody>
</table>
Index

Symbol 137, 138
SysOID 107, 288, 288
System control 27
System language 278
System Object Identifier 107, 288, 288, 288
System requirements 20, 363
System resources 176

T
Table of contents 355
Tablet PC 192
Technical Questions 379
Telnet 306, 344
Temperature 179
Temperature monitoring 179
Text display 286
Threshold value 232
Time 81
Timeout 296
Tool 325
Tool bar 66, 72
Topology 87
Topology Discovery 117, 217
Training Courses 379
Trap 59, 105, 163, 245, 259, 259
Trap destination 323
Trap destination address 59, 298
Traps 364
Trial period 59, 210

U
Ubuntu 349
Unacknowledged events 98
Update 32
User authorizations 44, 48
User defined properties 317
User Management 263
User name 294
User-configurable action 271
User-defined property 173, 173

V
Value 222, 227
Version 355
VLAN membership 240
VRRP 220

W
Warnings 98
Web interface 342
Web server 193, 193
Windows Phone 193
Wireless client 220
Wireless Local Area Network 117

Z
Zoom 86, 244
What is your opinion of this manual? We are always striving to provide as comprehensive a description of our product as possible, as well as important information that will ensure trouble-free operation. Your comments and suggestions help us to further improve the quality of our documentation.

Your assessment of this manual:

<table>
<thead>
<tr>
<th></th>
<th>Very good</th>
<th>Good</th>
<th>Satisfactory</th>
<th>Mediocre</th>
<th>Poor</th>
</tr>
</thead>
<tbody>
<tr>
<td>Precise description</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Readability</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Understandability</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Examples</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Structure</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Completeness</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Graphics</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Drawings</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Tables</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

Did you discover any errors in this manual? If so, on what page?
Dear User,
Please fill out and return this page

▶ as a fax to the number +49 (0)7127 14-1600 or
▶ by post to

Hirschmann Automation and Control GmbH
Department 01RD-NT
Stuttgarter Str. 45-51
72654 Neckartenzlingen
D Further Support

- **Technical Questions**
  For technical questions, please contact any Hirschmann dealer in your area or Hirschmann directly.
  You will find the addresses of our partners on the Internet at

  A list of local telephone numbers and email addresses for technical support directly from Hirschmann is available at
  [https://hirschmann-support.belden.eu.com](https://hirschmann-support.belden.eu.com).

  This site also includes a free of charge knowledge base and a software download section.

- **Hirschmann Competence Center**
  The Hirschmann Competence Center is ahead of its competitors:
  - **Consulting** incorporates comprehensive technical advice, from system evaluation through network planning to project planning.
  - **Training** offers you an introduction to the basics, product briefing and user training with certification.
    The current technology and product training courses can be found at
    [http://www.hicomcenter.com](http://www.hicomcenter.com)
  - **Support** ranges from the first installation through the standby service to maintenance concepts.

  With the Hirschmann Competence Center, you have decided against making any compromises. Our client-customized package leaves you free to choose the service components you want to use.
  Internet:
  [http://www.hicomcenter.com](http://www.hicomcenter.com)